teamviewer.com link icon
or
Ask The Community

LAN access not working

Today I enabled LAN access on a Teamviewer install that's been working for years without issue. When I enter the IP address in the Partner ID and select Connect I get a pop up for "Unable to connect. Could not connect to partner". Same issue trying to coneect from PC A to B or B to A. What am I missing.

Tagged:

Comments

  • mLipok
    mLipok Posts: 781 ⭐Star⭐

    Do you have enabled only LAN connection or also Internet connection.
    Try to enable only LAN and say what you see.

    Regards,
    mLipok , AutoIt MVP
  • If that gets LAN working what recommendation(s) do you have to get both working? LAN w/out also having internet does me no good. 

  • Vatsilidis
    Vatsilidis Posts: 655 ⭐Star⭐

    Hi @gmagdna 

    Did you read this article about LAN configuration of TeamViewer?

    If is possible, could you provide some details about the network configuration of both pc's?  I'd like to see the IP Address v.4, the subnet mask, the Gateway and the network group name.

    In order to have both pc's talking direct within a LAN, it must belong to the same sub-network inside your LAN and (depends - not always) to the same network group name, and this will be easy to check it by this IP v.4 settings. The network group name can been seen from computer properties.

    One more question please, are you using some specific firewall witch could have strict rules? If yes, which one?

  • Hello @Vatsilidis 

    As with @mLipok, it's very helpful to udnerstand where you're headed with a question. I have read the article you referenced, more than once. It would be helpful to understand what in that areticle you think I might have missed, or which is critical to recheck. It is very basic in that implies connecting via a LAN, while leaving internet intatct, is as simple as selecting Accept for "Incoming LAN connections" then enterinmg the IP as the Partner ID. The computers have no issue connecting with each other outside of TV. They are on the same subnet, Gateway and I assume by "group name" you mean Workgroup, and they are both on the same one. Again, they connect outside of TeamViewer. I am very competent in how to configure my network, and TV would have me believe it' simple to connect on my LAN. To confirm I'm getting the most relevant responses - you succesfully connect between two computers on a LAN?

    As for the firewall - Win10 Defender.

  • mLipok
    mLipok Posts: 781 ⭐Star⭐

    So it sounds strange.

    I have one more question before I recomend to you to contact TV support and send them logs (on their request).

    There was a time when I had a problem with standard TV App (instaled).
    Did you try to use TV Portable version as a hosting/remote APP  , or even better Team Viewer Host version ?

     

    Regards,
    mLipok , AutoIt MVP
  • DomLan
    DomLan Posts: 490 ⭐Star⭐

    Hi @gmagdna,

    I don't want to overlap with other friends ( @mLipok and @Vatsilidis  ) who are already following you, but perhaps it would be useful to understand from the Teamviewer logs of one of the machines (better of both), if there are indications on why the connection is not possible.

    Regards

    Domenico Langone
    MCSD: App Builder
    Did my reply answer your question? Accept it as a solution to help others.
    Find this helpful? Say thanks by clicking on the Thumbs Up button.
  • I haven't tried TV Portable and from what I see it requires a licensed account because the license must be entered in Portable for it to work. As for Host, haven't  tried that either but it also looks to require that at leats one PC have a license, and it gets installed on a server, and I'm not looking to install another program. The free full version has the fucntionality so that's what I'm looking to get runing. As for logs, there's nothing in them which makes sense because somewhere I saw that connecting on LAN doesn't trigger the conneciton log. So to be clear, you are connecting to over LAN between two PCs? On TV15 but have a license and use either Portable or Host?

  • @DomLan the logs don't show anything. I just replied to @mLipok that I read somewhere that LAN connections are not logged. I can't remember where I read that. You make a succesful connection over LAN?

  • Vatsilidis
    Vatsilidis Posts: 655 ⭐Star⭐

    Hi@gmagdna 

    Well, we all are trying to help here and I believe you have three of the very knowledgeable community members in your post (@DomLan , @mLipok  and me) trying to solve this strange issue.

    As a continue to yesterday conversation, I made some tests today with two Windows PC's within my bussiness network, with several settings changing, and here is what I found which it seems to fit with your issue and I got the same error message.

    At the follwing screenshots you can see after each picture and after the comments for each one. My apologies for the Greek Language on the whole menus to the screenshots but I have been mark with red color each importand point.

    At first the setting to both pc's is to accept local connections not exclusively.

    1 PC1-TO-PC2-1st connection.png

    To the 1st image I connected

    FROM PC1 with LAN IP Address 192.168.0.23

    TO the PC2 (Lan IP 192.168.0.153) ,   

    at this morning and Everything went fine, I had a succesfull LAN connection.

     

    2 PC1-PRIVATE_NETWORK-33.jpg

    During this succesfull connection as shows in the 2nd image above, the type of Local Network Connection Profile of the PC2  was Public. At the same time the Local Network Connection Profile of the PC1  was private.

    But after changed the Local Network Connection Profile of the PC2 to be Private Network, then i got the same error you describe, "Unable to connect. Could not connect to partner", but in Greek.

    I had two different Private Networks.

     

    3 PC1-TO-PC2-FAILURE.png

    The 3rd image above shows the error i got after changing that.

     

    2.1 PC1-PRIVATE_NETWORK2222.jpg

    After I change the Local Network Connection Profile of the PC2 back to public, the two PC's connected again like the first time.

    I know you know where all this settings are, but I put the screenshots to get other people helped by this post in the future.

    Please if you could check this settings, update about what is happened.

    Best regards to all

     

     

  • @Vatsilidis I understand three people are trying to help. My issue is exactly what you've now confirmed - no one was successfully operating the feature I was asking about so the help was not based on experience. Instead it was shooting in the dark (if you're familiar with the term) in the hopes a solution was stumbled upon. That is why I asked each of you if the feature was successfully running on your LAN. If Yes then you could each say it worked as in the article, or that it took some tweaking and so what was required.

    Now that you've tested the feature personally you've identified a possible solution, which in your case seems to point to TV firewall permissions being different for Public and Private networks. I know that in a default installation on Win 7, 8 and 10 TV sets itself in Defender as allowed on only Public - seems a poor choice but it's what I've seen. Thanks You for actually trying the feature to offer assistance  

    I had re-checked that all settings are as they should be to allow LAN access, and they were. However, I tried one PC on Public and the other on Private, then swapped the settings, but no success.

     

     

  • Vatsilidis
    Vatsilidis Posts: 655 ⭐Star⭐

    ok, could you give it a try with both in public profile setting?

  • ramosvacca
    ramosvacca Posts: 1 Newbie

    With two windows 10 vm

    As @Vatsilidis says, when the host machine configuration is set to "Private" as Network Profile, it stops accepting incoming connections by IP in "only LAN" mode.

    When the host Network Profile is set to "Public" again, it starts working an accepts incoming connections by IP.

    Guest machines can be set to either "Public" or "Private".

    NOTE: More interesting, if host machine Network Profile is set to "Private" and it stops working, you can change incoming connections to accept both "LAN and Internet" and connect to the host by "Partner ID" as if you were connecting from the internet, TeamViewer will find the route through LAN network, at least that is how it worked for me on a router subnetwork with its own DHCP.