teamviewer.com link icon
or
Ask The Community

Sign-in Greyed Out and No ID & Password

I have a macbook pro late 2015 running High Sierra and I installed latest version of Team Viewer 15.3.2682 on it.

I don't have an ID (& Password of course) for the machine, neither I can log into my account.  I had version 14 installed earlier with same issue and never got round to fix it and kept using **Third Party Product**.  Now I thought to give this a shot - see if this is fixable.

Thanks in advance.

Screen Shot 2020-03-17 at 16.26.44.pngScreen Shot 2020-03-17 at 16.39.10.png

Comments

  • Esther
    Esther Posts: 4,112 Former Community Manager

    Hi @cooldharma 

    It looks like your TeamViewer can´t connect to the internet. Maybe your firewall is blocking it? You could e.g. whitelist *.teamviewer.com in your firewall.

    Also, this article might help you: Which ports are used by TeamViewer? 

    Looking forward to hear your feedback,

    Esther

    Former Community Manager

  • Hi Esther, thanks for responding.

    I have 2 firewalls.  1st one is inbuilt in Mac & 2nd one is Little Snitch.  Team Viewer is in the whitelist of both of them.  I just tried Team Viewer after stopping both firewalls, but issue still persists.

  • Esther
    Esther Posts: 4,112 Former Community Manager

    Hi again,

    can you give it a try to restart the TeamViewer service after having added it to the Whitelist of your firewall?

    Thanks, Esther

    Former Community Manager

  • Team Viewer has been in whitelist for very long time.  I didn't add it just now.  So, there has been numerous restarts after it's been added to the whitelist.  Also, I had Team Viewer 14 till today, which I uninstalled by going to Preferences - Advnace - Uninstall (also checkbox 'delete config files' was selected).  Then I had a clean intall of TV 15 latest version, but it is giving me same problem that I had faced with version 14.

  • @Esther   Do you have any more suggestions to my issue??

  • Esther
    Esther Posts: 4,112 Former Community Manager

    @cooldharma I am very sorry, nut unfortunately not really. I just know that something is blocking TeamViewer to access the internet. We need to find the blocker and remove/adjust it.

    Maybe we can ask one of our Stars like @Vatsilidis for help. The Stars have a strong technical background. Vatsilidis - do you maybe have an idea @cooldharma could try?

    Thanks and best,

    Esther

    Former Community Manager

  • Vatsilidis
    Vatsilidis Posts: 655 ⭐Star⭐

    Hi @cooldharma  and thank you @Esther  for the invitation and the acknowledgment.

    As a first step, I'd like to ask @cooldharma  how did you go from version 14 to version 15? 

    It was trough an update? Did you uninstall version 14 and then install version 15?

    I am asking these important details because as you wrote, you had version 14 installed earlier with the same issue and never got round to fix it. If you didn't uninstall the previous version with the preferred way to make a new fresh installation, then I strongly recommend you begin by doing this.

    To make a full uninstall of the app in macOS, you must go to the Preferences > Advanced > down you will see uninstall but you must select and the option to remove configuration files.

    Screenshot 2020-03-03 16.05.23-FINAL.jpg

    After the uninstall, please reboot your Mac, then download the latest version and install it as well. 

    I'll be here to let me know if this solves it for you or if it isn't!

    Thank you and best regards

  • @Vatsilidis Thanks for chipping in.  As you can see from the 5th message in this thread, I have done exactly what you suggested here.  I did this by following a page on teamviewer website.  Only when it didn't work, I decided to post my issue here.  So, please let me know if you have any other suggestions.

    Thank again.

  • Vatsilidis
    Vatsilidis Posts: 655 ⭐Star⭐

    Hi

    I miss it that you already have done that.

    Ok then, after that to me this it seems like the app doesn't working as it should be, either because haven't given the access permissions from the Privacy menu either your ports are closed or blocked for some reason and you need to perform a port sann to find out what is happening (if the ports are open and listening.

    About the firewall, have you mentioned that you are using 2 different firewalls? There is a case that they could conflict between them. The most preferred way is always using one firewall, not two or three, just to avoid conflicts between them.

    Thank you and best regards

  • As I earlier said, the app is whilelisted in both the firewalls and I tried multiple times running the app with both the firewalls off too.

    My system is 10.13.6 High Sierra, so the link you shared about giving permission does not apply, but I did check in "Security & Privacy" - Privacy and all the permissions, but the app hasn't requested any permission there.  Is it supposed to anywhere there?

    I don't understand ports and all, so I don't know what to do there.

     

  • Vatsilidis
    Vatsilidis Posts: 655 ⭐Star⭐

    ok, (this is very importand) your system Siera is in the limits of the compatibility list for version 15.3 that you are using. Could you update it to the latest OS Mac supports?

    After the update, you can apply the following, if again doesn't work

    Go to Privacy settings and give manually the permissions that needed?

    If the app doesn't appear to check the box next to it, then press the + button to add it.

    About the firewalls, it should not exist two on the same operating system, even if is disabled. Remember that exist one third installed, the preinstalled from the macOS, and even if it is disabled, they have applied settings on the apps which have to do with rights and other very crucial details. Disabling a firewall is not necessary means that it returns all the settings has applied in other apps to default. I know that security is a very important aspect, but please give importance to this, if you use an external firewall, choose one and only the best you can have.

    Best regards

  • umident
    umident Posts: 1 Newbie

    I think the problem is because of @cooldharma 's selecting "accept exclusively" for "Incoming LAN connections" setting. I had the same problem and after I read @Esther 's post saying that TeamViewer is somehow unable to connect to Internet, I changed the setting on my mac from "accept exclusively" to "accept" and now I am able to sign in.