link icon
Ask The Community

Teamviewer 15 cannot be installed correctly on Mac OS 10.14.6 - Helper tool installation seems to fa

TV version 15.4.4445

First of all it is not possible to configure TV to start at system start.

Every time i start TV15 on Mac OS 10.14.6 after a reboot Teamviewer wants to install a HelperTool. When i confirm the installation then Teamviewer does not start at all. In i can see that TV is running.

When i cancel the installation of the Helpertool then TV starts, but it is not possible to configure it to start at system start. When i try to check that option in the StartScreen of TV then TV wants again to install the HelperTool. If i confirm the installation (including entering my Root password) then  the option is unchecked again after 1 or 2 seconds.If i try to enable that option in the program preferences, then TV also wants to install the HelperTool. After confirmation (and entering Root password..)  the option stays checked until i leave the preferences. When going back to the preferences the option is unchecked again. 

Working with TV is possible so far, but it´s not possible to start TV automatically with the system start. 

I´ve run already through the steps of unistalling TV (both automatically from within TV and also manually) and reinstalling TV again after a reboot. So that does not help.

I´ve tried even without  any Anti-Virus/Firewa

If you need any debug information please let me know. 

I had this problem already with the previous version of TV15.




  • Vatsilidis
    Vatsilidis Posts: 655 ⭐Star⭐

    Hi @matthiasr 

    It seems that something has been stuck in your Mac's installation folders.

    During uninstall from settings > Advanced menu, did you removed also and the Configuration files, or you just run the uninstall process? 

    By which way did you try to set up TV to autostart during system boot?

    One last question, please, your mac doesn't support the latest macOS updates? Now is ready the 10.15.4 version.

    Best regards


  • Hi and thanks for our answer.

    Sorry, i forgot to mention that i did the uninstall including the configuration files.

    To let Teamviewer start at system start i tried both: enabling it at the start screen of TV  and also in the preferences of TV. Both leads TV to popup the HelperTool installation where one has to enter the root password. What happens then was described in my previous post.

    Regarding Mac OS. Upgrading to Catalina at this time is not an option for me. As you might know there is plenty software out there which is not yet available as 64bit or where the 64bit version is still buggy. I am using a Mac OS which is one version behind, so that should not be the cause that TV behaves like this, should it?


Sign In or Register to comment.