teamviewer.com link icon
or
Ask The Community

Drag And Drop File Transfer Stopped Working

I'm using TV 15.4.8332 on both my local and remote Windows PCs (local = Win10, remote=Win7). I used to be able to drag and drop files in both directions. Now, I can only drag and drop from my local PC to my remote. If I try to do it in the other direction, it does not work. It just leaves the file at the edge of the remote PC desktop. I have dual monitors on my local PC if that makes any difference. This worked before I upgraded to the most current version. Any help will be greatly appreciated.

Tagged:

Comments

  • Esther
    Esther Posts: 4,089 Former Community Manager

    Hi @clash14 

    Thanks for your post!

    May I ask which version you were using before? So - basically in which version did it work? This makes it easier for the team to find the issue ?

    Thanks and best,

    Esther

    Former Community Manager

  • clash14
    clash14 Posts: 3

    Thanks for your reply. It was version 14.X but I'm sorry I don't remember the numbers following the decimal point.

  • Esther
    Esther Posts: 4,089 Former Community Manager

    HI @clash14 

    That is already very good info! I´ll pass this to the right development team and ask them to have a look!

    Thanks for bringing this ? up!

    Esther 

    Former Community Manager

  • clash14
    clash14 Posts: 3

    @Esther wrote:

    Thanks for bringing this ? up!

    No luck on this? I can upload a video showing the problem in action if that's any help.

  • Esther
    Esther Posts: 4,089 Former Community Manager

    HI @clash14 

    Thanks a lot!

    That would be a great help and I am 100% sure the devs are appreciating it a lot to get such amazing support!

    Thanks and have a fantastic day,

    Esther

     

     

    Former Community Manager

  • Kerstin_PO
    Kerstin_PO Posts: 77 Staff member 🤠

    Hi @clash14 ,

    with the next release (TeamViewer 15.7) this bug should finally be fixed. If you should still encouter the problem with that version, please give us feedback.

    Thanks for bringing up this issue and helping us steadily to improve the quality.

    I'm sorry for any inconvenience!

    Best,

    Kerstin

    Product Owner TeamViewer Core
  • 2cv
    2cv Posts: 1

    hi - Is there any update on this?

    I seem to have the same issue, so I'm adding to this thread.

    I have 15.8.3 running on both systems. win10 local and win7 remote. I can drag from win10 to win7 but not from win7 to win10. (I don't know if I ever dragged files from the win7 system.)

    I can transfer another way, but dragging is the most efficient for me!

    Thanks for any help that you can offer!

  • TheFatController
    TheFatController Posts: 4 ✭✭
    edited October 2021

    15.22.3 no longer permits drag and drop between two Win 10 PCs on the same desk.

    At the edge of the screen, it tries to hide "under" the edge of the desktop.

    Drag n' Drop is enabled on all PCs.

    I have three "headless" PCs so TV is the monitor for activating applications or transferring files between the desktop PCs.

    The transfer is generally from remote to local but it would be nice to transfer between two "remote" units rather than using the local desktop as a transit hub.

    Using the "File Transfer" function is tedious and probably no more effective than using a USB thumb drive.

    Is there a fix in the pipeline?

  • Domswell
    Domswell Posts: 0 Newbie
    edited February 8

    Hello guys,

    i use teamviewer on my windows 10 computer and remote controll a mac (both with two monitors). I have the problem that every drag and drop action does not work.

    For example: i left click on a file and hold the left mouse button. I drag the file to a folder and if i release the mouse button, the file just stays at the cursor. It just behaves as i would still hold down the left mouse button. I can only end this by pushing ESC.

    I attached a video (sorry for poor quality) where you can see the issue. I left clicked on the file "code left" while holding the left mouse button down. I then dragged

    it to the folder "Logos" and released the left mouse button, but nothing happens. I then clicked right and left a couple times but as i said, the only way out it to push ESC.


    Thanks in Adavnce!



  • Deadmana
    Deadmana Posts: 1

    I'm having this exact same problem. It began to occur last month. Why hasn't this been fixed yet?

  • joaoserraseal
    joaoserraseal Posts: 4 ✭✭
    edited March 18

    Same here i had to restart the mac to make it work properly again

    I'm using a mac mini with no controls attached

    Mine its not just files, if you try to drag anything it get stuck to the cursor, for instance, a bookmark on chrome

  • TheConciergeTec
    TheConciergeTec Posts: 2 ✭✭

    Mac User Here:

    After struggling with this random sticky drag and drop issue for months and trying to resolve, I finally decided to try a complete uninstall of TeamViewer using the uninstall function under the Advanced tab, with the addition of deleting the configuration files, restarting, and re-installing the latest version. This has resolved the issue for me and will hopefully stay resolved.

    Preferences > Advanced (sub-tab) > scroll to the very bottom > choose "Also delete configuration files" > Uninstall then Restart your computer.

    May also work for Windows.

    I was on a 2014 MacBook Pro using macOS Mojave (10.14.6) when the issue started but just recently migrated to a 2021 MacBook Pro (M1) with macOS Monterey (12.3) and the issue persisted.

    I had reverted back to TeamViewer version 15.19.4 which seemed to resolve the issue temporarily, but randomly popped back up depending on client version of TeamViewer QuickSupport.

    Now on the latest version 15.28.5 as of March 27, 2022 and is seemingly stable with various older and newer versions of TeamViewer QuickSupport.

  • AmericanWick1973
    AmericanWick1973 Posts: 1

    Our company just began using TeamViewer for remote access. I'm also having an issue with drag and drop functionality. I did not have this issue prior to TeamViewer installation. Has anyone figured out how to troubleshoot? Wondering if uninstalling would fix.