teamviewer.com link icon
or
Ask The Community

Do you want to enjoy the new TeamViewer user interface for Windows?


Download the new version and let us know what you think about it! 👉 Please click here 👈

TeamViewer has different ID depending on how it is started

I've noticed it uses the ID in /etc/teamviewer/global.conf when I open a terminal through my desktop and run /opt/teamviewer/tv_bin/TeamViewer . For reproducibility, if I "ssh localhost" in the same terminal, set (and unset) all environment variables (though only the DISPLAY variable is required, I attempted to change all in order to troubleshoot the issue) to match the original desktop terminal and run the same command, I get a completely different TeamViewer ID. Across several computers, this behavior is repeatable (and very undesireable). How can I reliably (re)start TeamViewer over SSH (or in a script) in such a way that it uses the settings in global.conf? This issue occurs in TeamViewer 14 and 15.

Comments

  • Hicks
    Hicks Posts: 1 Newbie

    Same here. Any solutions?

  • longhongc
    longhongc Posts: 1 Newbie
    edited July 26

    I am facing the same problem. When I use SSH to start teamviewer the ID changes, causing me unable to connect with it.

    Eventually, I start the teamviewer by the command below through ssh instead of directly starting the program, and my problem is solved.

    sudo teamviewer --daemon start