link icon
Ask The Community

Commercial use - Connection time out



  • I just spoke to someone from teamviewer about the free version.  Since he was on the commercial side he gave me this option which didnt work for me.  Go to to reset the account.  He then hung up on me.  sooo Im done. I wont use team viewer anymore.  They are inconsistiant they aggravate me to ends now.  i would consider purchase a license, but their customer service is **bleep**, zero.  SO good bye.

  • I have sent request 3 times already this past montn and have been sent this email:

    "We are happy to inform you that your TeamViewer ID has been reset to “free”. After reviewing your request, we decided that your use case can be qualified as “personal...."

    I have uninstalled, rebooted, then reinstalled but it still keeps saying Trial version *expired*

    Yes, I have chosen Personal Use during intstallation. Yes, I have logged in to my account which is identified as Free on the web portal. 

    Please help. 


  • Proxi
    Proxi Posts: 1

    To whom it may concern,

    Due to Lock-down, I found myself assisting three individuals with computer issues. One of these users was assisting my Daughter log in and interact with her school's online learning platform. I have subsequently been flagged as a potential Business user and my account times out. Is there any way to correct this?

    I look forward to your response,

  • I just got Belder's reply can he not read... I keep trying to point out i have used teamviewer for many years for personal use only, its only because the new owners of the company want to try and force ever body to pay to use it that i am now being blooked from using it. I am one of those very stupid people that spent years recomending it to every body that made it so popular that is now being blocked. I would never ever consider recomending it to any body any more. And just to confirm as the community managers, dont seam to know what they are talking about if i ever used it to log in to my work computers i would get sacked i would loose my car my house and the company i work for would prosecute me. Now please get some body who can rad english to read my post thank you so much.

  • jt4242
    jt4242 Posts: 2

    I've had a weird experience.  I log onto my husband's account to fix up messes he makes in his computer.  From my desktop, there was no problem - I could remote access his PC.  But, when I tried from my laptop, I got the dreaded Teamviewer has detected commercial use.  This was using the same account to access his one account so the problem was not linked to an account.

    I tried everything - uninstalled Teamviewer, reinstalled, etc etc.  Same results.  So then I reinstalled Windows on the laptop and, after that, Teamviewer was fine.

    So, obviously, some setting gets left in after an uninstall.  If this happens again, is there something I can use to remove all traces of Teamviewer and do a real fresh install so that I don't have to go through the whole reinstallation again?  Hours and hours of working on this to get it working - I really love Teamviewer but this was crazy!!

  • You have to  get a clearance for every device you have it is not related to the account. I had been logging on using a tablet to chekc on some raspberry pi's and other machines - all non-commercial use. THe tablet gave me the warning message. I coincidentally had to rebuild the tablet and the message went away for about a month and then came back - I had to fill out the form specific to the teamviewer id for the tablet to get rid of the commercial use warning. (I also had to do it for all the raspberry pi's I was running!)

  • i got a mesaage from the teamviewer client that  they has marked my account due to they think i use it as corporate.. but now they prevents me from helping out my little brother in the other end of the country.


    what do i do?

  • I use TeamViewer to help to my parents and It shows a message that it is a commercial use detected. Unlock my account please!

  • jt4242
    jt4242 Posts: 2

    You're right!  I had forgotten - last time, when I had to send in the reset form,  I just remember the waiting and waiting and hating not having access to TeamViewer!

    Thanks!!  that makes more sense. 

    I still wish it wouldn't happen especially with no cause.  I'd rather pay a reasonable license fee (not the crazy price for the commercial version) and not have to deal with this - it's a super program but to go from free to $58 per month is a bit of a leap!.  I'd be willing to pay $5 per month - I don't use it that often but do need it when my daughter has PC problems or when I'm away and want to logon to my home PC.

  • I just filled out the stupid form again to prove it that they not looking.  The web sated that someone will get back to me in 24 hours.  Lets see, I'm not holding my breath. I'm looking for another means to get this done.  This is about 10 times i've filled out a form and waiting for nothing to happen. Also this time i listed most of the computers that i use.  Not sure if thats worth anything.   

  • I use Team Viewer free version to connect to my mom's Mac computer as she is 95 and cannot control her computer.
    In the last few days Team View has disconnected after a few minutes.
    team Viewer has been working wonderfully on our computers for years now.
    Suddenly, it is not working so well.
    I have updated Team Viewer on my mom's computer and my computer to the latest free version of Team Viewer.
    Can you tell me if there is a way that I can use Team Viewer on our computers so it does not disconnect after a few minutes?
    Thank you

  • as1959
    as1959 Posts: 1

    Dear TeamViewer support

    I am unable to connect remotely to my partner system using TeamViewer. 

    My Id-**Information removed as per Community Guidelines**

    Partner Id- **Please do not post TeamViewer IDs**

    I have attached the message that is displayed while trying to connect remotely to partner system. Please help me resolve this issue. 

    Thank you


  • I am using for personal, but it is saying commercial use is detected

  • I have started getting Commercial Use Detected on all my machines at home! This is crippling me as I have several devices across the house that I need to connect to remotely... namely: my HTPC in my living room, my laptop, my desktop (which I primarily use).

    Why is it detecting commercial use? Is it because I am working from home due to COVID? What other options do I have? I use the same desktop for both work and personal use...

    Please fix this!

  • MF_1234
    MF_1234 Posts: 0

    how much the Max time for one connection it PC in a non commerial use? i need to know ho long it will take before this message will show (maximum session duration to a partner teamviewer in non commercial use)

  • I just had this problem today too...I only use teamviewer a few times a month at most...for a friends computer and my spare computer that I run [email protected] for covid research on...I tried to connect to it today using my main computer from a friends house (different physical IP address, maybe this is why?) on my PC, and poof! it popped up, and now I can't stay connect for more than a minute.


    Pretty annoying, and (once again) poor programming on teamviewers part.

  • Yuri_T
    Yuri_T Posts: 1,990 Moderator

    Hi @MF_1234 ,

    Thank you for your post ?

    The free version of TeamViewer has a three-hour limit on its connections. This means each session will be disconnected after three hours. However you can always establish a new connection again immediately afterwards.

    Please note that licensed versions of TeamViewer do not have any time limit on their connections. If you have a need for unlimited connections, please consider purchasing a license. We will be happy to discuss our licensing options with you and give you a personalized quotation by our sales team.

    Hope this will be helpful.

    Kind regards,

    Community Moderator/ コミュニティモデレーター
  • tonyjp1
    tonyjp1 Posts: 1

    my account is a free account is being treated like it commerical account can i please get a account reset

  • bendksu
    bendksu Posts: 2

    My computer crashed and I had to have a new SSD card installed, so basically, I am working on a "new computer". When I try to connect with my friend via TeamViewer, I receive the following message:


    Connection blocked after timeout. Your license limits the maximum session duration to a partner, immediate reconnects are blocked. Please try later or upgrade your license. Connections to this partner will be blocked until 08:12.


    But each time I try to connect again, the time is moved up. Why can we not connect?

  • xs1
    xs1 Posts: 11

    Guys, i have used teamviewer for more years than i can remember... early 2000s sometime. I have 3 PC's (total). 2 of which i monitor once a day for a brief minute..  1 pc is now only letting me connect for 10 seconds before it boots me off, the other i cannot connect to at all because it says the "trial has expired"?? Im not using either box commerically..  One is my content server and the other i have listed is my mothers PC, I have to help her & my daughter with every now and again.. 

    As much as i appreciate this program being free, its becoming almost unusable. Id be willing to pay monthly for a private account, but the commercial accounts are way to expensive for basic home use. 

    Please help!

    DOWNLOAD Mbps: 919.48
    UPLOAD Mbps: 942.24
  • thanks for your reply

    just i need to know how much time i can use the team viewer free lience before the following message appear :

    connection blocked after timeout

    your license limits the maximum session duration to a partner. immediate reconnects are blocked

  • xs1
    xs1 Posts: 11

    Pc 1 :  Fine

    PC2:   says commercial use detected, but the license says free usage; disconnects every 10 seconds

    PC3:   says trial version "expired"  for some reason and wont connect to or be conected to by any other pc. 

    Im not sure why the changes, but i cannot use this program at all :(

    DOWNLOAD Mbps: 919.48
    UPLOAD Mbps: 942.24
  • Facing the same problem here since yesterday

    I'm free user and has set up TeamViewer with 

    Free license (non-commercial use only) - Dhruv Saxena

    WhatsApp Image 2020-08-29 at 10.33.51 AM.jpeg

  • imjhen
    imjhen Posts: 1

    I have never used TeamViewer for a commercial purpose. I mainly use it on my laptop on main level of my home to access my desktop upstairs. Sometimes my brother accesses my computer remotely to help me with a problem. This is the extent of my usage.

  • same happens for me it **bleep** and seems like i cant get any help

  • High565
    High565 Posts: 3

    It is TeamViewers' new business model.   You don't make money on free services, just on paid (aka. commercial) subscriptions.  Suggest you try one of the other still free services.

  • xs1
    xs1 Posts: 11

    I cant even connect to my home server at all now.. literally going to have to hook up a keyboard and mouse again to go use it when needed. This a major PITA >.<  I se up this box specifically for remote access... 


    DOWNLOAD Mbps: 919.48
    UPLOAD Mbps: 942.24
  • I never had an issue logging into my computer till today. I have teamviewer installed on a few different devices. I went out of town for the week and my newish laptop wont connect to my personal computer.

    Everytime I go to log in it says commerical use detected and times me out. it says to try again in a minute to which it fails and resets timer. My phone connects fine but that is such a small screen to get what I need.

    I read other posts of people submiting a ticket but I do not see how to.

  • @Esther 

    You received an incorrect answer. I get the same time limit. In fact, it now states that it will terminate after 5 minutes. Which when dealing wirth a family member and getting them to get you the code and get connected, takes exactly 4 minutes and 59 seconds... This is a REALLY stupid addition to their already difficult to use software.

    I can't think of a more complicated UX/UI, pricing or anything. I am truly baffled why people are using this. 

  • I connect to a machine and then get kicked off after 5 minutes.

    There is a popup stating:

    "TeamViewer Free does not allow conections to customized TeamViewer clients with your own company logo. Please use the basic Quicksupport or the full version.

    This session wil be terminated after 5 minutes."

    I am not sure what that is even supposed to mean. I downloaded the client, I have them download the client and now this....

Sign In or Register to comment.