link icon
Ask The Community

Invalid Token / Paid Activation issue

This is newly paid License. TeamViewer Management console shows "Free" under username but when you click "Edit Profile" it loads to and shows ACTIVE for "Remote Access Base: 3 devices"

In  TeamViewer app it shows as Free/Trial Version but under "TeamViewer Options > Computers&Contacts it shows "Activated License"

Following the activation email and clicking the link again shows Invalid Token.

If this is truly activated why won't it act like it.

Please assist, Thank you.



  • Support.teamviewer autodirects to community.teamviewer currently in some sort of cruel joke; same with "get help" so a normal ticket can't be raised currently. Tried calling support - phone support technically isn't covered in this plan but sales (my third rep after the second disconencted)  transferred me over to techsupport anyways. After waiting 18 back in queue I finally got through  and then as he started to speak after he got my invoice # it sounded like the line muted and then they "disconnected" again after a few seconds.

    Someone needs to get back to me on this ASAP.

  • Fiona_G
    Fiona_G Posts: 689 Staff member 🤠

    Hi @DeputyClerk,

    Thank you for your post. we apologize for your negative experience.

    Regarding the support ticket, you have to submit a ticket with your licensed account, if you have not activated your license into the account, it comes to the community page. If you like, please send over your invoice number and email address via a private message. We would like to investigate it further for you.


    I look forward to your private message.


    Best regards,



  • Dear Teamviewer support!

    I have similar issue with the Teamviewer activiation. I recently joined a support team in my organization, and the teamviewer drops the error, your trial version has expired, however the license was provided for me by the team.

    Tried to submit a ticket on the website, but it was just turning me back to the start page.

    Could you please help on this?


    Thank you in advance!


    Kind regards,



  • I sent the private message with the requested info. It shows active in but not TeamViewer Management console which is through the same email address. The activation link was followed already but nothing is recognizing that. If a new activation email simply needs to be resent that would be great. I would appreciate if we could get the version we paid for working asap.

  • Jean7
    Jean7 Posts: 2 ✭✭

    I purchased the following license:

    - TeamViewer Remote Access Access to 3 devices

    - Online Support via TeamViewer Community and Support Portal, no support via phone

    - Invoicing period: 17-Mar-2020 - 16-Mar- 2021

    I received an E-Mail validation link (with the token url param) and clicked it, yet my account has always been labeled "Free", and TeamViewer disconnects me in less than a minute.

    When I try clicking the validation link again it says "The token is invalid".

    Could someone please fix my account?

  • Fiona_G
    Fiona_G Posts: 689 Staff member 🤠

    Hi @DeputyClerk,

    Thank you for sharing the information.

    Please have a further discussion with our support team via the support ticket I've created for you. In the meantime, please kindly check out this article to activate your Remote Access Plan appropriately.

    Thanks for your patience and understanding in advance.

    Kind regards,


  • Fiona_G
    Fiona_G Posts: 689 Staff member 🤠

    Hi @Istvan_94,

    Thank you for your message and welcome to our community.

    As I mentioned above, you have to use a licensed account to create a support ticket. Please kindly contact your Company Profile admin and request them to assign a license to your account. 

    I hope this information would be helpful.

    Best regards,


  • Hi, I have a similar problem, and I can't create a ticket  !!! I ve paid ca 200 euro for a license, and I can t activate it !!!!! 

    I've followed all steps in your guide book, and receive constantly : invalid token !! 

    please help



Sign In or Register to comment.