link icon
Ask The Community

Intune not working with ASSIGNMENTOPTIONS="--grant-easy-access”

When deploying custom host through INTUNE, everything works fine.

The custom host is installed, the device is assigned to the teamviewer group

/qn APITOKEN=our-hosts-api-token CUSTOMCONFIGID=ourhostconfigid

However as soon as we add ASSIGNMENTOPTIONS="--grant-easy-access” the host does not get installed anymore on the clients.

Is there mayby a typo or something?

This is how we set it in intune Command-line arguments;

/qn APITOKEN=our-hosts-api-token CUSTOMCONFIGID=ourhostconfigid ASSIGNMENTOPTIONS="--grant-easy-access”

We tried different order of the params, that doesn't seem to matter. We also tried without our custom host, but as soon as grant-easy-access is added to the mix, it stops working.

Just to be clear, without easy-access option the deploy works like a charm, however the easy-access option is ofcourse not enabled then.



  • Tomi-
    Tomi- Posts: 11


    Have you still found any new info or solutions regarding this problem? I currently have an open ticket with TeamViewer support regarding this problem and just today I made a thread about the problem also.

    Kind regards,

  • Hi,

    No still looking for a solution, it is a real problem for us at the moment.

    Please share the link to your thread so we can upvote it also!

    Thank you.

  • Tomi-
    Tomi- Posts: 11

    I just went through the guide and my settings and all the info around AGAIN and something caught my eye this time. In the guide it says "Allow account assignment via the Assignment Tool: Account assignment without confirmation will activate easy access automatically" so might that be the cause why the --grant-easy-access parameter is causing problems?

    Although you said that you've tried the deployment without the --grant-easy-access parameter and then the easy access was not enabled? Did you still follow the guide and have that account assignment checked when trying to deploy without the --grant-easy-access parameter? :)

  • Hi,

    I believe the assignment tool is no longer support/available as of version 13.2

    However I do see now that the account assignment without confirmation, via the API, should enable the easy access, so the easy access parameter does not need/should not be used.

    This makes the issue description a bit different:

    easy access does not work when using /qn APITOKEN= and having ALLOW ACCOUNT ASSIGNMENT enabled.

  • Tomi-
    Tomi- Posts: 11

    Ok thanks for the reply! I'll let you know if I find anything or if the TeamViewer support answers me (still nothing from them). Also if you get any new info or solutions regarding this, please let me know too. Thank you! :)

  • Hello @Johnson44 ,

    That is not the solution but someone with the same question/issue. :-)

    Leaving out the grant-easy-access will fix the issue about not installing at all via Intune, however without the easy-access being enabled on the clients.

    Kind regards

  • Tomi-
    Tomi- Posts: 11

    Hey @Myprovider !

    I've continued diagnosing this and today I wanted to test something "just for the heck of it" and it seems to have worked! All I did was leave the " " (quotes) out from the command line. So my command line was like this:


    With that command line the deployment went through and all my customizations were in place and the policy I attached to the host seems to be in place also. Then I tried taking remote control via Intune portal and it still needed user action from the company portal but if I just connected via the TeamViewer client to the computer, I managed to get the remote session open without any user prompts.

    After that I also uninstalled the host and reinstalled it with leaving the ASSIGNMENTOPTIONS=--grant-easy-access out of the command line and again all worked but it didn't let me take control without password.

    So it really seems to work. Test it out and let me know if I hit the jackpot or if there is some other forces in work now. :-)

    Kind regards,

  • Hi,

    Very hopefully I just tested the same, strange enough in my case also without the quotes, as soon as I add --grant-easy-access the deployment fails. And without everything (still) works however not able to access without the password.

  • Tomi-
    Tomi- Posts: 11

    This seems really strange, I just tested deployment/uninstall/redeployment cycles a few times again and everytime the same result; with ASSIGNMENTOPTIONS=--grant-easy-access (notice there is no space between = and --) it deploys fine and easy access works and without the ASSIGNMENTOPTIONS parameter it deploys without easy access.

    I wonder if you might have something else blocking the deployment? Have you double or triple checked the api token and config id? Also what error code do you get in Intune when the installation fails?

    Kind regards,

  • Hi, i got it to work; @Tomi- 

    I deploy it (as suggested by teamviewer helpdesk) as Win32 app in intune.

    It still did not work then, a changed the assignment options (after trying several formats, with/without brackets) to contain a space after --grant-easy-access like so;

    ASSIGNMENTOPTIONS="--grant-easy-access ”

    Then it works! I will try to find time to try this as normal msi deployment which works nicer in intune, and since the first go gave the same problem, i am hoping that the extra space is the solution and the win32 deployment package method had nothing to do with it :-)

  • Tomi-
    Tomi- Posts: 11

    Hi @Myprovider !

    I'm happy to hear you got it working at least as Win32 app. Let me know if you the space solves the problem with MSI deployment also, when you have time to try it. I'm curious to see if that's also a possible fix. :)

    I got an answer from TeamViewer support also and they said the problem is actually more with Intune at the moment, because it somehow truncates the command line. They told me it's ok to leave the quotes out of the command line if it works for me and they'll notify me if/when they get updated information about the situation.

    Kind regards,

  • JMak
    JMak Posts: 2

    I just want to confirm that I am able to deplpoy the MSI (without WIN32 app) via InTune by removing the " for ASSIGNMENTOPTIONS=

Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!