Commercial use - Connection time out



  • steviemar
    steviemar Posts: 4 ✭✭

    I get kicked out of using this software. I'm told that I am a commercial user

  • Jenni
    Jenni Posts: 5 ✭✭

    Last week I was getting the "suspected commercial use" message. I got that fixed (at least thats what the email said). But now when I try to connect to one of the computers I only get a minute before I get kicked off saying the session was "timed out" NOTHING about commercial use, just "timed out".

    On top of that when I try to reconnect I get a "connection blocked after timeout......Immediate reconnects are blocked. Please try later or upgrade your license. Connection to this partner will be blocked unitl ##:##" message. The VERY interesting thing about this message is that even after that specified time, I am still blocked and get the same "connection blocked....." message but the "blocked until" time has changed to one minute from the current time. No matter how many times I try to reconnect that message keeps showing up and the time is changed........

  • wlukefox
    wlukefox Posts: 1

    I'm having the same issue. Any recommendations? Completely unusable right now.

  • keyman916
    keyman916 Posts: 2 ✭✭

    i have the same problem

  • GeoffP
    GeoffP Posts: 1

    I'm getting timed out after 30 seconds. I've been using TeamViewer for years to support my mother and use it once or twice a month. We both have the latest version installed. Any suggestions for a fix?

  • pt1424
    pt1424 Posts: 2 ✭✭

    I am getting a message that TeamViewer has timed out. I only have this issue on one computer, and I started getting the Commercial usage message only after I cloned my drive. Initially, I thought the issue was corrected, I sent the form to TV explaining how I use it, but I no longer get the message about Commercial use, just times out after connecting for a couple of minutes. I have another computer in a different room on the same account that works without issues.

  • b_broody1
    b_broody1 Posts: 2 ✭✭

    I only use team viewer with 1 person, perhaps 1 a week. First I got notice that you thought I was using Team Viewer commercially, finally got that straighten out, and now I sign in to my friend and it times me right out.

  • AFF
    AFF Posts: 1
    edited September 2021

    Same frustration here - evidently sophisticated means commercial. Like most people, I use Teamviewer for my mom. Hopelessly inept at anything with a screen. I'd like to thank them for letting me use their software to help her out, but the most recent restriction to 5 or so minutes makes that painful.

    Honestly - be happy to pay for a personal license without restrictions at a price more suited to the value it has for me, but $600 is enough to make me look elsewhere for solutions - maybe even slog my way through Apple's remote management **bleep**.

  • roso
    roso Posts: 5 ✭✭

    This keeps happening now with everyone I connect with.


    Your Teamviewer sessions has timed out and will be closed.

    This was a free session sponsored by TV sessions are free for personal use. Thank you for playing fair.

    Does it think I'm using it commercially? Why can't I stay on anymore?

  • Joe_Bosco_69
    Joe_Bosco_69 Posts: 4 ✭✭

    I connected to my mother's computer via TeamViewer for a remote control session to assist her and within 30 seconds, just after seeing the desktop on the remote computer, TeamViewer closes the connection. It then displays a text box message saying "Your license limits the maximum session duration to a partner, immediate reconnects are blocked. Please try later or upgrade your license."  So I waited a couple of hours, tried it again with the exact same result.

    I've used TeamViewer for years to support my family and to remote control other computers on my home network and until a year or so ago, never had a problem and was always grateful for the free personal use license. I've never used it for commercial purposes. But right now, I can't even remote control my laptop, which is sitting 2 ft. from my router on the same network.

    I'm flummoxed as to how to fix this. It's not like I can afford to purchase a commercial license just for the ability to look at an error message on my mom's computer. I tried uninstalling and reinstalled TeamViewer to no avail.

    I'd be very appreciative to anyone who can help me solve this problem.

  • roso
    roso Posts: 5 ✭✭

    I have the exact same problem!

  • marcini
    marcini Posts: 1

    I'm having the same issue, teamviewer team please help. I need to help my parents overseas!!!

  • cashflowjoe
    cashflowjoe Posts: 1

    Same thing happens to me. Teamviewer Team? Hello...???

  • extracash
    extracash Posts: 0
    edited December 2020

    I have been using TeamViewer for years but recently it has limited my use to only a few minutes.

    Once it said I needed to upgrade to the Business model and after writing back and forth they reactivated my access to a longer time I guess.

    The people I am working with are now getting the same run around as I had and we are not big users of this system so why is the system being so complicated to work with>

    I have told everyone that if it consists we will change over to **Information removed as per Community Guidelines** so we will see what happens.

    So much for that. It has been fun and good with this free service but I guess we are no longer needed.


  • 1252154362
    1252154362 Posts: 1

    After downloading the latest free Teamviewer, I keep getting timed out within 5 seconds after connecting.

  • Gmb226
    Gmb226 Posts: 1

    For some reason when I sign in to do work from home it says we are using commercial use detected and i cant work from home anymore

  • SFGrecia
    SFGrecia Posts: 3 ✭✭

    I am a kindergarten teacher (i.e., NOT a computer person) and I use TeamViewer to occasionally help an elderly friend with his computer questions. Lately, we can only connect for about 1 minute and we get kicked off. Are there new limits to the free use?

  • iwork2ski
    iwork2ski Posts: 1

    I used to love TV to help all the family members with their computer issues. Now I get a 10 minute time out which is a real problem. Then you cannot reconnect for a period of time. I cannot remember the amount of time but I think it was 15 minutes. Really not helpful when your great aunt keeps hitting the close button. So Esther responses are incorrect as Bdoubleu stated. Maybe TV now considers all users commercial users. Regardless I had to move on to another Remote Desktop product.

  • steve_rees
    steve_rees Posts: 3 ✭✭

    I'm doing pure personal use (connecting from one computer to another within my home, as a retired person), and ran into the issue of false positives on commercial use earlier this year. I followed the PDF-based appeal process, and that worked the first couple of times. Most recently, there was no response to the PDF appeal, and I'm still having connection problems.

    Currently, it connects OK, but times out after about 1 minute (not due to inactivity, just elapsed time). "Your TeamViewer session has timed out and will be closed." and below that "This was a free session sponsored by TeamViewer sessions are free of charge for personal use."

    I didn't use to have these timeouts. It's not actively complaining about the falsely-suspected commercial use, but I suspect the timeouts and the commercial use malarky are related.

    Are the timeouts related to suspected commercial use (ie, if I finally get a response on the latest PDF appeal(s), will this go away?), or is this a new roadblock for TV? :-(

    Suggestions appreciated.


  • califbob51
    califbob51 Posts: 1

    I'm having a similar issue, my connection drops seconds after connecting to my brother's computer. How do I resolve this and what is the PDF appeal process?


  • steve_rees
    steve_rees Posts: 3 ✭✭

    @califbob51 here's the link -

    Good luck getting it resolved.

  • Sahil_123
    Sahil_123 Posts: 0
    edited January 2021

    Currently I'm using Team-viewer for personal use but during connection it's continuously showing session timeout due to commercial use.

    Please resolve this issue as soon as possible or I have to move for another remote connection apps.

    My Team-viewer ID: **Information removed as per Community Guidelines**

  • jiahao86
    jiahao86 Posts: 0

    why i have limit it?

  • Jenni
    Jenni Posts: 5 ✭✭

    Only solution I've found so far is to use a completely different program!! I know we are "free" users but the fact that we can't get support is ridiculous!!! I may just have to move on from TV....smh

  • alex_sssss
    alex_sssss Posts: 0


    First, I read the article and I followed the steps, filling forms precicely and signing multiple times over the last 2 years, doesn't work. Even it it recents - it lasts until next connction.

    There's absolutely no commercial use in my case - trying to help my parents, who are in another country.

    I have a colleague with identical situation, he tried to use TeamViewer to help his relatives.

    Do I assume right, that the avove article is not correct/up to date and slowly "free version" is getting deprecated?

  • JimAA8
    JimAA8 Posts: 1

    What the heck have they done with this program? It used to work so well and I never had issues with it. I've used it for years to connect to my Dad's computer to help him with issues. Today I went to connect and it won't accept the password and then keeps popping up a message about connection timeout and giving me some time that's a minute away that I have to wait. I wait until after that time but it pops up the same message and updates the time to be another minute out. Finally got connected going through the Chat section and it stayed connected for about a minute and then disconnected. When I try to reconnect, it does the same thing. WHAT is going on?

  • sydneyos
    sydneyos Posts: 1

    Yes, I am having the same problem. Contacted TV multiple times with no response.

  • ezjacob
    ezjacob Posts: 1

    So I've been using team viewer free for awhile to help remote to my home computers when I'm away but now all of a sudden I've limited to 5 minutes for non-business use? is there a way for support to review my logs to see that I don't use it for business so I can remove the time restriction?

  • chrislev
    chrislev Posts: 0

    This started about November 2020. I only use Teamviewer for personal use. I connect to a friend's computer in another state and the session in terminated shortly after connection. Every attempt to reconnect is met with a Blocked notice and states to upgrade the license. I only use this for personal use. What happened to Teamviewer that I can no longer use it?

  • SFGrecia
    SFGrecia Posts: 3 ✭✭

    I'm having the same issue. I use Team Viewer to help an elderly computer-challenged friend occasionally with help on updates and basic tech questions. Now I have to pull my hair out trying to visualize what he's describing on the phone. Ugh. HELP!