link icon
Ask The Community

Works when wired direct to modem, wont work wired direct to router

elrichio86 Posts: 1
edited February 2021 in General Questions

Hi people.

Here's how I have my network setup:

  • Virgin Media SuperHub 3 in router mode;
  • Eero mesh router hard-wired into the SuperHub;
  • Powerline plug hard-wired into the SuperHub;
  • Windows Server on the other end of the Powerline, with TeamViewer;
  • Every other gadget & PC uses the Eero wi-fi.

This works. I can connect to the server from both inside my Eero network, and externally. The only problem is that I cant directly access the server from PCs on the Eero network (for file-transfers, for example), I can only access it through TeamViewer.

Whilst this is fine, it means I've effectively got two networks on the go. It seems like it would be better practise to do everything through the Eero router (and thus be able to do file-transfers server-to-PC), and only use the SuperHub as a simple modem.

So I've tried moving the Powerline from the SuperHub to the Eero router, to create a single network. I can see both the Powerline and my server in the Eero app, and I can connect to them directly from another PC on the network, so they are correctly part of the new network. The difficulty is that TeamViewer no longer sees my server as online (either from my PC or an external source).

Any idea's why this might be? Surely if the server is visible & accessible on the network, then TeamViewer should be able to connect? What am I doing wrong?

As far as I'm aware I'm running the latest TeamViewer on everything, whilst the server is running Windows Server 2012.


  • Esther
    Esther Posts: 4,110 Former Community Manager

    @elrichio86 Just a thought: But can you check the TeamViewer ID after moving the Powerline from the SuperHub to the Eero router, to create a single network. Is it still the same?

    Former Community Manager