link icon
Ask The Community

TeamViewer is one of the winners of the European Customer Centricity Award 🥳

Please find more information here.

Commercial use - Connection time out



  • kucer
    kucer Posts: 0 Newbie

    The reset page does not work. I put in my ID and it is more than 8 but less than 11 letters but it just highlights that field in red like I have it wrong. I have OCD and it takes me 30-60 minutes to leave for work because I keep having to go back and check the stove, etc. With teamviewer I can just leave OBS up connected to my cameras and TV in to my pc to verify that no, my house is not on fire. It also allows me to view my emotional support animal. You think this is no big deal but it causes me a ton of anxiety. And I cannot even put in a ticket or chat/call/email with a real human being to get this resolved. Did some awful company buy teamviewer? You used to be the best but this is just a massive swerve downhill.

  • bradmich
    bradmich Posts: 1

    Recently I have tried to connect with another one of my computers and after about 2 minutes I get blocked and the mesaage that I have exceeded maximum duration. I only use TEAM Viewer about once every month or less and have had no blocks so far yet now I am getting this message and issue?

    What is going on??

  • ktr239
    ktr239 Posts: 1 Newbie

    Seriously - I cannot connect to anything, why am i being penalised for not paying for a FREE account?

  • I have also just started getting this problem. While connecting my Mac to my Ubuntu computer.

    Connecting from my phone to my Mac seems to work and doesn't time out. So I don't think this is an account or licensing problem.

    I reinstalled Teamviewer on mac and my Ubuntu machines. Still getting the same error.

    This is what I get when trying to reconnect:

  • mgchurchvideo
    mgchurchvideo Posts: 2

    I recently summited a request to get my ID rest as I was flagged I use teamviewer to connect to my church computer to organize I do this on my own time and I'm not paid. This is very frustrating. I would love to talk to anyone on phone just give me a number. NOT HAPPY

  • HaVoK
    HaVoK Posts: 1

    I am travelling and trying to remote to my home PC but teamviewer keeps timing out over and over. How can I fix this? I am using the free version. Thanks!

  • Supawoo
    Supawoo Posts: 1 Newbie
    edited April 19

    Just save yourself a headache with these **bleep** **bleep** and switch to **Third Party Product**. You're welcome!

  • rchan
    rchan Posts: 1 Newbie

    I'm trying to connect to my Father's computer to get some files to help him file his taxes.

    I haven't connected to this computer in a while.

    I connect on to his computer and in about a minute or so. I get kicked out and I try to reconnect and get this:

    Connection blocked after timeout.

    Your license limits the maximum session duration to a partner, immediate reconnects are blocked. Please try later or upgrade your license

    Connections to this partner will be blocked until 21:35

    I'm using version 15.16.8 (32-bit)

  • clee1978
    clee1978 Posts: 0 Newbie

    I am having the exact same issue. All I am trying to do is assist my friend with some computer issues that he is having; however, I don't stay connected for more than thirty seconds, and I am kicked out. I do not use this software for financial gain, only to help my friends and family when they need computer assistance, be it macOS, Windows, Linux, etc. When I visit the TeamViewer site and on the application itself, it states that I am using the free account. I am using version 15.16.8 64 bit and the behavior is the same on macOS, Windows 10 build 20H2v2 and Linux. Please assist us, TeamViewer! Thank you.

  • Sunhee
    Sunhee Posts: 1 Newbie

    Hello, I am Sunhee.

    Recently I have been blocked when I was using Teamviewer.

    The program said I need a commercial license.

    But I am in the academic field and used TeamViewer with my friend for coding the program or R.

    Could you permit my Teamviewer access?


  • Hi,

    I have been using Teamviewer for a long time around 8 years. I have three PC's at my home that all have it installed. One of them is using a VPN and has no screen. I use this PC for my Onedrive storage and media. Anytime I connect to this PC for remote control after a minute TV kicks me out and won't let me reconnect for a certain period. Why is this? How do I fix it?



  • lazza79
    lazza79 Posts: 1 Newbie

    I have 4 PCs in my TeamViewer account and recently I am being kicked out after about one minute.

    Could you please help?

    I have a free license and I don't use the PC for commercial purposes.

    Thank you!

  • ThinkOfANumber
    ThinkOfANumber Posts: 0 Newbie

    I'm in the same boat today trying to help my 81-year-old dad. Constantly disconnected and then timeout messages.

  • lazza79
    lazza79 Posts: 1 Newbie

    I have the same issue.

    Please help!

  • JonathanChristie
    JonathanChristie Posts: 0 Newbie

    Had this appear a few weeks ago. submitted a request to have it 'unblocked' (not for the first time either) and it worked for a couple of weeks. now its re-appeared. I gave up the convenience of using if for a homelab connection a while ago too.

    This really is becoming a pain in the proverbial.

    I'm probably being over cynical but it seems like crass move to force users into purchasing when they need it most.

  • Libertay
    Libertay Posts: 0

    This is happening to me too. I connect to my home pc, then it closes and tells me I have to wait. When I try again it does the same thing.

  • rchan
    rchan Posts: 1 Newbie

    It's been happening to a lot of people since yesterday.

  • Wagman67
    Wagman67 Posts: 0

    Well, I see we are all in this boat. I don't see TV either attempting a resolution or letting us know they are attempting a resolution. It is free, so I guess I am getting what I paid for, anyway.

  • skube
    skube Posts: 0

    This is so frustrating and really not endearing me to TeamViewer.

  • clouds73
    clouds73 Posts: 2 ✭✭


    I'm not a company or anything, I'm just a dad who connects daily to my son's computer and teaches him! He is only 9 years old, and he's is struggling with his online schooling, so I have to connect daily to his computer and help him study because unfortunately, I don't live with him. I connected once to my daughter's computer at the same house, but it's always my son, every day. Now, TeamViewer closes after 1 minute and won't let me stay longer and also won't reconnect immediately. This is a disaster for me because my son needs me and all other remote software isn't that efficient. Please, can you lift this limitation? Thank You

  • Rooster
    Rooster Posts: 0 Newbie

    Same issue, no idea what this is about. I have not used my TeamViewer all week. Seems a little shady on Teamviewers side.

  • SneakyGit
    SneakyGit Posts: 0 Newbie

    Ditto .. I have not used Team Viewer in a couple of months

  • Rctaets
    Rctaets Posts: 0 Newbie

    Same timeout issues.

  • Mba7th
    Mba7th Posts: 0 Newbie

    same issue here, it connects for 1 minute only

    issue only on my ipad pro

    connects fine thru iphone

    didnt try it on any os or devices

  • dasnipa13
    dasnipa13 Posts: 0

    I help alot of friends without ever receiving any compensation.. EVER. And I have been disconnected for the same issue.. many times.. this should be remedied.

  • Catlady7310
    Catlady7310 Posts: 0

    Same issue here since I upgraded to the most current version I only

    use to help my friends with no fees involved. I have been using this product for

    many many years now

  • Stildreamn
    Stildreamn Posts: 0 Newbie

    I'm also having the same issue but don't see anyone posting how to fix it or if there's a problem with the Web site

  • Jinen
    Jinen Posts: 0 Newbie

    Same issue...any resolution, please help.

  • swaichulis
    swaichulis Posts: 1

    How do you reset your Team Viewer ID for the free personal use version?

    I'm no longer able to connect to my computer at my other house.

  • Mazza154
    Mazza154 Posts: 0

    Same here, any update on how to resolve this?