link icon
Ask The Community

Commercial use - Connection time out



  • Goosa
    Goosa Posts: 1

    Your flagging and appeals system is broken. I've been flagged multiple times over the years and was disappointed to find the chatbot, contact links, and support redirects to the forums and not tech support for personal use license holders. I don't even help friends, only family and my own devices, but I keep getting flagged and cleared on appeals. Now I can't stay connected over 30 seconds, and I'm blocked from connecting again.

    Look at the image I posted, the file I'm trying to submit is a .pdf and only 252 KB. What is going on with TeamViewer? It's an essential tool for me, but your paranoia is making it unusable.

    If I can't appeal, what choice does anyone have but to delete TeamViewer?

  • Modify_inc
    Modify_inc Posts: 2
    edited April 2021

    Support reset my TV ID on 4/27/21, but the ID they reset does NOT match the one I provided. The instructions I received via email say:

    "Check if the TeamViewer ID(s) you provided match(es) the TeamViewer ID(s) you are using. In this case, please repeat the process and fill out a new form for this/these TeamViewer ID(s):"

    Yet, every time I try to resubmit as directed, it says:

    "Your request has already been submitted and is pending further review. Thank you for your patience as we process your request."

    Hopefully this means someone is actually reviewing it again, but why would they be? As far as I know, they are unaware of the issue since I can not contact them because I'm just a free user. I mean, how do I know the message isn't related to my original form I submitted, and thus always displays that message if I try to resubmit? I haven't received any notice/update since they "supposedly" reset it on 4/27/21. Would just like confirmation that they are aware of the issue.

    Edit: No one has even reached out to me to confirm what the correct ID should be.

  • DavidVirden
    DavidVirden Posts: 4 ✭✭
    edited April 2021

    I'm Currently using TV in a non commercial way to take care of my parents computers in Maryland (USA). I usually logon once a week. My user id is **Do not post TeamViewer IDs**. I have been doing this for over a year. The problem started on April 29 2021. I do not receive any payment. Any help would greatly be appreciated.


    David Virden

    **Do Not post email addresses**

  • Dave_Reiser
    Dave_Reiser Posts: 6 ✭✭

    Hi David,

    Did you get a notice saying they felt you were a commercial user? I did and I had to sign an affidavit that I was only using TV for personal use. They send you the affidavit as a PDF and you have to sign it and send it back. This is the second time that I've had to do this.

    I live in Gaithersburg Maryland. Where are your parents located?


    Dave Reiser

  • jlchaps
    jlchaps Posts: 2 ✭✭

    Hello, I use teamviewer only for a private use. I use it to have access to my own computers in distance or locally.

    Sometimes I help someone in my family.

    And today, I have a message saying that it seems that it is for commercial use and I need a licence!

    How can I continue to use TV in private with free access ?

    Thank you for your help.

    Kind regards

  • Can0nFan
    Can0nFan Posts: 4 ✭✭
    edited April 2021

    I have installed Team Viewer as a registered free user and can no longer connect to my parents that are over a 700KM drive away in another province locked down due to a covid spike

    my fathers browser is essentially unusable and everytime i try to connect i get timed out messages and to try again at such and such a time thats is 1 -2 min in the future.

    I need this to support my parents whats up with the constant connection issues?

  • joshedmunds16
    joshedmunds16 Posts: 3 ✭✭

    Is it just me or is TeamViewer trying to force their free users that have never used the software for profit to buy the commercial version of TeamViewer? This is the second time their software has flagged me and accuseing me of using the program for profit when I am not and never have. I have been using TeamViewer for over 10 years now and loved it. It has helped me and my family alot especially my father who drives trucks and does long hauls. He is not good with technology. But I guess its time to look for a program. Because I cannot come close to affording the commercial version of TeamViewer. TeamViewer was nice while it lasted.

  • tenementgeek
    tenementgeek Posts: 2 ✭✭

    I was just about to say exactly the same thing, except t that in my case it is my 89 year old mother with Dementia. She's already suspicious enough of all her electronic devices, now I have to try to explain that the trustworthy free software we have been using for the last ten years mysteriously stopped working, and that we have no viable alternative for me to provide remote assistance.

  • tenementgeek
    tenementgeek Posts: 2 ✭✭

    How does this "answer" his question? I was just making a comment.

  • Kaggy
    Kaggy Posts: 2 ✭✭

    I am having this same problem. I am a registered free user, using Team Viewer to connect to my parents' desktop computer and the desktop computer of my older brother, who has dementia. They are 2000 miles away from me and for several weeks I have not been able to hold a connection for more than a minute. I use Team View exclusively for the purpose of helping family members. I am NOT getting a "suspected commercial use" warning, so I don't understand why my connections are timing out and I'm blocked from connecting again anytime soon. I've tried extending the "Timing Out Inactive Session" setting under Extras-Options-Advanced menu, but this changes nothing. I'm really frustrated that I can't help my parents who are in their 90s and my brother, who needs help using his computer at all because of his disability. What's going on? How to get help?

  • Artemkin
    Artemkin Posts: 4 ✭✭

    Same problem i have.

    I have a job far from home, and i can't use app in my computer more 5min. I use only for private connection.

  • Artemkin
    Artemkin Posts: 4 ✭✭
    edited May 2021

    Hi, i have a problem with my app teamviewer, i can't use more 5min. I use only for my own private connection.

    How i can fix it?

  • Kaggy
    Kaggy Posts: 2 ✭✭

    I am having the same problem that other users have posted they're struggling with. I am a registered user with a free account, using Team Viewer to connect to my parents' desktop computer and the desktop computer of my older brother, who has dementia. They are 2000 miles away from me. For several weeks I have not been able to hold a connection for more than a minute. I use Team Viewer exclusively for the purpose of helping family members. I am NOT getting a "suspected commercial use" warning, so I don't understand why my connections are timing out and I'm blocked from connecting again anytime soon. I've tried extending the "Timing Out Inactive Session" setting under Extras-Options-Advanced menu, but this changes nothing. I'm really frustrated that I can't help my parents who are in their 90s and my brother, who needs help using his computer at all because of his disability. I don't see anyone giving any useful answers to users with free accounts who have previously posted this problem. What's going on? How to get help?

  • mphi55
    mphi55 Posts: 1
    edited May 2021

    Just purchased a new iMac for our church. I use Teamviewer to log in remotely to do work for the church from home. Since the upgrade to the new iMac, I can connect to it but it locks up/freezes after only a few seconds.

    Logging into it with a MacBook pro. Running Catalina at home and Big Sur up at the church.

    Both have the most current version of Teamviewer. 15.17.6. Was working fine until the new iMac.

  • Kreigr
    Kreigr Posts: 1

    I keep getting timed out when trying to connect to one of my PCs. I am only using at home with a few PCs connected. I think TV suspects I am using commercially. How can I fix this. Is it a setting I am missing or can't find?

  • GiJohn
    GiJohn Posts: 1

    This is driving me nuts. What did I do to get flagged like this? This doesn't really make any sense to me. I only use TeamViewer to check in on my kids' gaming computer from my phone. Is this commercial use?

    ... I really doubt it...

    It kinda seems like maybe this is just a ploy to make us upgrade to the business version.

    I might be inclined to do that, but I don't want to pay for a full year in advance. There should be a monthly option or something.

  • Bebbspoke
    Bebbspoke Posts: 22 ✭✭
    edited May 2021

    Hi Peoples; - I am a private user of TV (free) - I regularly check the pcs of a few friends & relatives.

    On one of these devices - the TV link now drops out within about 1 minute of connection, with reconnect blocked for 5 minutes.

    This makes servicing the colleagues pc impossible...

    Please - any suggestions? (both machines are running latest TV version 15.17.6)

    Thank you.

  • Bebbspoke
    Bebbspoke Posts: 22 ✭✭

    Hi Folks - again I am erroneously accused of "Commercial Use" - please; - where is the link to resolve the issue?

    Thank you.

  • Bob66441
    Bob66441 Posts: 5 ✭✭

    I am using the latest version of Teamviewer Version: 15.17.6 (64-bit). Have used TV for years without problem to assist friends or family member with their PCs. I am getting timed out and disconnected withint a minute after connecting. I am NOT getting a commercial use detected message. Started March to April 2021.

    I installed the 64-bit version after my Teamviewer Version: 15.16.8 (32-bit) kept timing out after less than a minute when connecting to help my mother with her PC. Further attempts only result in a timeout with the time to wait advanced to connect attempt time + 2 minutes. Have restarted both PCs and checked Advance Setting Timeout (was and still is set to off). Have tried installing older version of TV (TV ver. 10) which would not allow me to connect unless I agree to update. Ver 10 kept telling me I was detected as a commercial user. Updating back to Version: 15.16.8 32-bit gives me the time out problem again. (The commercial user notice does not appear anymore as it did when I was on ver. 10). I am able to connect for about 1 minute if I restart or stop and start the TV service in windows taskmgr services. I do not know what else to do. I am not using a VPN for internet access. I am not using a proxy. My connection download/upload is 30mb+/2.9mb+.

    Again, I am NOT getting a commercial use detected message. I have also tested TV with another friend on two of his computers, and am having the same problem. He also gets the same timeouts when connecting to me or to his laptop PC. I had no problems before March 2021. All PC's are Windows 10 Home, not using VPN, firewall enabled (disable does not correct problem). . Please help if you can.

  • Remeto
    Remeto Posts: 4 ✭✭
    edited May 2021

    i have the same problem, much users after the last update have this problem

  • Marvinski
    Marvinski Posts: 1 Newbie

    I've been having the same problem with TeamViewer Free License. It disconnects after about 1 minute with a "timeout error" message. This problem started about 3 weeks ago with version 15.16.8 (32-bit). I updated to the latest version 15.17.6 (32-bit), but it continues to have the same problem with any and all connections timing out and aborting the session every time. Note that I do *not* get a "commercial use detected" message - just the timeout message.

    Is this a bug? Please TeamViewer Support, help us figure out what the cause of the problem is.

  • Remeto
    Remeto Posts: 4 ✭✭

    i tested the solution i found and it works very well

  • Spartan1
    Spartan1 Posts: 1 Newbie

    I was told to fill in a form to justify my request for a free licence. I did this, and uploaded it as requested. So what happens now...?

    Do I get an email saying if it's been approved/disallowed? Or what...

  • loggingsecretary1
    loggingsecretary1 Posts: 1
    edited May 2021

    The same thing keeps happening to me, I was wondering if you go any kind of an answer? I see they won't help you unless you have a license though. If the paid version works like the free one I don't know that I want to spend the money.

  • Dave_Reiser
    Dave_Reiser Posts: 6 ✭✭

    Oh yes, near BWI.

    Now, how do we communicate with TV? I still can use it.

  • José_António54
    José_António54 Posts: 10 ✭✭

    Good afternoon

    When I enter a remote session, the session disconnects shortly afterwards and one appears to me that has timed out, as shown in the annex.

    Thank you very much awaiting solution to the problem.


  • pete2con
    pete2con Posts: 1

    I have been using free TeamViewer for a year and recently after logging into my account and accessing my husband's computer, TeamViewer kicks me out telling me I have run over my time - what am I doing wrong? Thank you

  • rfennimore
    rfennimore Posts: 6 ✭✭
    edited May 2021

    Are any other people experiencing this? (see attached). I am runnning TeamViewer Version: 15.17.6 (a008a771384) on macOS Big Sur 11.2.3 (20D91). Free licence and non-commercial.

  • Jcmarcell
    Jcmarcell Posts: 2 ✭✭
    edited May 2021

    I am using windows home for at home personal and non commercial work. Worked for years actually on team teamviewer. But recently I've ran into an issue with windows update making my PC unbootable. This resulted in me fixing the error and reverting to some older windows updates. Teamviewer worked fine up until I used this bat file that installed the ability to use group policy editor on win 10 home version (which only come factory in pro editions for win 10). The reason I installed this is to have the ability to disable windows updates (to prevent what just happened with win 10 pushing bogus updates automatically) Which I did. Now team viewer said my system is a commercial account ? I tried restarting and even deleting teamviewer and it works for a while then right back to commercial use detected.

    I understand teamviewer is free and you guys don't want people using it commerically for free. Don't get me started on those people that "just need to log into my work computer for an email" because I don't do that at all what so ever. I have 8 computer's all personal in my home and need access with teamviewer. I'm willing to pay for my usage but I don't want to have to pay for the commercial use at current price if I'm not fully using all the features which brings me to ask if we can get a less expensive version for lite commercial users. With maybe limited features. For cheaper. (Idea pitch that nobody important enough will read)

    Furthermore I want to have access to my PC and I'm in a situation where changing hardware or software can destroy my ability to encrypt current data so deleting windows or adding a new version or anything like that IS NOT AN OPTION for this pc at this time. I lost enough down time just fixing Windows 10 After the update. After disabling the features from newly added group policy editor, it still shows commercial use detected also.

    I'm at the point where I'd be willing to pay for a license at reduce price. (Highly unlikely)


    Just having to find a different software for this ONE pc when all my others work with teamviewer (pain the **bleep** **bleep**)

    OR move a bunch of **bleep** just to connect a monitor for 15 mins every couple days. (Pain but honestly it's what I've been doing)

    Any ideas to completely remove this problem with teamviewer without having me change any of my current setup would be appreciated.

    thanks for anyone's time, and don't get me started on the "this is the wrong thread" because it's been two weeks and I still haven't heard back from whoever supposed to be resting my ID (again).

    I'm feeling my personal scenario might not be the same scenario as others experiencing the same problem.


    Lastly I feel like this is teamviewers quiet way of getting all of us freeloaders to pay up and cough up the money we been using for free all these years and to slowly erase the neutral line thats in between those "I need to check my work email from home computer one time" and those "hey co-worker let me connect teamviewer to help you while we are here at work on our commercial computers in our commercial environment" people.

    Rant over thanks for listening, any ideas??