Commercial use - Connection time out



  • KennedyR
    KennedyR Posts: 1
    edited June 2021

    My teamviewer will not stay connected for more than a minute. It times out and locks me out for a few minutes, but when I try again it still does the same thing. I've connected to 2 different computers and it does the same thing for both. So it must be something with on my own end... I'm using free version, by the way. It also is not giving me the "commercial detection" notification I've seen people post before.

  • MichaelBerkowitz

    I'm having exactly the same problem. I'm guessing it was a recent update to the software, but who knows.

  • Gazpacholulu
    Gazpacholulu Posts: 1

    Same here, what a complete PITA after years of great service

  • Kzoom
    Kzoom Posts: 6 ✭✭
    edited June 2021

    I've been told by 'Yuri' at TeamViewer support to post a reset request, which I'd already done BEFORE I complained about the situation on Twitter, which got his response. Done it twice since. No response, no reset, nothing.

    [removed per Community Guidelines]

    TeamViewer was SO good, SO useful for helping my mom, and accessing my home PC from the road...UNTIL NOW.😣

  • johnwmreed
    johnwmreed Posts: 5 ✭✭
    edited June 2021

    I have tried six times for a reset. My 3 desktop computers work fine with Teamviewer (they can connect to each other).

    My iPad app continues to time out connecting to my 3 desktop computers after six resets.

    Is there anything I can do to fix?

  • abailao
    abailao Posts: 1

    I have two computer and an iPhone. By using my iPhone and my account i can access the computers; however, when I try to connect from my MacBook to a personal computer the TeamViewer keep timing out the sections saying that a commercial use was detected.

    I do not know why TeamViewer flagged me as a commercial user since I use only for personal purposes.

    Sincerely yours

  • MarkBarendse
    MarkBarendse Posts: 1

    I am having the same problem all of a sudden. I have never had this hassle before. How can this be fixed?

  • uatvsp
    uatvsp Posts: 1

    I am having problem with teamviewer free in a PC after upgrading to Windows 10. I had teamviewer installed on that PC for several years and never had any problem using it free with the older version of Windows. But immediately after upgrading to Windows 10, I am getting kicked out when I try to use teamviewer.

    Does not make any sense since the PC is running Windows 10 Home edition, used only as family room PC connected to a TV, and teamviewer usage on it is very very light - even for a free user. I see no reason whatsoever to flag this PC for commercial usage.

    How can this be fixed?

  • ZTT0821
    ZTT0821 Posts: 1

    I didn't use teamviewer for a long time. Today I use teamviewer to connect another pc, it shows limited connection, and disconnected immediately. I am very confused.

    I did not use it for commercial use. Why does this happen?

  • EdwardUK
    EdwardUK Posts: 47 ✭✭
  • bbbb0857
    bbbb0857 Posts: 0

    why i get block from connect to my friend pc ???

  • Sech
    Sech Posts: 0

    I would like to express my appreciation to TeamViewer for the last several years for allowing me to occasionally help out my Church through remote access to manage the HVAC system. But I received a notice that I was not able to use the Private Non-Commercial version. I read the info and suppose that because the Church although non-profit does have paid staff was the determining factor. I also used it for assisting my 80+ year old brother before he passed away. It is wonderful tool and I will miss it. A big THANK YOU for allowing the use of the service. Take care

  • Givskov
    Givskov Posts: 1
    edited June 2021

    Dear Teamviewer,

    I am trying to support my old mother on 88 - and get kicked off after one (1!!!) minute - thus making your software totally USELESS.

    This is not the first time, I have experienced this - and thought that the wouldn't be a problem anymore.

    However - I was wrong, and your software piles up in the stack of useless **bleep**!!

    So I guess that's a goodbye after many years - I'll look for something more usable!


  • Elpeacen
    Elpeacen Posts: 1

    I use Teamviewer to help my legally blind and deaf sister in law. She is using some magnifying software that makes her screen very large, like each letter about 2-3 inches on the screen!

    Occasionally, she gets stuck and can't move on, usually some button to click that she can't see. My wife would drive all the way over there half hour each way, or 45 minutes rush hour traffic just so she can move on with what she is trying to do on her computer.

    Also, I was using Teamviewer to access my other computer in the back of the house where my printer is to print documents on my printer. My printer is suppose to be wifi, but for some reason the wifi does not take. I can then access the computer back there that is wired to the printer to print something.

    However, I got nabbed as suspected commercial use. I have tried to explain this to Teamviewer but I haven't heard back from them yet for several day. So far my sister in law is okay, but not forlong. I'm not using it for work, I print things for my religious congregation. Is this commercial use as per Teamviewer policy?


  • akram1400
    akram1400 Posts: 0


    I want to cancel the ban on the program I have, as I only use it for home devices only (my children) currently I cannot access the devices and work on them for more than one minute, then the program is closed or the session is closed

     using the free version of TeamViewer

    I want a solution to this problem I have....thank you

  • Trillous
    Trillous Posts: 0

    I have no idea how this has happened, but now my sessions are time-limited. How can I prove that it's a free account?

  • redavenger
    redavenger Posts: 6 ✭✭

    this teamviewer support and accusations is terrible.

    i went through the whole reset process, got a email saying that it was reset, but it didn't fix anything im still getting disconnected after 30 seconds.

  • Thomas97
    Thomas97 Posts: 1
    edited June 2021

    Hello. I use the program Team Viever To help my nephews because they can not handle the computer. I use this program only for private, non-commercial purposes. When trying to connect I gets a message that the free session is over and is blocked until e.g. 14:42 but when this hour passes I still can not connect. So why was my account blocked and I can no longer connect to help my nephew, to help my family. Can you unlock my account in some way? If yes, I would ask for it very much!

  • Nolan565
    Nolan565 Posts: 0

    I am getting a request time out error whenever i try to connect the vpn for using TV. Is there any proper solution?

  • Irena0507971
    Irena0507971 Posts: 1
    edited June 2021


    I'he been using free license Team Viewer  for non-commercial use only – to connect to my home computer.

    But after few minutes the connection is lost:

    This was a free session sponsored by sessions are free of charge for personal use.

    Your license limits the maximum session duration to a partner, immediate reconnects are blocked.

    Can you help me with this problem?

    [Removed as per the community guidelines.]

  • niv
    niv Posts: 0

    Hey, I'm getting a message "commercial use suspected" and then I get disconnected.

    of course, I'm not using the software for any commercial use. I'm using it for my own laptop and pc and helping my family.

    What should I do?


  • Freejim
    Freejim Posts: 0


    I'm using Teamviewer to help friend with their computer's problem. Recently, TV close the session after one minute and indicate that I'm "probably" using it for commercial use.

    I'm not. How can I make it work ?

    Thanks for the help.



  • mikel36
    mikel36 Posts: 0

    I have been assisting my dad learn how to use his laptop and my other family members if they have an issue with their PC.. but recently im getting timed out.

    i looked it up.. and i found out that because team viewer judges it as commercial and i have to subscribe.

  • Kevin_D
    Kevin_D Posts: 1


    i have a similar issue, randomly (once a year maybe) i receive a message stating that commercial use is suspected, it isnt and in for me to help my family f they have issues or to log into another computer of mine. i have used Teamviewer for years but this issue started about 2 years ago, after a while it goes back to normal? i am currenly getting this message and i have tried to get feedback before from TeamViewer via the app and have yet to receive a reply - 2yrs now.

    From reading the comments is the only way to ask for a reset and see what someone decides? Is anyone aware of what makes the s/w think it is being used commercially?


  • KenPersonal
    KenPersonal Posts: 1

    I have been playing by the rules. Yes I use this from a computer that is connected to a commercial environment. They have connected to my computer after I logged out, when I logged back in, I use it for personal use, however after 3 seconds I am booted out. $50 a month for 4 devices is a bit rich. a $1.00 a month per device, I could consider that. But again my use is for PERSONAL access. What gives?!?!

  • Juro
    Juro Posts: 1


    I'm using TeamViewer only for personal use when accessing my PC or helping out my 70 year old aunt with hers, however I can only stay connected for a minute after which TeamViewer disconnects me and tells me I'm using it for business.

    I'm not using it for business, I do play fair so I'd appreciate if you could remove this restriction from my account.


  • DeborahPittRivera_66

    I live in NY and have an 82 year old mother in Ohio. She is not able to do much on the computer and I used to be able to help her through team viewer. Now it kicks me out after 30 seconds. I do not use it for business as we have different platforms here and teamviewer is not one of them.

    How do I resolve so I can help mom?

  • zaryabk
    zaryabk Posts: 0

    I have been using TeamViewer for many years to help family & friends out, but suddenly a few days ago, it started saying commercial use detected. I have never used TeamViewer for anything commercial. I found a reset request form & when I submitted it, two days passed & I got an email saying my account had been reset. When I tried using TeamViewer, I got the same message, so I checked all the information I had given & it was all correct. The only option it gave was to retry by doing the process again. At this point I have done the process over 5-6 times & I keep on getting the message, Commercial use detected & the connection timing out after a minute. I do not know what to do at this point. Has anyone had this before?

  • Ander13
    Ander13 Posts: 1

    Please, how can we use the non-commercial license again? Recently, the program started telling me that your license only supports a certain session duration. I have only 6 PCs added in the TeamViewer Management Console, and when connected to each of them, the program will disconnect me after a few seconds. I want to use a non-commercial license to connect a PC to a friend and family.

    thank you