Commercial use - Connection time out



  • Irena0507971
    Irena0507971 Posts: 1
    edited June 2021


    I'he been using free license Team Viewer  for non-commercial use only – to connect to my home computer.

    But after few minutes the connection is lost:

    This was a free session sponsored by sessions are free of charge for personal use.

    Your license limits the maximum session duration to a partner, immediate reconnects are blocked.

    Can you help me with this problem?

    [Removed as per the community guidelines.]

  • niv
    niv Posts: 0

    Hey, I'm getting a message "commercial use suspected" and then I get disconnected.

    of course, I'm not using the software for any commercial use. I'm using it for my own laptop and pc and helping my family.

    What should I do?


  • Freejim
    Freejim Posts: 0


    I'm using Teamviewer to help friend with their computer's problem. Recently, TV close the session after one minute and indicate that I'm "probably" using it for commercial use.

    I'm not. How can I make it work ?

    Thanks for the help.



  • mikel36
    mikel36 Posts: 0 Newbie

    I have been assisting my dad learn how to use his laptop and my other family members if they have an issue with their PC.. but recently im getting timed out.

    i looked it up.. and i found out that because team viewer judges it as commercial and i have to subscribe.

  • Kevin_D
    Kevin_D Posts: 1


    i have a similar issue, randomly (once a year maybe) i receive a message stating that commercial use is suspected, it isnt and in for me to help my family f they have issues or to log into another computer of mine. i have used Teamviewer for years but this issue started about 2 years ago, after a while it goes back to normal? i am currenly getting this message and i have tried to get feedback before from TeamViewer via the app and have yet to receive a reply - 2yrs now.

    From reading the comments is the only way to ask for a reset and see what someone decides? Is anyone aware of what makes the s/w think it is being used commercially?


  • KenPersonal
    KenPersonal Posts: 1 Newbie

    I have been playing by the rules. Yes I use this from a computer that is connected to a commercial environment. They have connected to my computer after I logged out, when I logged back in, I use it for personal use, however after 3 seconds I am booted out. $50 a month for 4 devices is a bit rich. a $1.00 a month per device, I could consider that. But again my use is for PERSONAL access. What gives?!?!

  • Juro
    Juro Posts: 1 Newbie


    I'm using TeamViewer only for personal use when accessing my PC or helping out my 70 year old aunt with hers, however I can only stay connected for a minute after which TeamViewer disconnects me and tells me I'm using it for business.

    I'm not using it for business, I do play fair so I'd appreciate if you could remove this restriction from my account.


  • I live in NY and have an 82 year old mother in Ohio. She is not able to do much on the computer and I used to be able to help her through team viewer. Now it kicks me out after 30 seconds. I do not use it for business as we have different platforms here and teamviewer is not one of them.

    How do I resolve so I can help mom?

  • zaryabk
    zaryabk Posts: 0

    I have been using TeamViewer for many years to help family & friends out, but suddenly a few days ago, it started saying commercial use detected. I have never used TeamViewer for anything commercial. I found a reset request form & when I submitted it, two days passed & I got an email saying my account had been reset. When I tried using TeamViewer, I got the same message, so I checked all the information I had given & it was all correct. The only option it gave was to retry by doing the process again. At this point I have done the process over 5-6 times & I keep on getting the message, Commercial use detected & the connection timing out after a minute. I do not know what to do at this point. Has anyone had this before?

  • Ander13
    Ander13 Posts: 1

    Please, how can we use the non-commercial license again? Recently, the program started telling me that your license only supports a certain session duration. I have only 6 PCs added in the TeamViewer Management Console, and when connected to each of them, the program will disconnect me after a few seconds. I want to use a non-commercial license to connect a PC to a friend and family.

    thank you

  • Miroslav83023
    Miroslav83023 Posts: 1
    edited June 2021


    Can you please delete my history of PCs?

    I am using software for my personals PCs and you can see that is only 5 PC on the list.

    Thanks in advace,

  • Tkut
    Tkut Posts: 5 ✭✭

    I'm pretty young and don't know if I should put this stuff in in the form.

  • RobertP
    RobertP Posts: 0

    I mainly use TeamViewer to connect to my media player pc. My usage of this software has not changed and this is the second time it has been locked due to false detection of commercial use.

    I need it unblocked !

    Many other people must be getting falsely blocked as I am again.

  • For over 7 months and submitting 4 forms to reactivate my account because I am 65 years old and did not want to travel up 12 stairs to the basement computer (personal computers) no COMMERCIAL USE, recent back surgery among others due to a car accident, thru no fault of mine, and still I can not log on without the same message "Commercial Use It appears TeamViewer is being used in a commercial environment".

    There is no commercial environment when I have been on disability for many years and enjoy using the internet without climbing up and downstairs to my basement. I DO NOT KNOW WHAT ELSE I CAN DO TO GET REACTIVATED, AS THEY HAVE STATED 4 TIMES. Soon it will be eight months and I am going back in again for back surgery. HELP😣 PLEASE😪 Is this happening to you?

  • DUG
    DUG Posts: 1

    I've been using teamviewer for years. Lately when using on Windows, my connection timesout after a minute or less however on a MAC it does not timeout even though it is the same free account. I tried various fixes but nothing seems to work. Any ideas?

  • FuzzmanKs
    FuzzmanKs Posts: 54 ✭✭

    I assume that you have provided, on the RESET MANAGEMENT form, ALL of the Teamviewer ID's that you connect to. Therefore I can't help but wonder if there is something that is triggering the flagging of your account. Have you scrolled back in this thread a month or two to find any helpful hints? Did you read the first message in this thread along with the Blog that is mentioned in the first message? Some things I've learned that can trigger the flag is connecting to or from a work network system. Connecting to church, personal interest clubs (fishing, ham radio, etc), volunteer organizations...basically anything that is not personal at home connections. It has also been mentioned above that if you have a video conferencing program installed on your device, that may trigger the flag. If you can't find any helpful hints above in this thread, maybe it is a good time to start searching for another free provider. I found one that I have configured as a backup for me.

  • Yenwen
    Yenwen Posts: 1 Newbie

    Dear community,

    I've submitted the declaration for personal use of my TeamViewer account three times...

    I received emails from the TeamViewer team two times that indicated my IDs had been reactivated, but I still failed to connect to my remote device. I submitted the declaration the 3rd time on June 1st, 2021, but I have not received the response and the reset webpage ( still showed that my request is pending.

    A message showed "Connection blocked after timeout. Your license limits the maximum session duration to a partner, immediate reconnects are blocked." 

    I would appreciate if any of you can provide insight or suggestion of how to solve this issue...

    Thank you,


  • Abiba
    Abiba Posts: 1 Newbie

    I have the same issue since yesterday after the update! i cannot connect to the devices! and i cannot find how to contact the support!

  • Akusho
    Akusho Posts: 0 Newbie


    I'm sure everyone is sick of these questions, but I've been trying to re-activate my PC for remote use for the past 2 months.

    I have sent two requests to remove the flag for commercial use and both were granted, in one I thought listing my account is enough so the computers under it will be un-flagged, the second time I listed all IDs I use, but I still can't access my computer without timing out.

    Is there anything to do here, or TeamViewer support is just the way it is and I should move on to greener pastures?

  • gee_dee_ell
    gee_dee_ell Posts: 6 ✭✭

    LIkewise, I have been advised on a few occasions that my IDs have been reset and service restored. Most times this has been proven false by not being able to connect for more than a minute or so between laptop and desktop. I did two weeks ago believe TV had cracked the problem, I had bilateral communication between them. However, just yesterday I entered the the TIMEOUT BLOCK zone once more.

    Just WTH is going on with TV algorithms to propagate this misery for users who are "playing fair".

  • garytgtx
    garytgtx Posts: 0 Newbie


    Hi. I have been using free option system for a good few months now, especially over covid lockdowns. I only use it to connect to my dad's laptop, so i can help him to log in, to watch/stream football games, etc. My dad is an 88 year old OAP, with severe memory issues and can struggle with password logins etc, so this has been a brilliant tool for us. I even put a review on trust piolet saying this. I have and would never use it for any commercial use. I recently got a new laptop, but everything worked fine until I 'upgraded to latest version' the other night. it then locked me out on a timer, but every time I went back, it just moved the time on again. Tried again tonight, but it still wouldn't work. 

    I have tried the suggested form, but when I complete it, nothing happens when I press 'crate PDF', so can't get any further than that.

    I don't know what I've done to make it think I'm breaking the rules, but I'm honestly not and hope you can help me with this. Cheers.

  • Elen4ik
    Elen4ik Posts: 1 Newbie

    I'd like to claim that my TeamViewer account is suspected as Commercial, however I'm using it only to access a couple of my own devices and my parents' PCs. I can prove it by providing all the necessary data about each device. Waiting for your comments. Thank You!

  • josepferrer
    josepferrer Posts: 1

    This is not serious, three times that I request that my computers be reset, three times that you tell me that it is done and three times that they are blocked. What's going on ?

  • tdhardy843
    tdhardy843 Posts: 0 Newbie

    My teamviewer free version keeps giving me a message "Connection blocked after timeout" .

    I reached out to support once and sent a form in that I wasn't using my license for commercial use. I received an email that it had been resolved but it didn't.

    I tried uninstalling teamviewer and its settings on both of my computers and reinstalled. Same result.

    I then did the same thing and created another account, again with fresh installs. Same result.

    Is there anything I can do to restore the functionality of the free version or am I at a point that I should look for other software?

  • I'm having the exact same issue. I also wasn't using it for commercial use and was told the restriction had been removed.

  • Karel_Zeman
    Karel_Zeman Posts: 1 Newbie

    Yes, I have the exactly same problem. For computer where I'm connecting to I asked for ID unblocking for 3 times. I received positive answer for all 3 request but connection to this computer is still blocked (Your TeamViewer session has timed out and will be closed). My ID is OK because I don't have problem to connect to another computers.

    Please could somebody from TeamViewer company fix this issue?


  • dwp
    dwp Posts: 2 Newbie

    Where can I find the "Don't tag me as a commercial user" form?

    I miss using this utility, it worked and was easy, but I haven't used it in 2yrs. since I have been flagged as a commercial user. Really?

  • demenicis
    demenicis Posts: 2 Newbie

    I'm trying to provide valuable help to my Mum in brazil, while im in the UK, since about almost a year I my account is being blocked after 1 minute connected.

    I definetelly do not use it commercially, just check how often I use it please.

    I beg for this limit to be removed as I have now a pile of unresolved issue on my mum's side.

    Please help, thanks in advance

    Luiz Demenicis

  • demenicis
    demenicis Posts: 2 Newbie

    Just having this same issue.......flagged as commercial for helping my mum/dad once a week?

    Now my dad died (covid19 + parkingson) and I cannot help my mum doing anything. what a shame ths automatica assumption users are cheatting their usage....


  • sjacobs
    sjacobs Posts: 1

    This suddenly began happening yesterday. After connecting successfully, TeamViewer (ver. 15.18.5) times out after 2 or 3 minutes. Please note that this is NOT related to commercial use. The first time I attempt to reconnect, I receive the following message:

    I get the same message whether I attempt to reconnect immediately or 30 minutes later (the "blocked until ... " time is always 2 mins after my first reconnect attempt).

    Can someone please assist? Thank you.