Commercial use - Connection time out



  • FuzzmanKs
    FuzzmanKs Posts: 54 ✭✭

    This would not be the proper thread to put your suggestions. This thread is (apparently) community-user-based support only. No TV employees here. I'm sure there is others parts of this forum that is for suggestions.

  • dkenefake
    dkenefake Posts: 4 ✭✭

    I have one PC that has apparently been flagged in error for commercial use. I've requested and been granted a reset three times but still get kicked off a minute or two after connecting. I tried calling for support but was sent to this community for answers.

    What do I need to do to get a home PC cleared to use after numerous resets fail? Can I change the Teaviewer ID for this machine and start over? If so, how? Should I continue asking for a reset until one sticks?

    If this has happened to anyone else and there's a solution out there please help me find it.


  • PaulGureghian
    PaulGureghian Posts: 2 ✭✭

    When connecting from Win10 to Arch Linux on a RPI3.

  • jetman67
    jetman67 Posts: 2 ✭✭
    edited June 2021

    this free version has turned into a joke, machines I have used for years set up as private use work once and because I have a bad connection i loose connection, try to reconnect then it blocks me and tells me its for personal use and connection blocked because of timeout and i have been connected for 1 minute. Im over this and im not paying the crazy price of 50 a month for a private usage thats totally unrealistic for a single license, must be time to look for another solution, pity this was a great free tool


  • jetman67
    jetman67 Posts: 2 ✭✭

    so many complaints for the same issue, this company needs to get its act together

  • FuzzmanKs
    FuzzmanKs Posts: 54 ✭✭

    @EdwardUK - I noticed that. I had pretty much decided that most of the folks posting asking for help have not done any reseach and that I was only going to respond to those it appeared to have done some research first. I might still unsubscribe from this thread because I'm not sure anyone is getting our responses. Maybe i should have been including the @ Username . I did get a notification from TV forums that you had mentioned me in a comment. I assume it was because you included the @ and not because you Quoted a message i wrote. I agree that TV should provide some information on what an account holder might try and do. A link in their warning pop-up would be good.

  • Virtualizedude
    Virtualizedude Posts: 1

    The timeout after a few seconds is happening between any 2 pcs. Not able to use teamviewer now.

  • xaris
    xaris Posts: 1
    edited June 2021

    My suggestion is that you search for another alternative.

    It happened to me before. I rarely used Teamviewer. Maybe once or twice a year. But when I do, I may be a couple of hours cnnected to one or two computers.

    The first time, I sent an e-mail asking them why I was flagged for commercial use, and they didn't explain but they allowed me to use it again.

    That was a year ago. I've been a couple of days trying to connect to my server and another computer that's having problems connecting to the server. And I can't. 30 seconds and I'm out.

    Then it says that my coneection is blocked for a minute or so. I try again, and again the same message saying that the connection is blocked.

    Desperate, because I can't go to the office (I had an accident, and I can't walk for the moment), I decided to pay one month of the license.

    And not only the price has gone up quite a bit, they pretend that I pay for a full year... they don't give you the choice to pay only for a month.

  • Fuloskop
    Fuloskop Posts: 0

    hello i use team viewer to my all pc close or controlling and use my girl friend pc use but Did team viewer limit the session because it thought I was using it for a commercial job. Can u help me

  • Mik4
    Mik4 Posts: 2 ✭✭

    Same issue, sooooo frustrating as Teamviewer is quite rarely needed when there's enough time....😁

    I do not see any recent solutions btw.

  • GlennG
    GlennG Posts: 0
    edited June 2021
    Hi guys,
    One of my home computers (Jupiter, a Windows 10 machine) has been
    blocked because of suspected commercial use. I put in a statement
    through the automated system but have not heard anything back. The
    Teamviewer ID of Jupiter is XXXXXXX. It appears that the
    Teamviewer ID in the PDF I submitted is that of the machine I was
    connecting from (a Mac).
    I have since looked through my Teamviewer connection logs and suspect
    that the machine was locked out for reporting a location of 'London'. My
    home location is Sydney. However, Jupiter is connected to my TV and I
    use a VPN (Hotspot Shield) to stream media from the UK. I forgot the
    machine was still on the VPN when I connected (the VPN stayed connected
    overnight). Jupiter never has, nor ever will be physically in London.
    As I noted in my original correspondence, I am semi-retired and do not
    use Teamviewer for commercial purposes. I mainly use it for controlling
    machines around my home (several linux boxes, a Mac, a couple of Pis and
    a Windows 10 machine---Jupiter---and a WIndows 7 box that gets switched
    on occassionally). I will occassionally provide computer support to my
    I would appreciate you reenabling access to all my machines.
    Looking forward to hearing back from you shortly on this matter.
    (Donald) Glenn Geers

  • Stephan3
    Stephan3 Posts: 7 ✭✭

    Same issue here.

  • fog2222
    fog2222 Posts: 5 ✭✭

    Seems that if they have stopped allowing free personal use the could at least state that instead of ignoring everyone. I've moved on.

  • ericb819
    ericb819 Posts: 1

    I'm trying to use this for personal use to help out with my relatives like its meant to be used for. The license says (non-commercial use) which I believe that is right??

    The error I'm getting says (Your TeamViewer session has timeout and will be closed) while i am showing my family a certain program. Why I try to reconnect I get (your connection is blocked for a minute)

    All of the computers that I have this installed on are registering the same non-commercial use. Anyone know why this is happening? Unless i need to request a account

  • FuzzmanKs
    FuzzmanKs Posts: 54 ✭✭

    @dkenefake When you fill out the Reset PDF are you including both TV machine ID's? Is one of them running a server operating system? Are you using a work internet connection to access your home PC? Scroll back up for the last month or two and you will probably find some helpful tips. Machine ID's do not change even if you uninstall/reinstall TV. More on machine ID's here:

  • FuzzmanKs
    FuzzmanKs Posts: 54 ✭✭

    @xaris - Servers are not allowed on the free program use. From your description, connecting into the office sounds like commercial use to me. I think you are being flagged because of this:

  • FuzzmanKs
    FuzzmanKs Posts: 54 ✭✭

    @Fuloskop - I don't understand your question. Please use punctuation to format sentences and give more details. Maybe someone can help.

  • FuzzmanKs
    FuzzmanKs Posts: 54 ✭✭

    I don't think you will hear from Teamviewer since you are a free user. Read the first message in this thread and the blog it mentions. I think you should resubmit the Reset PDF and list the TV machine ID's of each computer you are using AND connecting to. I think you can list 10 machine ID's (don't use spaces between the coma). I suspect the VPN is what caused the problem and not the fact that it appeared you were connecting out of country.

  • aussipeter
    aussipeter Posts: 2 ✭✭
    edited June 2021

    I have a FREE version of Teamviewer to supprt 2 elderly sisters and 2 older friends. My remote 'assistance' has been working well for the last 4 month however lately I have difficulties logging in with one of them and after a few seconds connecting (putting in their PW) I am getting repeated error messages advising that I exceeded the session time although I had contact for no more than 20 or 30 seconds. The message then says that I can log on after 1 minute which does not work. Repeated attempts after alonger break end up with the same result.

    What can I do? I am a pensioner and don;t have th emonies for a commercial licence - thank you!

  • 2021年06月14日12時27分48秒
    edited June 2021

    Dear Sir/Madam,


    As I mentioned in my previous emails, I am using TeamViewer only for private use.


    I have sent the self-declarations four times (May 13, June 1, June 7, and June 10, 2021). I received your troubleshooting emails on June 5, June 8, and June 11, 2021, but TeamViewer is still cutting out after one minute.


    The main PC, used by only myself, is fixed at my office. I do not share my office or main PC, and I am the only one with access to my office and the main PC. I have been remotely controlling the main PC from my home for checking emails and reviewing papers a few hours a week.

    As this issue has still not been resolved, I would like to delete my current TeamViewer ID and set up a new one. Please delete my TeamViewer ID as soon as possible.


    1. Main PC ID: ***Information removed as per Community Guideline***

     2. ID when accessing from home: ***Information removed as per Community Guideline***


    Thank you,

  • milcs
    milcs Posts: 5 ✭✭


    I am a personal, long time user of TeamViewer. I would say, I have been using it for longer than 10 years now (give or take).

    A few months ago, I started getting logged off from TeamViewer, within one minute of starting a session. When pressing the button to ask for info, I was taken to a page saying that I might have been flagged as a commercial user. Which couldn't be further from the truth.

    I use TeamViewer to control my home computers. Mostly, controlling my desktop from my laptop (both Windows PCs). I rarely also use it to control an old iMac. All of these computers live at home. Except my laptop, that goes with me everywhere.

    The most use for TeamViewer, is to control my desktop, that sits in the same desk as my laptop. To avoid having to change screen sources and peripherals (keyboard, mouse, etc), I use my desktop through my laptop, most of the times.

    I have asked, for a third time now, to have my TeamViewer IDs reset. I have provided the IDs for the 3 computers (first time only one... didn't really realize I had one ID per computer) twice now.

    And I'm a bit desperate. There's no one that I can actually directly contact, I keep receiving automatic answers, and there isn't any progress after having tried to solve this situation.

    Could anyone advise me on what to do?


  • kimkash
    kimkash Posts: 6 ✭✭

    I'm a user of TeamViewer since the beginning of time and lately the mobile app (android, latest version) flagged my use as commercial use even though I'm only using it to connect to my remote PC's at home and at my parent's house. After 1 min the app force-closes the connection and won't let me reconnect for about half an hour.

    I searched the website for 15min in order to contact technical support but it seems TeamViewer don't open that option to someone who doesn't pay and only use their free service.

    How do I make it stop/where can I contact tech support directly so they can review my case with a human operator so they can unflag me as commercial use violator?

    Thank you very much for all =]

  • AhmedAE
    AhmedAE Posts: 0


    I'm using TeamViewer personally, and I'm not in a team group or a company, so how can I use it free with my 2 own laptops with out block?


  • milcs
    milcs Posts: 5 ✭✭

    @JoshP Thanks for your reply on my other post.

    I have to say though, that my problem is more complicated than


    First time I asked the reset, I only put my desktop ID. Didn't

    realize I had one ID per machine. I re-asked for a reset, this time with the

    three computer IDs. I received a confirmation saying that the reset was

    performed. Well... I still can't use TeamViewer. This is why I made my post. I

    know what I (theoretically) have to do to have my account reset. I’ve done it,

    I’ve received an email confirming the reset of my account… Still can’t use TeamViewer!

  • chadpeters
    chadpeters Posts: 1

    I have submitted the unflag/block forms multiple times now, and can't stay on the remote computer more than a few minutes before I get flagged again. TV for personal use is totally useless now since the commercial detection system is far too sensitive and results in a False Positive pay wall...

  • pcconsultinguk
    pcconsultinguk Posts: 1

    I have been 'identified' as a commercial user. I have gone thur the process of completing the online form 4 times and have recived 4 emails saying I am an authorised 'personal' user ........ see below .........

    Dear User,

    Thank you very much for sending your self-declaration of private use to us.

    We have successfully reset the TeamViewer ID(s) you submitted via the form provided earlier.

    We acknowledge that you are using TeamViewer for private use only on these devices.

    Yet when I connect to my wifes laptop and desktop I get kicked out. I am using my persoanl laptop to connect. My work laptop does not have Internet access.

    What is the point of completing the online forms, getting the e mails saying all is good, when quite clearly it is not all good.

    The question now is are the Support at teamViewer just not capable of performing the task required or do they, TeamViewer, just do not care?

    I have just submitted mt 5th online form ......... does anyone have more submissions than that?

  • KnottyCord
    KnottyCord Posts: 1

    TeamViewer thinks I'm using it for commercial use. Only helping my family. Now I can't even connect for more than 30 seconded at a time!

  • Bart_9283
    Bart_9283 Posts: 2 ✭✭

    Are your wifes laptop and desktop private computers and connected to a non business network? It seems that everything that has been connected to a commercial system is suspicious to TeamViewer.

    It seems that TeamViewer is overly active lately.

  • Fikson
    Fikson Posts: 1
    edited June 2021

    Hi! I Have a free plan subscription on my email at [Removed as per the community guidelines.] But I keep getting this error message" Connection blocked after timeout. Your license limits the maximum session duration to a partner, immediate reconnects are blocked. But i get this message only on this laptop, on any other device that I would eventually try it works, It just doesn't work on my laptop... I have the free plan and I don't need a business one, howcome it is free when it wont allow me to use it? And I doublechecked I didn't install any corporate product but the free version from teamviewer download page