link icon
Ask The Community

When I end my session, the friend I was connected to gets logged out on his Mac

I use TeamViewer to help an elderly friend across town. We both use Macs.

Lately, each time I disconnect after controlling his computer, my friend gets logged out, and he has to login again. This confuses him (he's 98 years old).  

If I reconnect I can see the login screen and login.This didn't used to happen. How can I end our session without him getting logged out? Anybody know? I just tried various ways of ending the session, but each time I reconnected I see he gets logged out and needs to login again.


Best Answer



  • Scotty
    Scotty Posts: 492 Staff member 🤠
    Thanks for posting!

    This is a setting that can be changed in TeamViewer on your side.

    Go to into the options of TeamViewer, then under "Advanced" > "Advanced Settings for Connections to Other Computers" > "Lock Remote Computer" and set this to "Never".

    I hope this solves this for you!
    Senior Moderator
    Did my reply answer your question? Why not accept it as a solution to help others?
  • douglerner
    douglerner Posts: 7

    Thanks for your reply. I'm afraid I don't see that setting though. This is what I see, in screenshot.



  • Scotty
    Scotty Posts: 492 Staff member 🤠

    Sorry, I just checked and realised this option in settings is missing on MacOS. I apologise for that, but yes it is here in the menu.

    I'm glad you worked it out!


    Senior Moderator
    Did my reply answer your question? Why not accept it as a solution to help others?
  • Instead of the quick support client, you should install the full TeamViewer on your mother's computer. There you can set it to allow remote access at any time without your mother touching anything. That's what I do when helping my 98 year old friend across town.

    Please post followup questions in a new discussion since this is a completely separate topic. Thanks.


  • mlp44141
    mlp44141 Posts: 1

    The "Lock on session end" check box stopped working in the latest update. I am using TeamViewer 12.0.78515 on MacOS Sierra 10.12..5 on the remote machine. I use TeamViewer 12.0.78313 on WIndows 10 to access it.

    Previously, Lock on session end was checked by default, and unchecking it would leave the remote machine logged in when I exited TeamViewer. Now it is not checked by default. Whether I check it or not. TeamViewer logs off the remote Mac when I exit.

    I saw a suggestion to set the option for Lock remote computer to Never, but it still logs out of the remote computer.

  • For a few days it was ok, but this started happening again.  Now every single time I close the sessiont the "lock" setting seems to automatically turn on again and my friend gets logged out. He's 98 years old, so finds that very confusing.

    When I connect again, sure enough I see the login screen. And when I look at the "lock on quit" setting it has gotten checked (turned on) again. I turn it off, but the same thing happens each time.

    This was ok for about a week, but then this started happening 100% of the times I end the session.

    Is there any way of getting that setting to stick (stay unchecked)?

  • DHK1
    DHK1 Posts: 15

    I have the same problem. Whenever I log out of a macOS session (10.12.5), Teamviewer 12.0.78507, my remote session is logged out, even though the lock options under "Extras" are NOT checked. HELP!

  • Same here. Teamviewer Host v 12.0.78517 H running on a Mac and accessed by a Mac. The only useful workaround I've been able to effect thus far is rebooting every time I'm done accessing the machine. That seems to do a pretty consistent job of making the session available for me for the next time. It's far from ideal, but it's better than not being able to connect outright. Any idea if this is being addressed yet? Cheers.

  • Hi. Thanks for the post. Was there any need for reconfiguration on the host end? If I lose that connectivity outright it will be very taxing for me to restore. Thx.

  • DHK1
    DHK1 Posts: 15

    Yes, this change WAS made on the host, not the client...

  • Ouch. That's not a viable solution for me at this time then. Maybe TeamViewer will have a less impactful fix for it soon. Thanks for the help.

  • Scotty
    Scotty Posts: 492 Staff member 🤠

    Hi Everyone,

    From the posts I think this may be being missed.

    I have clarified my previous post:

    The lock-out is initiated from the connecting device. Below is the instructions on how to stop this but it is different depending on the OS you are connecting from.

    -If connecting from a Windows device-
    In the software:
    - Options
    - Advanced
    - Advanced Settings for connections to other computers
    - Lock on session end
    - Change to "Never"

    Lock Remote computer.png

    -If connecting from MacOS-
    During a session:
    - Open the "Actions" tab"
    - Select "Lock Computer"
    - Uncheck "Lock on session end" (this will need to be done on each session)

    Lock On session End.PNG

    I hope this clarifies.


    Senior Moderator
    Did my reply answer your question? Why not accept it as a solution to help others?
  • Hi Scotty,

    Thanks for your post, but this is still not working on macOS for me. Both host and client are Sierra 10.12.6 with Teamviewer 12.0.90924.



  • Scotty, I think that's the point of most people's problem, certainly my problem. Lock Remote Computer IS set to Never on the host machine. Whenever connecting to a macOS machine (running Sierra or High Sierra) it always logs out on disconnect regardless of the host's Lock On Disconnect settings.

  • MtnKat
    MtnKat Posts: 1

    When you log out - is there just a big X or is it a dropdown?  If it is a dropdown, then your "lock on never" isn't working correctly.  Mine was working, then quit working even though it was still set to "never" on the windows host connecting to a mac remote machine.  I messed around looking at the different options in that same window and that seemed to make the "never" work again.

    I think it's a bug in Teamviewer.  They should hire me. :)

  • I have it set to "never" as well and every once and a while it still brings up the lock symbol on the X and I go to the dropdown to uncheck it. So the X is just the X now without the lock symbol and it'll still lockdown the computer when I disconnect. It only happens on Mac machines and it's been happening with Sierra and High Sierra on the later versions of TeamViewer 12.

  • PelicanMedia
    PelicanMedia Posts: 14 ✭✭

    I am connecting to Windows PCs from a Mac. Both using the latest available v13.

    This only happens on one Windows PC, (was happening on v12) updated to v13 and is STILL locking the PC when I finish the session. I have followed...

    During a session:
    - Open the "Actions" tab"
    - Select "Lock Computer"
    - Uncheck "Lock on session end" (this will need to be done on each session) 

    And the option stays unticked until the Windows PC is rebooted (scheduled to do so every night).

    This is not good enough that is has to be done EVERY session.

    Please mark this post as UNSOLVED, as it has not been resolved. Other posts also back this up.

  • I have a work around thta might help you. We are having the same issues at our university, but I belive it has something to do with the policies our IT team has imposed on us. 

    The work around that worked for me is to end the session (The host computer locks even though I have my setting set for this not to happen), remote in again, put in the password and end the session right away (before you get logged in). The computer cannot Lock if you're not fully logged in, so it stays logged in :)

    Hope it helps!

  • Thanks. I figured that out too but it does not always work 100% of the time. In fact I'd say it works less than 10% of the time especially with the Macs we connect to using SSDs. I noticed that the full client application received an update (not the Host version) within version 12 in the past 2 weeks and it seems to have corrected the issue. If you're still having the issue check for the latest version within 12. My version is showing as 12.0.92876.

  • Of course right after I wrote that reply I am having problems again. But it's also happening on one particular computer, out of ten, that runs Windows 10 now.

  • JohnD
    JohnD Posts: 35

    Unfortunately, this bug has been reintroduced in Mac v13.1.4170 (or maybe a close previous version).  Many of my hosts are now constantly reverting to automatically locking the host on disconnect, even when I explicitly uncheck Action > Lock Computer > Lock On Session End.

    This needs to be fixed again in the Mac Host.  And they need to explose a Host-side Advanced pref that can disable this useless and obnoxious feature, just like they have on the Windows Host.

  • Spiney
    Spiney Posts: 2

    This is driving my wife crazy.  I regularly connect back to our home computer (Mac, up to date) from my Mac (up to date) at work, and every time it locks the screen on her.  Please get this fixed.

  • JohnD
    JohnD Posts: 35

    Try the solution that I posted in this thread; it seems to work with v14.  It's a PITA, but if it works then it's probably worth it.


  • I am experiencing this issue on my mac on the latest release v.14 of teamviewer.  The setting is non-existent under the extra menu.  This seems to be a regression in code that might result when the teamviewer code does not have good test coverage that can catch regressions like this.

    As it stands, this issue is a deal breaker for me.

  • Same here. MacOS v14 doesn't have this option and it;s a dael breaker as I need remote computers to be busy processing video fies for hours after I complete a session. Logging out stop stops everything. Please help us TeamViewer!

  • After 3 years of forum discussions, this UI glitch ist still not fixed. TeamViewer doesn't care enough about MacOS. 

    Not a plattform problem (the standard defense), since the option works well on iOS, too.

    So SAD!1!

  • PelicanMedia
    PelicanMedia Posts: 14 ✭✭

    I agree it should have been fixed by now. As with most repeat bugs in updates that are never addressed.

    Would you like to borrow my brick wall?


  • Is this issue fixed? I am experiencing the same and it is extremely annoying, especially because it is for me as well a metter of work. There is no option to avoid this issue! 

Sign In or Register to comment.