link icon
Ask The Community

Not ready, Please check your connection

Hi, i'm using TeamViwer on a Windows 10.1 and since last month I couldn't connect to any computer since this message started showing up.

I've tried the support, and they only say to make sure that port 5938 has been opened for outgoing connections and also unblock the following URL:  *

Which I did, and it didn't work. I also tried to stop Windows Firewall and nothing changed.

I don't use any other security programs beside the windows defender and firewall.

I've been getting this error since I reinstalled Windows, it was working just fine before, nothing changed besides that. Any solution to this?



Best Answer



  • Chiron
    Chiron Posts: 226 ✭✭
    • Is networking OK? Make sure internet access is working, access to file shares, printers, etc.
    • Can others connect to you with TeamViewer? Check if the problem is just outgoing connections.
    • Did Windows update to build 1703? We have had some issues with other applications after that upgrade.
    • Have you tried re-installing TeamViewer? You can keep your settings, watch for the checkbox during the uninstall wizard.
    • What version of TeamViewer are you using? May need to upgrade (or down-grade).

    Let us know if you find a solution!

    I don't work for TeamViewer. I'm just a user.
    • Yes, my internet is working just fine, and I can see other computer in my network
    • They can't, since my teamviewer doesn't show any information like ID or Password neither let me connect to my account
    • Yes, my Windows 10 PRO is at 1703 build
    • Yes I tried a clean reinstall
    • 12.0.82216, I've tried installing v11 and didn't work
  • It was deactivated, I set to "accept" and the message teamviewer shows is "Only LAN Connection avaliable". I was successful in triying to connect to my IP address.

    Here is how I set my firewall Outbound and inbound rules.

    teamv rules.jpg

    I have also paste the below in "C:\Windows\System32\drivers\etc\hosts"

    "# Teamviewer"

  • Chiron
    Chiron Posts: 226 ✭✭

    OK, so TeamViewer functions on LAN. Are you in Germany? Because I am in the USA and my IP addresses don't match yours.

    I can ping and it resolves to

    Try to ping one of the servers, if it fails try tracert to see where it stops.

    I don't work for TeamViewer. I'm just a user.
  • I'm from Brazil, I got those ip on a youtube video trying to fix this issue, I could not ping to them, are there others I should include on that host file?

    Here is tracert to master15

    "Rastreando a rota para []
    com no máximo 30 saltos:

    1 1 ms 1 ms <1 ms
    2 * * * Esgotado o tempo limite do pedido.
    3 12 ms 12 ms 8 ms []
    4 21 ms 20 ms 23 ms []
    5 24 ms 26 ms 23 ms []
    6 140 ms 142 ms 139 ms []
    7 131 ms 130 ms 134 ms
    8 194 ms 200 ms 197 ms lon-sb4-i.LON.GB.NET.DTAG.DE []
    9 196 ms 213 ms 194 ms
    10 199 ms 224 ms 197 ms []
    11 208 ms 208 ms 207 ms []
    12 208 ms 208 ms 206 ms []
    13 * * * Esgotado o tempo limite do pedido.
    ....14 to 30 time out. ...."

  • I put the same DNS as the computer teamviewer was working and it worked in mine too. I even deleted the teamviewer entries I had on Host file.


    Thank You very much!

  • yes

  • Not reeady 

  • i am using google dns and teamviewer v12 never worked for me but v11 is still running excelent.. my pc is resolving the same dns ip's like lookup for every masterx subdomain.. On my windows server it's the same problem..


  • My teamviewer cannot connect after update windows update KB4033631 at my tablet.

    I have to uninstall the update and the teamviewer can conenct again.

  • Biwel
    Biwel Posts: 3

    gabriel0515  :can you explay how you did that?

    and khchuang :how did you know what update you need to delete ?

    i did a lot updates and dont have the one you have.



  • I went on the other computer TeamViewer was working on:

    Network and Sharing Center > Change adapter Settings > Right click on the connection > Propieties > IP V4 Protocol  to see what DNS that computer was using, and did the same thing on mine to put the same DNS. You can also do that by cmd command.

    It was a DNS problem for me, so try chaging you DNS somehow

  • Reinstalling did solved my problem.

  • this happened to me during AVG installation. See if that ain't the problem. I re-installed Teamviewer, signed back in, VOILA! 

  • I have two questions

    1. yesterday, I was working on one of my client's computers and Windows was asking for the administrator (domain) credentials. The TeamViewer screen blanked and at the client's end, it was waiting for the credentials to be installed. I had to abort doing this remotely because I didn't want to give the client that information. Thus, a trip down to their office.

    So, is there a way to get around this?

    2 second question, when I restart a workstation, sometimes I'm given the option to reconnect after a restart but most times not. How can I set that so that I always am able to log back in without the client having to re-run the TV program and sending me a new password?


  • I have no teamviewer entries in my hosts file, nothing blocking it in router, pc firewall is off, my PC DNS matches DNS in router settings, I can ping the server (and others)... yet still no connection. Any ideas?

  • I have a similar issue with my laptop whereby at home Teamviewer is not ready but if I vpn to the office or use my laptop in the office, Teamviewer works fine.

    I've checked the routing tables on my router, all good, checked the firewall rules, TV is allowed (uPNP is on anyway but I added a specific rule anyway)

    Still no joy, so as of now, if I need to use it at home, I use the vpn to my office first.

    If you touched it and it stopped working, the first question to ask is "Did anyone see me touch it..."
  • This video will show you how.
  • I have many of these problems on many workstations. Usually it is connected with ESET Antivirus. So what I do (that always helps) is usually:

    1. Add teamviewer and teamviewer service to exclusions in scanning. Then restart pc.
    2. Run in command line (as admin):
    netsh winsock reset
    netsh int ip reset
    (then restart) that usually helps and teaviewer starts to connect again.
    3. If above doesn't help, I go to network interfaces in device management and then delete lan and wifi interfaces (without deleting drivers) - just delete interfaces and restart pc.
    These steps always help to restore teamviewer connectivity.

    Many of my hosts fail randomly after some windows updates (i think). I often have to use other software to remotely connect to a host, use these steps in order to repair teamviewer.

  • My problem resolved when I unchecked the "Use new interface" option (under the General" tab)

  • thank you.
    Its work for on the no. 2
  • I tried all above suggestions above to no avail. I inherited my laptop from company that went Bankrupt in July 2018. I think the TV ID: (tied to MAC address?) has not changed and I suspect the TV ID is blocked by teamviewer. If there are actually TV internal support persons here that can help, please email me at [edited by a moderator] and I can send you the TV IF to check internal records. I have used TV in both windows and Linux since 2009 and really enjoyed using it. Thanks everyone for the above suggestions. Very Frustrating problem and support access seems limited without a valid license.

  • Well, I found out that also Eset Security (NOD32 Antivirus) is blocking Teamviewer, too. I exclude Teamviewer_Service.exe from scanning, restart PC and it's working again. Try that way, too. Maybe some AV is blocking it.

  • The other thing that can do this is a broken IPv6 network. Turn off IPv6 on the client and see if it works.....

  • SFFS
    SFFS Posts: 2

    Check to ensure the proper firewall settings exists.  

    When I started receiving this error, I found that the settings for the Private network were not allowing Teamviewer to connect.  It was only allowed on public networks.  Allowed private networks and it connected immediately.

  • All of a sudden i had faced same issue. I went to task manager, deleted all teamviewer processes, and then started teamviewer again. Guess what, it worked.  This is just a workaround and not solution but atleast your work won't stop.



  • itchibahn
    itchibahn Posts: 8 ✭✭


    #2 fixed it.


  • all of these solution not working for me

    but i found a way to fix it 

    in my hosts file the localhost was commented i just uncommented it and reboot. and tada all work again. don't ask me why these appen i just don't know 


Sign In or Register to comment.