link icon
Ask The Community

Commercial use - Connection time out



  • airplane-4b7416
    airplane-4b7416 Posts: 12 ✭✭

    TW says it seems i'm useing a commercial version but is not true-I use tw from my home to take control of pc i have at my mother house to control radio,I'm a radio operator

  • Hello,

    Lately I've received the dreaded "commercial use detected" from my account. Didn't think much of it, more than that it's wrong. My computer runs Windows 7 Pro. Accessing my HTPC, running Windows 10 to control the music this happens every time. Same thing happens when I access my Windows 7 computer from my Windows Mobile (yea I'm one of the few still using them...) or the HTPC

    However, from my Android phone or tablet, accessing my Windows 7 computer this does not occur, which makes be believe it is something with Windows 7 connection to and from certain units. Any thoughts?

  • gailp123
    gailp123 Posts: 2 ✭✭

    I've used my personal use TeamViewer without trouble until today. Now I'm booted out after 5 or 10 minutes. What's happening?

  • WegrzynAB
    WegrzynAB Posts: 1

    Hi all,

    I am using Team Viewer to help me with my PhD research (when I need to access my workstation at university on weekends or on holidays to run scripts). Is that a commercial use? I didn't see any clear statement from the TeamViewer team on it. If yes I am happy to pay for an academic license; however, the current licensing scheme doesn't discriminate between students and business, while the amount of money in the pocket is clearly different for these groups :/ 


  • I currently have issues with all remote Raspbian clients as they are stuck on V11
    Host PC running Linux Mint 17.3 Rosa and thats on V12

    Unable to 'upgrade' the application which has worked perfectly for ages - I'm a long-term user of TeamViewer. I suspect that this upgrade path is directly connected to Teamviewer's 'protect/increase our income stream' ethos because when June arrives, I get the feeling I won't be able to connect at all. I'm currently getting blocked on reconnects due to this infuriating timeout and forced upgrade - is there a V14 armhf .deb ?

    The armhf architecture support was very good but has since deteriorated. I don't hold out much hope for the future unless the situation changes.

  • Custodes
    Custodes Posts: 1

    I have some thoughts about this. This is not about them having 'detected' commercial usage on your system. This is all about new avenues of monetizing for them and pressuring users into buying into a commercial license.

    This nonsense started for me a few weeks ago as well, after which I submitted a request online to unblock the account -- which is not being used for commercial puposes whatsoever.

    Today I received an email stating that they were unable to discern private usage.  If they actually capture any of these sessions for commercial usage detection (using some machine learning algorithm) they have some work to do, because some of that usage with my girlfriend has been anything but commercial. 

    The only thing that did change is that I started using OpenVPN to dial into my home network to ensure an encrypted connection from wherever I use my laptop. The changing IP networks is probably what triggering this nonsense. I have no intention on changing that as there are more than enough alternatives to TeamViewer. 

    ps. The mail I received today also had a link to a printed form that is laden with spelling mistakes and duplicate fields. You might want to look into that dear people at TeamViewer GmbH, it comes across amateurish.

  • Kinz
    Kinz Posts: 1

    I have changed my pc and now i am not allowed to perform any changes on using any platform.

    Please reset my moves again.


  • Swarf
    Swarf Posts: 1
    Exactly the same here, and I just use it to my own pc from my phone, had the mail saying they’re unable to confirm private use. I mean, I’m not using it to get any sort of payment and just play Webb games when not able to move to pc, their algorithms for commercial use detection is just broken and pushes me away tbh, after years of using it this way it’s suddenly commercial? And if they accept the form which I have little to none hope for, will they do this again later on for the same week wait then what ever the wait is to accept the form? :/
  • Teamviewer derived that I'm doing a professional user of their software, and thus restricted the session to few minutes. I dont know what sort of algorithm are they using, but it is wrong in my case. I'm retired and I have no business activity. As it is a free use, I cant get any support. Any idea to restore my normal use ?

  • Kebab
    Kebab Posts: 1

    My account has also been flagged as business use, I am connecting to my home PC from an android tablet purely for personal use.

  • I started getting a warning that it looked as thought I was using TV for commercial use; I'm not, and to avoid future problems I wrote to explain why this was a false positive. Now, they do say it can take up to a week to deal with such things (!) but a few days later I try to connect as usual and am told there is a maximum session duration and to try again in ~10 minutes. When I do the connection lasts ~30s then times out again.

    It is now impossible to use TV in accordance with the free license terms!

    This is infurating given that I tried to address this issue in advance - the very least they could do is put a "hold" on any blocks given that I provided my IDs and other a/c information.

    What does TV plan to do to resolve these issues for me and other legitimate users of the fre license - which TV actually offers!? W|e don't get support but they do get useful data from our usage and recommendations... which I am now seriously thinking about broadcasting retractions of.

    Sadly, since this is the "community" all I actually expect is a lot of "me too's" but just in case TV is listening...

  • Narey
    Narey Posts: 1
    I know there’s like a billion posts here regarding false positives, but I thought I’d make my independent post to that TeamViewer can look into my usage and determine the real use of my account.

    I simply only ever remote into my home computers (Windows and Mac) from my iPhone, and now I’ve been flagged for commercial use.

    Could you please look into it and remove the false positive?

  • eurotrash
    eurotrash Posts: 1

    Nothing new now, as per the other recent threads.

    Got a "COMMERCIAL USE DETECTED", I assume because I use TV all the time - although it's always between just from one of my machines to another, entirely personal. So ok, it said the session will be terminated after 5 minutes, I thought ok that's enough time to do what I need to do. But no, it terminated after 27 seconds, and of course the subsequent connection attempt was blocked and I have to wait 10 minutes... for what, another 27 seconds connection time?

    Granted I'm using the free version, but way to drive people away from your product! Today I'll be looking into alternative products since obviously TV no longer wants anyone using its free version... would be better if they just annonuced they'll be retiring the free version on some date rather than attempting to force people away by making their usage expeience as unpleasant as possible. I'm expecting the next update to install a virus on the client machine, "HA THAT'S WHAT YOU GET FOR DARING TO USE THE FREE VERSION!"

  • Nirgal76
    Nirgal76 Posts: 1

    i use teamviwer from my office computer to connect to my home computer (only in that way) for personal stuff, not any commercial stuff. is it considered like commercial use ?

  • vasileioslogas
    vasileioslogas Posts: 3 ✭✭

    Im using TW 10 years in last 3 years what happents i dont know all the time lock and im use it in my home network not commercial and all the time this is get locked 
    Please fix this it looks like you do it just to annoyng the free users until to change programm or to buy lol!
    How can be commercial in the same lan ? omg .......

  • WillDx
    WillDx Posts: 2

    Just fill form here
    I had same issuse with teamviewer for about 3-4 times on 4 years peroid. 

  • WillDx
    WillDx Posts: 2

    Just fill form here
    I had same issuse with teamviewer for about 3-4 times on 4 years peroid. 

  • najim
    najim Posts: 1

    hi i need help


  • FormerUser
    FormerUser Posts: 1

    They're not offering any solutions to blocking you and I

  • pv7721
    pv7721 Posts: 139 ✭✭

    @FormerUser : as announced, TV 9 stopped working for me, I switched back to version 14 and at least for now it works; I noticed a difference on Android, though: each time I launch it it activates itself (so it's a bit slower at the beginning)

  • Xandor
    Xandor Posts: 8
    I already filed the form,multiple times !
    I get told between all my machines and my phone it's commercial... (and your reply was that it was reset to commercial! Yet it's still the same!)
  • pv7721
    pv7721 Posts: 139 ✭✭

    @Xandor : who exactly told you that?!? I too use phone to PC (but most of the time I'm in the same network, it's just a convenience to monitor it from another room).

  • Xandor
    Xandor Posts: 8
    @pv7721 I sent the form I was told to, and got the following back:
    Dear TeamViewer User,

    Thank you for getting in touch with us. We are happy to inform you that your TeamViewer ID has been reset to “free”. After reviewing your request, we decided that your use case can be qualified as “personal”.

  • pv7721
    pv7721 Posts: 139 ✭✭

    so it's ok for you or not yet? Have you restarted TV?

  • Xandor
    Xandor Posts: 8
    Mainly using it between my computers and my mobile, and it's not fixed on any of them.... even after multiple restarts.. the mail I received with it being reset was 1 1/2 week ago...
    Their whole new system is a farce and a joke and will do nothing but push away customers..
    (I use it at work as well, but other other accounts, I am closing those down now.. not gonna bother supporting team viewer with the **bleep** they are pulling.. )
  • pv7721
    pv7721 Posts: 139 ✭✭

    @Xandor : oh I see, I did the following: filled out the form for ALL the IDs I've been using (my PC, my mum's and brother's) because they say you have to do it like this; if you do it for only one ID, your account might get flagged again for the other IDs. I did receive only one reset to free (but they don't say for which one was) and I've also received a form to sign and send back. Eventually the warnings and flagging stopped, but I wonder what'll happen in version 15 (and by the way, the workaround to going back to version 9 and stay there without updating is no longer working, as they've deprecated this version, and you got automatically disconnected after 5 minutes).

  • Cjm1975
    Cjm1975 Posts: 2

    How do I submit this form?

    I am getting the exact same message about commercial use.

    When I try to contact Teamviewer it says you cannot unless you have a Licence.


  • Cjm1975
    Cjm1975 Posts: 2

    Thank you. I have submitted a ticket. I hope this works.

  • pv7721
    pv7721 Posts: 139 ✭✭

    @Cjm1975 : You're welcome. Hope always dies last.