Samsung Knox and TeamViewer

Esther Posts: 4,052 Former Community Manager

Hi all fellow Samsung users,

we are happy to share the exciting news with you that we’ve entirely revamped our mobile apps, and with that: We are now fully compatible with the Samsung Knox security platform!

What does that mean for you?

  1. Direct connection through Knox: No additional AddOn for Samsung devices must be downloaded and installed!
  2. Better connection performance!
  3. Support for even more devices likes Galaxy A and M series!
  4. New, fast, secure architecture!

Please allow me to invite you to update your TeamViewer QuickSupport and Host Apps on all Samsung Android Devices to ensure seamless remote connections to devices with Samsung Knox.

How to get the great new TeamViewer Apps?

  • Install or update your QuickSupport and/or Host Android mobile apps to the newest version:
    1. You can do this easily through the Google Play Store app on your mobile.
    2. Or, by downloading the QuickSupport or Host app directly from TeamViewer’s website:

That´s it! Now you can connect easily from your PC or mobile device using TeamViewer.

Note: Corporate and Enterprise customers can update their mobile devices directly through their Mobile Device Management or Enterprise Mobility Management solutions.

Note: After mid-January 2020, the Add-On: Samsung will be discontinued

We hope you are enjoying the new and updated apps and the seamless TeamViewer experience.

Thanks and best,



Former Community Manager



  • Galaxy S5 duos. Host ask for Knox. Enabled. Connection crash after one minute.

  • Samsung Galaxy S5: "Unfortunately, Host has stopped" Samsung Galaxy S8 seems to be working OK. the Host app doesn't stop like on the Samsung Galaxy S5
  • Downgrade to version 15.0.4. All back to normal.
    A ticket was created for me. But I'm a free user, so I can't reply the email with the log files.
    If the team provide a human-read email address, I can send it.

  • How did you downgrade? I have been receiving the "host crashed" app message while connected to teamviewer every couple of minutes while connected to teamviewer

  • There was obviously some kind of update made to my Samsung galaxy today, as when I connected teamviewer to it this morning I received a message that Samsung Knox was required to be authorized before connection was possible, and since that authorization I have had the host app crash every couple of minutes while connected through teamviewer… Can anyone provide any advice on if this is possible to correct?

  • @pghdev wrote:

    How did you downgrade? I have been receiving the "host crashed" app message while connected to teamviewer every couple of minutes while connected to teamviewer

    I've find a site with all old apk versions. I will not link here, but it's easy to find.
    But don't forget to disable auto update on Play Store.

  • KINY
    KINY Posts: 2

    Well, this is quite sad. Got 200 users i am no longer able to support with TeamViewer. The screen goes black OR i cannot control the samsung Knox Devices. Ive got it to work on one fully managed device, but workprofile does not seem to work. Really sad we just renewed our knox license. 

  • We have over 100 devices that aren't working because of this update. Do you have a timeline of when there will be a new version that fixes this issue with the QuickSupport app crashing on Samsung Tab A devices?

  • Same situation for me.  Host worked fine on my Samsung Tab A tablet with Android 9 until a couple weeks ago.  Since then, the connection freezes/drops within seconds of connecting.

  • The "revamp" seems to have destroyed the app altogether.  Everything was fine on my Samsung Tab A tablet until a few weeks ago.  Now, Host freezes/disconnects within seconds of connecting.  Completely unusable.

  • [removed per Community Guidelines - please do not post third-party TeamViewer download sites]

    I'm using without any problem. It's safe.

  • Trialing TeamViewer Host for Android to determine if we can use this in our organization.

    Tried to get it running on a Samsung tablet running the latest version of TVH.  When I start the app, it attempts to activate remote control, and then I get an Activation Failed message.

    I've tried it with Knox enabled and with Knox disabled...

    Can anyone help?

  • w4lter
    w4lter Posts: 7 ✭✭

    Hello @Esther ,

    do you have maybe an Update for us?

    The Version 15.1.24 is broken with Samsung Devices.
    We only get a Black Screen when QuickSupport is started in a Knox Container.

  • Esther
    Esther Posts: 4,052 Former Community Manager

    Hi all

    Thanks heaps for your comments.

    I checked internally and our devs are aware of the issues with the Samsung AddOn and are already working on a fix.

    For now, I do not have an ETA, but I will keep you posted.

    Best, Esther

    Former Community Manager

  • Any update on this issue ? We have more than 2000 smartphone concerned by this issue...

  • Hi, any update, please?

    Concerned devices ~2500

    FYI, on an Galaxy S10 with actual Android 10 update is is still working.

  • Please make a official link to the old version 15.0.4. Or replace on Google Play.
    It seens a lot of old Sammy devices were affected.
    So the DV team can resolve the issue without stress.

  • Esther
    Esther Posts: 4,052 Former Community Manager

    Hi all,

    Are you working with an MDM?

    Which MDM are you using?

    Thanks for your help,


    Former Community Manager

  • Hi,

    Some of our customers are using Microsoft Intune and some MobileIron. 

    Both of them are having trouble using teamviewer Quicksupport. 

    Kind regards, 

    Patrick Hogeboom

  • Hi

    We are using Microsoft Intune.


  • px
    px Posts: 1

    We are using Samsung Knox on Galaxy Tab A SM-T510 devices.

    I can connect to a tablet from my PC, but the PC capture goes black when opening apps.

  • We are using Workspace one linked to knox mobile enrollment for samsung's devices.

  • Knox-Apollo
    Knox-Apollo Posts: 2 ✭✭

    Hi all!

    @Esther when can we expect a solution? ~300 devices can´t be supported.

    We are using Knox-Legacy and Android-Enterprise container configured by Knox Manage.



  • ERAG
    ERAG Posts: 10 ✭✭

    We have more than 300 Android Devices, we ordered this months additional 100 Android Devices and we cant managed these tablets anymore. When is a fix available?

  • Workspace One on prem on our side.

    Samsung harware aswell

    Since today no Android 9 devices can't be remote control (no change made since last year on these devices profil / apps).

    Host and Quicksupport on Android client don't work.

    Devices on Android 5 (legacy profil) work fine but the Android 9 Android Enterprise don't.

  • Good afternoon
    After updating the QuickSupport app on our Samsung TAB A tablets, most tablets are unable to be accessed. Presenting several problems.
    Between them:
    When accessed, displays a black screen and can not do anything.
    Displays the ID screen and is not accessed.
    I can't sign in after entering the ID.

    I need a solution that doesn't need to go tablet by tablet and upgrade. There are over 60 tablets using Quicksupport.

    Images of the problems:

    Problem black screenProblem black screenProblem IDProblem ID


  • Hi Esther

    Please would you be able to provide an update on progress so far.  This issue is impacting 3000 devices within our organisation.


  • Currently having a ticket open without any response since last week

    Ticket number:  33304263

    I have 1'000 devices (Android) that I can't remote control anymore.

    Devices are on Android 9 (Full managed Android Enterprise)

    Samsung devices : SM-T395

    MDM : Workspace One UEM

    Issue : Each time we are tying to connect to a device, I got the following message after the Remote control window open ""Your partner rejected your connection request". Other features work as intended, only remote control impacted.

    The issue appear either that I use the Teamviewer Host function or the QuickSupport.

    On client side (Android):

    - Host 14.4.183

    - Teamviewer Addon Samsung  14.2.53

    - QuickSupport 14.4.195

    APK are directly install through the MDM and not using Google Play.

    On desktop side:

    Windows 10 laptop

    - Teamviewer 15.1.3937

    We did not pushed any update (app or new MDM profile) since the end of last year and back then we did not had any issue.


  • KINY
    KINY Posts: 2

    We are having the same issues for Samsung Knox enrolled devices with WORKPROFILE, all fully managed devices work, but not work profile. This is quite critical as we are using quicksupport to support users with billing hours to customers and so on. When we cannot remove help them they have to come in and this is starting to cost a lot of money. Way over what we pay teamviewer for things to work... @Esther