link icon
Ask The Community

Touches on Samsung Galaxy S9+ inaccurate


My parents both have the above phones, which I help them with remotely via TeamViewer.  Screen touches do work, but are only accurate at the very top left of the screen.

The further I am from the top left of the screen on the control program (Android or Windows10), the touch on the remote device is closer to top left.  I would guess the touch is around 90% of the way to where I think I'm making the input, regardless of where I touch on the screen.  This makes controlling the device next to impossible, which is an issue for my Dad's phone as he's in early stages of dementia, so struggles with the phone if I can't set it back to his default view for him.

Am I doing something wrong here?  Or is the Galaxy S9+ not fully supported.  I've tried using different home screens on the devices.  I've tried different display zoom settings.  Nothing works.

Testing on my Galaxy S20 Ultra provides excellent experience with the touches being exactly where I have expected them to be.


  • Vatsilidis
    Vatsilidis Posts: 661 Star


    Have you tried to disable for a moment the screen auto-rotate, once in portrait and once in landscape mode?

    Best regards

  • Hi,

    I've tried "Auto rotate" and "Portrait" modes from the Notifications drop-down.  But the phone screen never rotates anyway.  Either way, the touch scaling issue is still apparent under both settings.

    The phones run Nova Launcher normally, but the same scaling issue happens under One UI Home.  Normal display settings are:

    Font - default

    Font size - second from top

    Screen zoom - middle setting

    I have also tried with the default font size and screen zoom, but the input scaling still happens.  It's as if the wrong dpi is being used to translate the input from TeamViewer to then being pushed on the remote device.

  • I think I've just resolved it.  It seems to be working if I set the Screen Resolution to maximum (WQHD+ 2960x1440).  The scaling issue creeps in on FHD+ and HD+ resolutions.

    This is odd, however, as my Galaxy S20 Ultra works properly only on FHD+ resolution rather than HD+ or WQHD+.

    Is it worth raising this as a bug or feature request?  I suppose I know the answer to my problem and can work around it.  My parents won't notice the difference in running at WQHD+, although it may drain their battery slightly quicker...

  • Vatsilidis
    Vatsilidis Posts: 661 Star

    Good news then!

    I was ready to give you the hint to put the default settings to your phone, since that it seems to relate with changes in the device default settings.

    Best regards

  • Argh!  Super annoying.  One Galaxy S9+ requires screen set to WQHD+, whereas the other requires it set to FHD+.  I've tried all combinations of wiping QuickSupport data & cache, uninstalling, making sure both phone resolutions are set to the same when re-installing.  No difference.

    Again - I can work round, but now the phones are in slightly different configs.  It's just one more thing to remember, but still a pain.

Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!