teamviewer.com link icon
or
Ask The Community

When I end my session, the friend I was connected to gets logged out on his Mac

2»

Answers

  • @Domenica_Farci No, and probably won't be! Why would a multimillion-dollar company listen to the plebs like us that pay for and use their software?!

  • Here is the solution for Mac machines. As you can see from the attached screenshot, in your device (not on the remote one) you have the upper bar of the Teamviewer windows. with some options, among which there is "Actions". You click on "Actions" and you have a dropdown menu; choose the option "Lock Computer", and remove the tick on the option "Lock on session end" (which is there automatically). Issue solved ? 

    Screenshot 2020-05-05 at 09.27.27.png

  • @Domenica_Farci Try again in a few minutes/hours/days it will be back to being locked! Issue not solved ?

  • JohnD
    JohnD Posts: 35

    @Domenica_Farci wrote:

    Here is the solution for Mac machines. As you can see from the attached screenshot, in your device (not on the remote one) you have the upper bar of the Teamviewer windows. with some options, among which there is "Actions". You click on "Actions" and you have a dropdown menu; choose the option "Lock Computer", and remove the tick on the option "Lock on session end" (which is there automatically). Issue solved ? 


    That is not a "solution" for the underlying bug in TV.  At best it is an awkward and time-consuming (when you have to do it all day long over many machines) workaround for the code flaw in TV that randomly sets a remote session to lock the remote machine.  It causes enormous problems in my enterprise environment, especially when combined with other TV bugs and feature failures, and the impact should not be minimized.

  • TechyMark
    TechyMark Posts: 5

    You apparently missed the entire thread. The complaints people were having after the original post were that even with that option deselected it would still lock the Mac.

  • JohnD
    JohnD Posts: 35

    @TechyMark wrote:

    You apparently missed the entire thread. The complaints people were having after the original post were that even with that option deselected it would still lock the Mac.


    You apparently missed the accepted "solution" (again, just a workaround) that douglerner posted waaaaay back in 2017, which was to uncheck the Lock on session end option (and it has been reiterated by others since then).

    @Scotty from TV early on suggested the permanent way to solve it, without initially realizing that it's a Windows-only option that inexplicably and inappropriately doesn't exist on the macOS version of TV.  He then reiterated that super-annoying and time-consuming workaround for macOS.

    The remainder of this thread since then is mostly us whining at TV for not fixing the $%^*# underlying feature flaw and associated bugs in the first place, hoping against hope that the TV devs of the macOS version get their act together and implement this.

    :-)

  • @douglerner, in your photo that's what I see too. I know this thread is 3 years old, and you've already solved it, but I wanted to update it by replying to say what I did. (I found this thread with a Google search; others may too.) I didn't have the same link you did; I don't even have an Actions menu, so no "Lock" settings. (Edit: It wasn't clear in your post the "Actions" menu/tab is during a TeamViewer session.) Perhaps that's because of a newer OS now or newer TeamViewer, but under Access Control on your screen shot, the dropdown list has an entry for Custom settings and beneath that, Configure. One of the "Configure" options is Lock the remote keyboard and mouse, to which I selected Denied. What I want to prevent is locking the computer and returning to the login screen, but changing this setting to Denied did prevent going to the login screen, so I'm a happy camper.

  • JohnD
    JohnD Posts: 35

    @afwings unfortunately that does not work.  I edited my TeamViewer (controlling) app prefs on macOS to "Denied" for the Lock the remote keyboard and mouse setting and then remoted into another Mac that usually has the Lock Computer > Lock on Session End setting enabled by default, and unfortunately it was still set that way, and when I disconnected it still screen-locked the remote computer.

    I wouldn't expect a setting called "Lock the remote keyboard and mouse" to prevent locking the screen (that setting is more about denying the remote user the ability to mess with the keyboard/mouse when the system is being remote-controlled), but I was hopeful.  Sadly, it doesn't work, so, we're still waiting for the TeamViewer macOS development team to get their #$&% together and fix this longstanding bug.

  • smtips
    smtips Posts: 1 Newbie

    So I want to bring this up again. The so-called solution to uncheck Lock on Session end does NOT function at all on Mac OS Catalina. This thread has been somewhat annoying to read through with all the disagreement and confusion about one single feature that is broken and seems to have been forever on Macs. This simply does not work at all. It was NEVER turned on, on either of my machines (Sierra local, Catalina remote) and I've toggled it on and off today trying to correct the issue with the remote Catalina getting locked on end session every single time, and this function most certainly DOES NOT WORK ON THE MACS. TV needs to get their head together and actually READ their own forums and address this long-standing issue and correct it.

Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!