Highlighted
Posted by
Henagon

Paid but still no activation key

Like many others we paid for Teamviewer on Monday but still no activation key - Im trying to work from home and my free trial ends today.  So they have the money and I assume I'll lose access overnight.  As I havent got the activation key I cant even contact anyone!

I know everyone is stressed at the moment but maybe if TV could put some information on their website or automatically extend the trial that would help lots of people stuck in this same situation while we wait for TV to catch up.

5 Replies
Highlighted
Posted by
Digon

Re: Paid but still no activation key

I had the same issue. It took 10 days for me to receive mine. I contacted sales and they realized they had a typo when entering my email address into their system. I suggest calling the sales phone number and maybe they can get you straightened out.

3 Replies
Highlighted
Posted by
Henagon

Re: Paid but still no activation key

Thank you for your response.  Unfortunately I have tried this and it is now all automated messages directing you to the website or to raise a ticket - for which you need to have received the activation key.

Highlighted
Posted by
Henagon

Re: Paid but still no activation key

Can someone advise or point to where to ask or follow up on 'Paid but still no activation key '?

any email address or phone number for teamviewer support?

Highlighted
Posted by
Digon

Re: Paid but still no activation key

Right, I experienced this as well. Found myself in an endless loop with no help, because I didn't have my key. I actually filled out a form for new sales and explained my issue in the notes section. They called me back either same day or next day (can't remember, last few days have been crazy) seeing that the email address they had in my system did not match the one I entered on the form. They corrected the mistake quickly at that point. Wish there was more I could offer to help!

Highlighted
Posted by
Henagon

Re: Paid but still no activation key

Many thanks.  I have now done the same and hopefully I'll get it sorted.