Announcements

The Community is moving next week! 

Find all information incl. the timeline and tips for a smooth migration here.

Posted by
Henagon

Subscription not showing up

I bought a yearly subscription on Saturday. I was charged, and the money was taken out. I have order numbers and links to activate the license, and while it worked on Saturday, it now shows up as a free version. I cannot reactivate it, becuase it says that it is already activated on the account, even though it doesn't show up. I'm unable to submit a ticket becuase my account shows up as a free account, and I cannot get ahold of anyone on the phone. 

This has to be the absolute worst customer service expirience I have ever had, not to mention I just paid over a hundred dollars for a service I cant even use.

2 Replies
2 Replies
Posted by Moderator Moderator
Moderator

Re: Subscription not showing up

Hi @andrewstuchlik,

Thank you for your post and we are sorry for the negative experience.

I may confirm that your license has been activated successfully on your email account. Kindly login your licensed account on TeamViewer again before initiating any remote control connections please. Please noted that you would like activate the license ONCE on the account. If you would like to know more about the activation on the remote device, kindly visit How to activate your Remote Access plan. Or simply visit our Remote Access Support Hub for more assistance. Hope it would be helpful.

Feel free to contact us if there is anything we may assist further with.

Warm regards,

Ying_Q 

Posted by
Henagon

Re: Subscription not showing up

Same issue

tried all mentioned steps

what a **bleep**! no support ticket, no response to support email for days... 

Can you guys resolve it???

@Ying_Q