Posted by macgill
Henagon

A connection could not be established. Teamviewer not running on partner computer.

Am trying to connect away (laptop) with home/office PC.  Every time i am away, i encounter this problem message.  i need to get someone to click on the teamviewer icon on my home office computer to connect.  I have enabled remote access, listed both computers as trusted "contacts" etc.  Have updated to Teamviewer 12 on PC and laptop and still have same problem.  please help.

 

43 Replies
Highlighted
Posted by elbea64
Tetragon

Re: A connection could not be established. Teamviewer not running on partner computer.

Do you have set up unattended access?

This is needed to connect with your own, always the same password and it sets TeamViewer to run at system startup.

Connection -> setup unattended access will guide you to set it up. And follow this to make your host secure.

»We are all born unique, but most of us will die as a copy.«
4 Replies
Posted by 2JBMarch
Photon

Re: A connection could not be established. Teamviewer not running on partner computer.

TV will be working. Then when I re-estblish connection, it replies that TV is not running on Partner

Posted by justjill27
Electron

Re: A connection could not be established. Teamviewer not running on partner computer.

This is exactly what I get too. It works and then if I close the window on my home computer it thanks me for using it but I cannot reconnect later as it says it is not running on partner computer.

Posted by smartypantz
Henagon

Re: A connection could not be established. Teamviewer not running on partner computer.

I have this problem as well. It used to work just fine, and then suddenly something changed and I can't connect. I have rechecked settings multiple times. I tested the connection while sitting in front of the computer to confirm it was working, then tried to access it away from the computer and it claimed it was not running anymore. Now I'm wondering if it has something to do with the computer sleep settings which are preventing access after a period of time, though I can't think of any settings that were changed between then and now...

Posted by crescomm
Photon

Re: A connection could not be established. Teamviewer not running on partner computer.

same problem here. TV has always worked, have not touched remote computer settings and now 6 hour drive from remote offline computers on Christmas holiday. Unhappy.

Posted by Danmo43
Photon

Re: A connection could not be established. Teamviewer not running on partner computer.

Been working on my machine remotely for a week. Nothing changed. Now I get this message and cannot connect to my machine.

Posted by VGPete
Photon

Re: A connection could not be established. Teamviewer not running on partner computer.

I have this problem as well. I have rechecked settings multiple times. I tested the connection with my partner's computer to confirm it was working, then tried to access it away from the computer and it claimed it was not running anymore.

My partner is able to connect to my PC via TV, howerver I'm not able to connect to his PC via TV.

Very frustrating.

Posted by Dynamike
Electron

Re: A connection could not be established. Teamviewer not running on partner computer.

I setup TV13 on my desktop and I get this message anytime the computer sleeps. Anyway to connect when the computer is asleep without changing the sleep setting to 'Never'?

Posted by blendilm
Electron

Re: A connection could not be established. Teamviewer not running on partner computer.

HAS ANYONE FOUND A SOLUTION TO THIS PROBLEM?!! 

Posted by MarkF
Electron

Re: A connection could not be established. Teamviewer not running on partner computer.

Exactly the same for me too. It was fine before. Something has changed. Perhaps they changed something in the latest update? 

I think there is something in the sleep settings theory as on one of the occassions I tried to connect to my desktop computer from my laptop, after failing, while I was doing something else, it notified me that my desktop computer had just come online. I think it's because I have a scheduled task that runs every hour on my desktop and, if I catch it during this time, I can connect. 

Frustrating but then I don't use it often, thankfully.

 

 

Posted by three-jeeps
Digon

Re: A connection could not be established. Teamviewer not running on partner computer.

The silence is deafening.  ..

I have the same problem, yes, configured to be in unattended access (which didn't work until I found and applied 'the fix'....

Yes, I don't use it that often but...it seems when I *really* need it, it doesn't work....sigh

Suggestions? solutions? anyone???

Posted by eNdOne
Henagon

Re: A connection could not be established. Teamviewer not running on partner computer.

I cannot believe there has been no attention to this issue. 
It is not a new problem either.
There are bouts of unusability with software which steer me further and further away from it. 
Advice on alternatives that dont drop when you need it most? 
This is just costing me time & money, as im sure it is alot of other teamviewer users. 

Posted by three-jeeps
Digon

Re: A connection could not be established. Teamviewer not running on partner computer.

after taking LOTS of time to find out and try some solutions on my own, I decided to look for alternatives to TV.  I was surprised to find at least 6 that are free for personal use, and a few that have reasonable costs commercial (non-personal) use.  Rather than beat my head against the wall trying to determine a fix, I'll try one or two of the alternatives.  What really drove me to do this is the fact that my searches turned up LOTS of this type of problem that has been going on for over a year, with the same dead end...no solution proposed or discussed by Team view.  That lead me to the conclusion that they just plain don't give a s**t....

 

Posted by artauer101
Photon

Re: A connection could not be established. Teamviewer not running on partner computer.

What the **bleep** is wrong with TeamViewer? They are constantly advertising about buying their paid product however something like this goes unanswered for OVER A **bleep** YEAR!!!

What I have noticed every time that I run into this problem is that TV shows the machine in question has been offline for so many days....even when I am on that machine and see the services running!

I have used TV for several years, pretty much since it came out, and because of the lack of support I am jumping ship this weekend!

 

Posted by sgroner
Photon

Re: A connection could not be established. Teamviewer not running on partner computer.

I don't believe the answer is another program.  I am experiencing the same problem on only one computer.  I have tried other programs wth the same result. 

I believe that the problem is associated with the Win 10 sign-in screen.  My other computers don't have this feature.  It appears to me that the sign-in screen disconnects the computer from everything (probably as an energy saving measure).  I say this because when I turn off the sign-in screen (by entering the password) I get a message that my scanner is ready to work.  In fact, the scanner does nothing if the sign-in screeen is on.

I tried to eliminate this sign-in screen, without success so far.  After reading some of the comments I have jus now turned off all screen saving features.  Perhaps this will work.  Like all of you, I am disappointed that TV has not remarked about this problem. 

 

Posted by Rbailey154
Henagon

Re: A connection could not be established. Teamviewer not running on partner computer.

Alright everyone after a painful week of messing around changing settings testing changing them back and trying something else. I have found the solution. The problem in Windows 10 is related to the way in which the machine acts when you choose to sighn in with your Microsoft account credentials. I’m not sure why the lock screen functions differently but when you have Microsoft account sign in turned on the lock screen says CTRL-ALT-DEL to log in. So today i switched from using my Microsoft account to unlock the machine to using a local account and now I can use my TeamViewer account to wake and connect to the machine. Try it for your self.
Posted by eNdOne
Henagon

Re: A connection could not be established. Teamviewer not running on partner computer.

Really glad you've found a solution for Windows users. Us Mac peeps are still stuck in the mud... Bleh
Posted by asciigod
Henagon

Re: A connection could not be established. Teamviewer not running on partner computer.

Everytime I've encountered this (including 30 seconds ago) it's been fixable by stopping and restarting the Teamviewer service.

I only use Win7, but the process is start > run > TYPE "services.msc" ENTER

Then find the TV instance on the right side, right click, stop, right click, start.

Fingers crossed it keeps working.

Also, typically it's a problem on the PC I'm using, not the remote machine (thankfully!)

Good luck all.

Posted by Tango-Bravo
Henagon

Re: A connection could not be established. Teamviewer not running on partner computer.

I have installed Team Viewer 13 on my office computer Linux Cent OS 7. I connect from my home Windows 10 computer. I am able to connect to other Windows machines from home but the Linux Cent OS 7 workstation. The latter apparently refuses connection after one hour (or two). It is like, you are able to establish connection for a short time. Then, the connection severs and I get a message "Team Viewer not running on partner computer", although it is running. Surprisingly, after this severing happens, if someone touches just the mouse on my office computer, the TV can reconnect. So the following are the possibilities-


1. Does Team Viewer sleep after one hour of connection at my office?
2. Is it because the office is behind a firewall?

The problems keeps me going to office even on weekends, which is not great.

Posted by Nightwalker83
Electron

Re: A connection could not be established. Teamviewer not running on partner computer.

I have this problem now to! Before all I had to do to ensure the remote machine connected was select "Accept" instead of "Accept Exclusively" in the "General" area under "Extras". However, that is not working either I still get an ip address showing instead of the id regardless of which option I select and apply.
Posted by DayofJudgement
Henagon

Re: A connection could not be established. Teamviewer not running on partner computer.

I had a similar problem with one of my co-workers. It didn't work either, but later found out that due to hibernation on win10 TV stops working, even though the computer is ON.

Another co-worker also had the same problem but on this occasion i had to go into Task manager and kill all proccess related to TV, then start up TV and it worked after that.

Dunno if this will help anyone.
Posted by LMFT61
Henagon

Re: A connection could not be established. Teamviewer not running on partner computer.

I agree. Every time window 7 updates and restarts my office computer I lose my remote connection from my home laptop. I have no idea why Teamviewre shuts down after an update. Has anybody else had this particular problem?

Posted by Murphy10
Henagon

Re: A connection could not be established. Teamviewer not running on partner computer.

I was having this problem as well.  Then I got to thinking about when I used to use the free LogMeIn app.  I don't remember which OS I had at the time, but was pretty sure it didn't have a "sleep" option (or else I had it turned off).  So, I turned off the sleep option - can still log off - and have had an entire week problem free!  If you're not familiar with how to do this, it will be something like this (may vary slightly depending on your OS version).  On the remote computer access:  Control Panel/ Power Options/Change When The Computer Sleeps and choose "Never".  You can still time out the display to show your screen saver.  

Hope this helps ya'll!

Posted by staggart
Electron

Re: A connection could not be established. Teamviewer not running on partner computer.

This worked for me: If we have two machines, the one we are connecting TO and the one we are connecting FROM. I exited TV and restaretd it on the machine I am connecting FROM and that worked - I could then connect to the other "TO" machine.  Before trying that I had rebooted, etc. the machine being connected TO and that never worked.

Posted by skedaddle
Henagon

Re: A connection could not be established. Teamviewer not running on partner computer.

I'm having the same problem connecting from a Win 7 machine to a Win 10 machine.

Restarting the teamviewer service does not work. I doubt it is related to the Win 10 sign on screen, as TV works for often two or three days at a time. Eventually though, I am unable to connect from the Win 7 machine and have to restart the Win 10 machine (which is headless, and a royal pain in my arse).

Posted by ya
Henagon

Re: A connection could not be established. Teamviewer not running on partner computer.

I did, but still the same problem
Posted by SherryD
Henagon

Re: A connection could not be established. Teamviewer not running on partner computer.

You just may have answered my question...

Posted by MEShields
Neutron

Re: A connection could not be established. Teamviewer not running on partner computer.

I have three computers: one in my office, one in the lab and the third at home. My office computer gets this same message when I try to connect to either the lab or home computer. However, the lab and home computers connect just fine to both of the others! 

Why?????????????????

Very frustrating.

Posted by Moderator Moderator
Moderator

Re: A connection could not be established. Teamviewer not running on partner computer.

Hello MEShields,

Thank you for your message.

In that case, if you are on a Windows operating system, I recommend you to restart the TeamViewer service.

-Execute "run", type "services.msc" and press OK

-Now find TeamViewer, and restart it by doing a right click.

Then, restart the TeamViewer application. It should work again.

If you are using iOS, I recommend you to uninstall TeamViewer with deleting the settings, and re-install it from our website here.

I hope this could help. If not, do not hesitate to contact us again.

Cheers

French Community Moderator
Did my reply answer your question ? Accept it as a solution to help others.
Find this helpful ? Say thanks by clicking on the Thumbs Up button.
Posted by jeremyvi
Henagon

Re: A connection could not be established. Teamviewer not running on partner computer.

Restarting the service does not help me. I have users that are able to connect to a remote machine however, myself and at least one other cannot connect and get the message 

"A connection could not be established.  Teamviewer not running on partner computer."

This is a big problem for us because we need 24*7 connectivity. What else can we try?

The dialog that pops up actually says "Unable to Connect" 

 

"Teamviewer not running on partner computer."

 

So it's slightly different

Posted by jeremyvi
Henagon

Re: A connection could not be established. Teamviewer not running on partner computer.

The dialog that pops up actually says "Unable to Connect" 

 

"Teamviewer not running on partner computer."

Posted by Den_LiteManager
Digon

Re: A connection could not be established. Teamviewer not running on partner computer.

Configure TeamViewer to Unattended access

Posted by Alice146
Electron

Re: A connection could not be established. Teamviewer not running on partner computer.

It would seem that you didn't read the thread, people mentioned doing this step already.
Posted by Alice146
Electron

Re: A connection could not be established. Teamviewer not running on partner computer.

I use only the (Personal Use) version, as I don't do much other than connect to check on download progress/background activities while I am out or at work. So the things that I'm doing aren't really important per se.

But that doesn't make this problem any less frustrating. My PC is booted, logged in, and has teamviewer running, and still it gives me this error.

Reading through this thread it seems that this issue has been long running with little to no support to fix it.

Posted by edmirseca
Electron

Re: A connection could not be established. Teamviewer not running on partner computer.

Hi all,

I continue with the same error. I unnistall and restarted several times the service but keep the same getting the error. This is a little frustrate when you wanna do something and cannot connect.

Posted by madeby1
Electron

Re: A connection could not be established. Teamviewer not running on partner computer.

Go to the Apple menu

System preferences

Security & Privacy

Go to the privacy tab

Click the lock icon on the bottom left to make changes

insert your pw

Click unlock

In the sidebar select Accessibility

Click on + to add an application

Browse in Applications for TV

Click on open

Once TV is in the list with a checked checkbox you can go to the lock icon and click to lock the changes.

You should now be able to access and control mac with TV.

Posted by Smithy
Electron

Re: A connection could not be established. Teamviewer not running on partner computer.

go to settings on your pc.

click on "system"

click on "power and sleep"

set sleep to "never"

JOB DONE !! 

Posted by Benchmarked
Henagon

Re: A connection could not be established. Teamviewer not running on partner computer.

Smithy is correct.
Posted by wredwards
Electron

Re: A connection could not be established. Teamviewer not running on partner computer.

I HAD the same issue and I solved it by launching the user management website and going to groups all and listed properties on the computer that is showing offline xx days and delete.

Now I can connect to my PC without any issues.

Posted by mihail8
Electron

Re: A connection could not be established. Teamviewer not running on partner computer.

I have the same probleme but i can't fixit with what you said.

Do you have a nother ideea to try?

 

Posted by Rommy
Henagon

Re: A connection could not be established. Teamviewer not running on partner computer.

Regarding Murhpy10's comments:

I suspect this is what is going on.  I have three computers on my account, 2 connect just fine after sitting for an extended amount of time.  The third that is giving me trouble has recently had Win 10 reinstalled and probably is still set to the default power setting to shut off after some period of inactivity.  The two that always work have that feature set to "Never while plugged in".  I'll check that setting when I get back home.

Posted by HERMITech
Neutron

Re: A connection could not be established. Teamviewer not running on partner computer.


@wredwards wrote:

I HAD the same issue and I solved it by launching the user management website and going to groups all and listed properties on the computer that is showing offline xx days and delete.

Now I can connect to my PC without any issues.


Thanks,
That worked for me.

Posted by Rommy
Henagon

Re: A connection could not be established. Teamviewer not running on partner computer.

Ok thanks. I'll check that out.