Fresh install Teamviewer 14 stuck in 'Not ready...' on new Windows 10 Pro

Announcements

Join the discussion about TeamViewer and the Windows 10 2004 Update: Click here

Highlighted
Posted by
Henagon

Fresh install Teamviewer 14 stuck in 'Not ready...' on new Windows 10 Pro

This is driving me nuts. I just bought a new Dell Inspirion laptop with Windows 10 Home. Installed windows updates and Bitdefender just like on my other Lenovo laptop which is working without any issues. Downloaded and installed latest Teamviewer and can't get past 'Not ready. Please check your connection.' I've tried it with Bitdefender disabled and even uninstalled. I've re-installed teamviewer a dozen times, even tried the protable version. I thought maybe it was because my Lenovo was Windows 10 Pro, so I upgraded from Home to Pro on the new Dell. Nothing changed. I disabled ipv6, flushed DNS, restarted teamviewer service, still nothing. 

So now I have two laptops open in front of me, my old Lenovo with Windows 10 Pro, and Bitdefender working fine with TeamViewer 14. On the same network I have my Dell Inspirion with Windows 10 Pro, no Bitdefender, with all Windows defender disabled, unable to get TeamViewer 14 to connect. Someone please help me.

Here's my log file:

 

[Logs removed]
9 Replies
1 Accepted Solution

Accepted Solutions
Highlighted
Posted by
Photon
Solution

Re: Fresh install Teamviewer 14 stuck in 'Not ready...' on new Windows 10 Pro

I'm also an IT consultant. I just setup a remote user with a Dell Inspiron 7386. The user said TeamViewer quit working after a windows update, but after way too much time I found a preinstalled program called SmartByte Drivers and Services. I've only tested this a few times, but it looks like disabling it has fixed the connection issue.

TLDR;

Start > type "SmartByte" > open SmartByte from Trusted Microsoft Store app > click the switch to turn network prioritization "Off". Restart Teamviewer

 

View solution in original post

9 Replies
Highlighted
Posted by
Photon

Re: Fresh install Teamviewer 14 stuck in 'Not ready...' on new Windows 10 Pro

Hi, i'm Federico and i writing from Italy.

I have the same problem on my new Dell Inspiron 2 in 1 Model 7386, with Windows 10 Pro installed. I am a IT Consultant and now i work with teamviewer installed on a Virtual Machine.

I have try to reinstall Windows with a new updated image... but the result it's the same.

On this notebook i have olso strange problem with some Outlook's accounts in imap...

Incredible!

Highlighted
Posted by
Henagon

Re: Fresh install Teamviewer 14 stuck in 'Not ready...' on new Windows 10 Pro

Not sure if the proper edicate is to edit my original post or reply to it, but for what it's worth, teamviewer now appears to have no issues connecting on my new Dell laptop. I have no idea why. Shortly after my post I closed the laptop and went out of town. It sat unused until a couple days ago. I came home, opened it up and teamviewer just worked. I re-enabled windows defender and installed bitdefender and everything is still working. ipv6 is still disabled but no other exceptions have been made. Maybe it was a windows update or that 6th reboot that made a difference? I'm sorry I can't be of more assistance. Anyway, happy new year everyone!!

Highlighted
Posted by
Henagon

Re: Fresh install Teamviewer 14 stuck in 'Not ready...' on new Windows 10 Pro

I'm having the same problem on a brand new Dell G7 laptop running Win 10 Pro.  When I boot, TV will not connect (password gray'd out).  I've tried everything just like you did, and nothing seems to be the magic bullet.  All of a sudden, it will "wake up" and work just fine.  As long as I don't shut down (I can put the laptop to sleep, hibernate, etc.), it will keep working fine.  If I shut down or reboot, it goes back into the same delayed connect situation.  I initially thought it was a hom/pro issue also as the laptop I replaced was running home and had no trouble (the new one came with Pro installed).  I compared settings and services to another Pro system and everything is the same.  I'm completely stumped as I can't come up with an idea of what it might be based on the timing of the issue.

Does yours continue to work fine even after a reboot/cold start?

Highlighted
Posted by
Henagon

Re: Fresh install Teamviewer 14 stuck in 'Not ready...' on new Windows 10 Pro

Yes, I've shutdown and powered on as well as the suspend when just closing the lid. TV continues to work. Although, for some reason it takes about 10-15 seconds after TV starts to establish the connection. Which I don't typically see with the several other machines I have TV installed on. It's very strange.

I'd disable ipv6 network protocol on your laptop unless you need it for something else. Fastest way to get to the network connections menu in the control panel is to open windows explorer and paste this in the location bar:

shell:::{992CFFA0-F557-101A-88EC-00DD010CCC48}

Like this screenshot

Screenshot (2).png

 

Right click on the in-use network adapter and select properties. Uncheck 'Internet Protocol Version 6 (TCP/IPv6)'. Click 'OK' and restart your computer.

My only other suggestion would be to take a look at the log file and see if it offers any clues. Select 'Extras' menu item in TV and then 'Open log files...' Let us know if you see anything interesting. Good luck!

Highlighted
Posted by
Photon
Solution

Re: Fresh install Teamviewer 14 stuck in 'Not ready...' on new Windows 10 Pro

I'm also an IT consultant. I just setup a remote user with a Dell Inspiron 7386. The user said TeamViewer quit working after a windows update, but after way too much time I found a preinstalled program called SmartByte Drivers and Services. I've only tested this a few times, but it looks like disabling it has fixed the connection issue.

TLDR;

Start > type "SmartByte" > open SmartByte from Trusted Microsoft Store app > click the switch to turn network prioritization "Off". Restart Teamviewer

 

View solution in original post

Highlighted
Posted by
Electron

Re: Fresh install Teamviewer 14 stuck in 'Not ready...' on new Windows 10 Pro

Life Saving. Been strugling for over 2 months on this on a Dell G7.
Works like a charm!!

Highlighted
Posted by
Photon

Re: Fresh install Teamviewer 14 stuck in 'Not ready...' on new Windows 10 Pro

This solution should be a near the top of the suggestions.  It is the only thing that worked for me... Thanks alot!!!

Highlighted
Posted by
Henagon

Re: Fresh install Teamviewer 14 stuck in 'Not ready...' on new Windows 10 Pro

Not only did this fix my issue with TeamViewer but emails getting stuck in the Output for gmail.

A genuine thank you for sharing this tech tip!

Highlighted
Posted by
Electron

Re: Fresh install Teamviewer 14 stuck in 'Not ready...' on new Windows 10 Pro

same! I have found that removing smartbyte fixes many issues with the machine related to connection problems. This includes internet speed, before removing it my clients were getting about 20/5 connection and after it went to 900/900 !!!  

Not sure why it is even there, but get rid of it!