TV v13 New MSI Deployment Method

Announcements

Enjoy your weekend!


If you want to read our latest blog post, click here.

Highlighted
Posted by
Henagon

TV v13 New MSI Deployment Method

Hi Guys / Support,

I am having an issue with Deploying TeamViewer to our suite of machines.

I was previouslly using v12 with the Assignment Tool, however that stopped creating the Assignment Data file (dealt with TeamViewer Australia Support regarding this).  Because the Assignment Data file stopped being created, the package would fail as one of the steps was to register it to our account using that assignment file.

Fast forward to today where I have updated the package to use the MSI and the new registration method.  I have it installing and registering successfully, however having an issue setting the standard password we use on our machines.

I am deploying the software using the following command.

msiexec.exe /i "\\DEPLOYMENT.SERVER\Apps$\Teamviewer\MSI\TeamViewer_Host.v13.msi" /norestart /qn TRANSFORMS="\\DEPLOYMENT.SERVER\Apps$\Teamviewer\MSI\TeamViewer_Host.v13.Settings.mst"

I am setting the additional details via the MST file instead of running it all on one big command line as that can cause deployment issues.

As per my example below, you can see how I have configured the MST file.

SS.20181025.150721.jpg

What you can see below is what our end user sees after we have connected, worked on the machine, then disconnected.  We need a way to specify our default password and not allow the end user to change or deactivate it.

Please help, I am sure I have missed something somewhere, I would have assumed it could be set in our TeamViewer account vs having to export and import registry keys etc.SS.20181025.150931.jpg