Announcements

Did you already try the new Windows 10 October 2020 Update?


Share your feedback and experience with TeamViewer on the new Windows build with our developers here.

Highlighted
Posted by
Digon

Debian Linux: Program does not start

When I start the program I get these messages, but the GUI does not start.

"teamviewer

Init...
CheckCPU: SSE2 support: yes
XRandRWait: No value set. Using default.
XRandRWait: Started by user.
Checking setup...
Launching TeamViewer ...
Starting network process (no daemon)
terminate called without an active exception
/opt/teamviewer/tv_bin/script/tvw_exec: Zeile 40: 15540 Abgebrochen             "$TV_BIN_DIR/teamviewerd" -n -f
Network process already started (or error)
Launching TeamViewer GUI ...  "

My system:

Linux xxxxxx 4.13.0-1-amd64 #1 SMP Debian 4.13.4-2 (2017-10-15) x86_64 GNU/Linux

What can I do ?

4 Replies
1 Accepted Solution

Accepted Solutions
Highlighted
Posted by
Digon
Solution

Re: Debian Linux: Program does not start

4 Replies
Highlighted
Posted by
Digon

Re: Debian Linux: Program does not start

hello,

same here (Debian/Buster)

I'd add that:

* the gui.log complains about  icui18n (Cannot load library ) despite i have libicu57 properly installed
* i've tried with either the deb package and the tar archive

* it's the same with version 11 (deb/tar)

 

I think it's because of some recent debian upgrades that messed it up. Please teamviewer guys, turn on a Debian/Buster 64b with multiarch option and test one install of teamviewer.

Have a good week-end ;)

regards

f.

 

 

 

Highlighted
Posted by
Digon
Solution

Re: Debian Linux: Program does not start

Highlighted
Posted by
Electron

Re: Debian Linux: Program does not start

try apt install libicu-dev:i386

I was missing the 32bit binaries.

Highlighted
Posted by
Photon

Re: Debian Linux: Program does not start

I have a similiar issue when I click on the Teamviewer 14 GUI. It behaves as though it wants to start but nothing...

Here is my systemctl status, not sure what the PID is complaining about:

● teamviewerd.service - TeamViewer remote control daemon
Loaded: loaded (/etc/systemd/system/teamviewerd.service; enabled; vendor preset: enabled)
Active: active (running) since Mon 2019-11-04 13:21:00 MST; 14min ago
Process: 2080 ExecStart=/opt/teamviewer/tv_bin/teamviewerd -d (code=exited, status=0/SUCCESS)
Main PID: 2082 (teamviewerd)
Tasks: 13 (limit: 4915)
Memory: 6.2M
CGroup: /system.slice/teamviewerd.service
└─2082 /opt/teamviewer/tv_bin/teamviewerd -d
Nov 04 13:21:00 buster systemd[1]: Starting TeamViewer remote control daemon...
Nov 04 13:21:00 buster systemd[1]: teamviewerd.service: Can't open PID file /run/teamviewerd.pid (yet?) after start: No such file or directory
Nov 04 13:21:00 buster systemd[1]: Started TeamViewer remote control daemon.

 

 

 

*thanx*