Hi, I am having trouble downloading TeamViewer on my Linux computer. It is operating on Ubuntu 14.04, 64-bit OS. When I open the download in the software center, I get a "Dependency is not satisfiable: libqt5gui5 (<=5.5)" error. What can I do to resolve this issue?
For TeamViewer 13, we have bumped the dependencies to Qt 5.5 (Host is still 5.2), to be able to use the newer features. We don't do yet, but probably will in 2018.
You could either try to enforce the installation (if you know what you're doing), or try to install the TAR package. That might work now, but might fail in the future.
Ubuntu 14.04 and Debian 8 are no longer officially supported. (I know, Installation notes do not reflect that yet - will be updated)
You could also consider to move to Ubuntu 16.04 LTS or later.
Same for Debian 8 users: consider moving to Debian 9.
Debian and Ubuntu have gone to imense effort to extend support out to many years because they are used in long term environments. For someone running Jessie installed in the summer when Jessie was actualluy current stable you have just cut off their support for connection to auto updating windows systems after just a few months.
Can you rethink this policy please.
That is reasonable. In general, we tend to support current/LTS releases. Therefore we agreed to keep the Host on 5.2 for the moment. That is already the middle-ground we found.
5.5 shall stay for a while. At some point, we might ship (optional) Qt binaries to support older releases, but we can't do that right now.
Nicely put. Sadly this still leaves us Linux subscribers prevented from connecting to v13 clients only weeks after purchasing new annual license for Teamviewer. Can you perhaps find a way to enable Llinux 12 consoles to connect to windows 13 clients?
Due to popular demand (yes, that's you :robothappy: ), the update scheduled for next week will have (limited) support for Debian 8 Jessie.
Limited here shall mean that in general everything will work fine. When we finally switch to Qt 5.5 in a few months, we might offer Qt binaries, if there is demand.
I'm currently using Ubuntu 16.04 LTS release and Teamviewer 13 cannot be installed here either. Error: Dependency is not satisfiable: libqt5gui5 (>=5.5)
Is there any way around this error on 16.04?
Found my own solution. Not very elegant, I installed the Windows version on a virtual machine, but it'll do until the Linux version can be fixed.
@RKLN, uh... I think you must have mixed something up.
My development machine is Ubuntu 16.04. Also, see here:
Could it be that you're trying to install the 32 bit package on a 64 bit machine or that it's actually not Ubuntu 16.04, or that you disabled repositories or...
Correct me if I'm wrong, but I think that error does not make any sense on Ubuntu 16.04
Oops! You are correct, I've mixed something up. I have two machines running 16.04 and had in mind the third that I was working with the other day was also running 16.04, but that was my error. It's running 14.04.:smileyembarrassed:
You know that some people are locked to different Ubuntu versions, like me, locked to 14.04. Any OS upgrade for me neans to loose the video driver support (thanks to Ati for that).
Are you suggesting to buy a new laptop? are you that **bleep**?