Announcements

Shape the future of the TeamViewer product with our Product Team. Click here to join!

Highlighted
Posted by vitrion
Henagon

Linux partner does not accept incoming connections

Teamviewer 12 allows outgoing connections but it does not allow incoming connections. In Fedora 25 Workstation this problem is evident; in Fedora 25 Server there is no problem. Apparently, something in Fedora 25 Workstation is blocking all the incoming connection, e.g. the firewalld service. I tried to solve this enabling ports 80, 443 and 5938, but it does not work.
I think that something else is blocking all the incoming Teamviewer connections, because there is no log in Teamviewer that shows the incoming connection rejection. I attach the log files for more information.
Please help.
What I mean is:
Teamviewer Fedora -> Teamviewer Windows OK
Teamviewer Fedora <- Teamviewer Windows FAILS (something is blocking incoming connections in Fedora and its corresponding log does not register the refused connection)
Thank you
OS: Fedora 25 Workstation
License: free
Please download the Teamviewer log files:
https://1drv.ms/t/s!Antm9EMPXrQmgYRKmSrRlu2N2hOhXQ
https://1drv.ms/u/s!Antm9EMPXrQmgYRLXEwvWwdH4Ulk_A

3 Replies
1 Accepted Solution

Accepted Solutions
Posted by TeamViewer Staff
TeamViewer Staff
Solution

Re: Linux partner does not accept incoming connections

Dear vitrion,

Thank you for your feedback.

To fix your issue, Please follow these steps to disable Wayland on your Fedora Box

  • Open the file /etc/gdm/custom.conf with your favorite editor (vi, nano, gedit, etc).
  • Uncomment the line 'WaylandEnable=false'
  • Save and reboot the system.

After that, the system will run using Xorg support and TeamViewer will work properly.

Let us know if this solution worked for you. We are looking forward to your comments.

If you have any other questions please don’t hesitate to contact us.

 

Did my reply answer your question? Accept it as a solution to help others, Thanks.

View solution in original post

3 Replies
Posted by TeamViewer Staff
TeamViewer Staff

Re: Linux partner does not accept incoming connections

Dear vitrion,

Thank you for your post.

According to the log file, data packets got lost during one or more of the sessions you established.

TeamViewer will always try to automatically re-send lost packets; however, in this case, several data-packets can not be received by the remote-computer which include your control commands so your commands have not been performed.

To fix this problem, please go to Extras | Options | Advanced. Here, click "Show Advanced options".

In the group "Advanced network settings", you will find the option "Use UDP (recommended)".

Please disable that option. This only needs to be done on your Linux box.

Hope this solution works for you.

 

Best regards,

Christian

Did my reply answer your question? Accept it as a solution to help others, Thanks.
Posted by vitrion
Henagon

Re: Linux partner does not accept incoming connections

I already did that in the computer in question.

Please see the attached picture. The result is the same.

The remote computer in question is a Fedora Linux dist called MSTR and the computer that tries to connect to it is a Windows 10 called NP-905-VTR.

This is the log of MSTR:

https://1drv.ms/u/s!Antm9EMPXrQmgYRcOgaIoU6V1jCfQg

This is the log of NP-905-VTR

https://1drv.ms/u/s!Antm9EMPXrQmgYRbVcrpytjbzTvu1Q

captura.png captura 2.png

Posted by TeamViewer Staff
TeamViewer Staff
Solution

Re: Linux partner does not accept incoming connections

Dear vitrion,

Thank you for your feedback.

To fix your issue, Please follow these steps to disable Wayland on your Fedora Box

  • Open the file /etc/gdm/custom.conf with your favorite editor (vi, nano, gedit, etc).
  • Uncomment the line 'WaylandEnable=false'
  • Save and reboot the system.

After that, the system will run using Xorg support and TeamViewer will work properly.

Let us know if this solution worked for you. We are looking forward to your comments.

If you have any other questions please don’t hesitate to contact us.

 

Did my reply answer your question? Accept it as a solution to help others, Thanks.

View solution in original post