Announcements

Remote Control for all devices running Android 7+ is here!

(Incl. Google Pixel series, Xiaomi smartphones, Oppo devices, and many more)


Learn more

Highlighted
Posted by
Digon

TeamViewer 15.5.3 (NI) Ubuntu 16.04 UI Cannot Change Focus

Kudos to the TeamViewer developer for producing Desktop Client for a wide variety of Linux distributions and also as a tarball.

Downloaded and tried two TeamViewer 15.5.3 binaries:-

  • teamviewer_15.5.3_amd64.deb; and
  • teamviewer_15.5.3_amd64.tar.xz

    The .deb, I stripped and installed at a temporary "root" in /tmp.  The tarball I extracted to a separate directory in /tmp/

    Both binaries ran first time without generating any missing library dependencies. The informational messages were identical for both and are as shown below:

    ```shell
    $ /tmp/Downloads/opt/teamviewer/tv_bin/script/teamviewerInit...
    CheckCPU: SSE2 support: yes
    Checking setup...
    Launching TeamViewer ...
    Starting network process (no daemon)
    Network process already started (or error)
    Launching TeamViewer GUI ...
    process already started (or error)
    Launching TeamViewer GUI ...

    $ /tmp/Downloads/opt/teamviewer/tv_bin/script/teamviewerInit...
    CheckCPU: SSE2 support: yes
    Checking setup...
    Launching TeamViewer ...
    Starting network process (no daemon)
    Network process already started (or error)
    Launching TeamViewer GUI ...
    process already started (or error)
    Launching TeamViewer GUI ...

    The first shows 15.5.3 and the second 15.5.3 NI in the about box.  The second has a "Getting Started" tab on the LHS, the first does not.  *Neither*have a Meetings tab (I was interested in evaluating it given the COVID-19 FAQ entry).

    Re the subject:

    It is not possible to set focus to the "E-mail" and "Password" fields in the "Sign In" tab -- obviously then I cannot sign-in.  Similarly for the "Remote Control" tab.  The *only* tab that I can set focus to is the "Insert partner ID" tab at the top of the Desktop Client window.  In the "Sign In" tab, I cannot activate either the "Forgot password" or "Sign up" links (but can switch freely between tabs (except the "Chat" tab).

    Platform:

    HP ThinPro 7.1 (oem'd Ubuntu 16.04 x86_64)

    Window Manager:

    Openbox 3.6.1

    Use Case:

    1.  Personal use - remoting to my elderly father's desktop in the USA to provide support

    2. Business use - 1-1 meetings and give/receive screenshare support

    Additional Information:

    I am on TalkTalk Business network (UK) that Wikipedia entry (on TeamViewer) says blocks TeamViewer and similar known remoting applications/protocols owing to its (TeamViewer's) use by phishing/scam criminals

    Thank you in advance.