Announcements

Become a product development partner for TeamViewer. Read more about it in our Announcement.

Highlighted
Posted by ABQ_RPi
Henagon

Teamviewer not starting on Raspberry Pi

I am at a complete standstill on this set of errors. The startup script is failing:

pi@raspberrypi:/opt/teamviewer/tv_bin/script $ uname -a
Linux raspberrypi 4.9.20+ #985 Mon Apr 3 10:19:25 BST 2017 armv6l GNU/Linux

pi@raspberrypi:/opt/teamviewer/tv_bin/script $ cat /etc/debian_version
8.0

pi@raspberrypi:/opt/teamviewer/tv_bin/script $ teamviewer

Init...
Checking setup...
Launching TeamViewer ...
Starting network process (no daemon)
/opt/teamviewer/tv_bin/script/tvw_exec: line 40:  1046 Illegal instruction     "$TV_BIN_DIR/teamviewerd" -n -f
Network process already started (or error)
Launching TeamViewer GUI ...
Illegal instruction
pi@raspberrypi:/opt/teamviewer/tv_bin/script $

5 Replies
1 Accepted Solution

Accepted Solutions
Posted by TeamViewer Staff
TeamViewer Staff
Solution

Re: Teamviewer not starting on Raspberry Pi

Hi QBQ_RPi,

the illegal instruction thing makes me wonder if you managed to install the normal TeamViewer package, which is Wine-based and of course only meant to be installed on Intel machines.

So, using the host package is the right way to go! Make sure to pick the arm download (although the installer should make it hard for you to install the wrong package). Have a look here: Linux Host downloads

EDIT: Actually, now I spotted it: You tried to install on a first-gen Raspberry Pi, but you need a Pi 2 or Pi 3. The TeamViewer package required the armv7 instruction set. Also, the performance on a first-gen Pi would be pretty bad...

P.S.: You don't need to go to a certain directory to run the teamviewer command!

Linux Developer
5 Replies
Posted by ABQ_RPi
Henagon

Re: Teamviewer not starting on Raspberry Pi

Due to the lack of any help with this problem, I have now purchased a new RPi and am trying to run the Host version. See another posting for problems with lack of persistent ID and password with this new solution. At least the host version installs and runs (once per boot session, anyway).

 

Posted by TeamViewer Staff
TeamViewer Staff
Solution

Re: Teamviewer not starting on Raspberry Pi

Hi QBQ_RPi,

the illegal instruction thing makes me wonder if you managed to install the normal TeamViewer package, which is Wine-based and of course only meant to be installed on Intel machines.

So, using the host package is the right way to go! Make sure to pick the arm download (although the installer should make it hard for you to install the wrong package). Have a look here: Linux Host downloads

EDIT: Actually, now I spotted it: You tried to install on a first-gen Raspberry Pi, but you need a Pi 2 or Pi 3. The TeamViewer package required the armv7 instruction set. Also, the performance on a first-gen Pi would be pretty bad...

P.S.: You don't need to go to a certain directory to run the teamviewer command!

Linux Developer
Posted by autolycus
Photon

Re: Teamviewer not starting on Raspberry Pi

I'm seeing this behavior on a Pi Zero, as well.

Posted by a-tec
Digon

Re: Teamviewer not starting on Raspberry Pi

Would be nice if the Pi Zero will be supported as well.

Posted by Bowen73
Photon

Re: Teamviewer not starting on Raspberry Pi

yes would be great for the pi zero to be supported.  tried ages to get it to run.  it installs fine just wont run