Posted by dosfanat
Henagon

team viewer does not open on debian 8

Hi! team viewer does not open on debian 8.

Here is some logs:fixme:service:scmdatabase_autostart_services Auto-start service L"MountMgr" failed to start: 2
fixme:service:scmdatabase_autostart_services Auto-start service L"PlugPlay" failed to start: 2
fixme:actctx:parse_depend_manifests Could not find dependent assembly L"Microsoft.Windows.Common-Controls" (6.0.0.0)
fixme:ole:CoInitializeSecurity ((nil),-1,(nil),(nil),0,3,(nil),0,(nil)) - stub!
fixme:heap:HeapSetInformation (nil) 1 (nil) 0
fixme:process:SetProcessDEPPolicy (3): stub
fixme:msg:ChangeWindowMessageFilter 233 00000001
fixme:msg:ChangeWindowMessageFilter 4a 00000001
fixme:msg:ChangeWindowMessageFilter 407 00000001
fixme:msg:ChangeWindowMessageFilter 49 00000001
fixme:ver:GetCurrentPackageId (0x1aee9f8 (nil)): stub
fixme:ver:GetCurrentPackageId (0x1bee9f8 (nil)): stub
fixme:process:SetProcessShutdownParameters (00000100, 00000000): partial stub.
fixme:win:EnumDisplayDevicesW ((null),0,0x32d98c,0x00000000), stub!
fixme:win:EnumDisplayDevicesW (L"\\\\.\\DISPLAY1",0,0x32dcd4,0x00000000), stub!
fixme:win:EnumDisplayDevicesW ((null),1,0x32d98c,0x00000000), stub!
wine: Unhandled exception 0x40000015 in thread 9 at address 0x320023:0x00edf4ef (thread 0009), starting debugger...
err:seh:start_debugger Couldn't start debugger ("winedbg --auto 8 252") (2)
Read the Wine Developers Guide on how to set up winedbg or another debugger

 

1 Accepted Solution

Accepted Solutions
Posted by TeamViewer Staff
TeamViewer Staff
Solution

Re: team viewer does not open on debian 8

Hi dosfanat,

Thank you for your post.

Let's clean up your system from TeamViewer previous traces and install the software.

Please use the following commands to solve your issue.

cd /
sudo rm -rf /home/*/.local/share/teamviewer* /home/*/.config/teamviewer /opt/teamviewer
cd ~
wget download.teamviewer.com/download/teamviewer_i386.deb
sudo dpkg -i teamviewer_i386.deb
sudo apt-get install -f -y

The open TeamViewer you may use the following command

teamviewer &

Hope that solution works for you.

Best regards,

Christian

Did my reply answer your question? Accept it as a solution to help others, Thanks.
13 Replies
Posted by NW-IT
Digon

Re: team viewer does not open on debian 8

It works here on Debian 8. I think you'll need to supply some more information ... ;)

- How did you install TV?
- How do you start it? (Manually from the menu? Automatically with the computer?)
- Which desktop environment? (xfce, Gnome, ... ?)
- Has it ever worked, or is this following an update/upgrade?

Posted by dosfanat
Henagon

Re: team viewer does not open on debian 8

Here you go:

- #dpkg -i <deb package name downloaded from TV website>

- tried Both from menu and terminal

- LXDE

- it did on the older version and started ONCE after the package upgrade.

Posted by NW-IT
Digon

Re: team viewer does not open on debian 8

Sorry, I don't come by very often.

If you start teamviewer from a terminal, what do you see? For example, this is what I see for a successful Teamviewer start:

$ teamviewer 

Init...
CheckCPU: SSE2 support: yes
XRandRWait: No value set. Using default.
XRandRWait: Started by user.
Checking setup...
Launching TeamViewer ...
Launching TeamViewer GUI ...
Posted by dosfanat
Henagon

Re: team viewer does not open on debian 8

Hi! It's literally the same thing.

XRandRWait: No value set. Using default.
XRandRWait: Started by user.
Checking setup...
Launching TeamViewer ...
Launching TeamViewer GUI ...

And then - nothing at all.

It simple drops me back in xterm.

in internal TV wine log there is some interesting messages:

fixme:service:scmdatabase_autostart_services Auto-start service L"MountMgr" failed to start: 2
fixme:service:scmdatabase_autostart_services Auto-start service L"PlugPlay" failed to start: 2
fixme:actctx:parse_depend_manifests Could not find dependent assembly L"Microsoft.Windows.Common-Controls" (6.0.0.0)
fixme:ole:CoInitializeSecurity ((nil),-1,(nil),(nil),0,3,(nil),0,(nil)) - stub!
fixme:heap:HeapSetInformation (nil) 1 (nil) 0
fixme:process:SetProcessDEPPolicy (3): stub
fixme:ver:GetCurrentPackageId (0x32f6d8 (nil)): stub
fixme:process:SetProcessShutdownParameters (00000100, 00000000): partial stub.
fixme:win:EnumDisplayDevicesW ((null),0,0x32d538,0x00000000), stub!
fixme:win:EnumDisplayDevicesW (L"\\\\.\\DISPLAY1",0,0x32d880,0x00000000), stub!
fixme:win:EnumDisplayDevicesW ((null),1,0x32d538,0x00000000), stub!
wine: Unhandled exception 0x40000015 in thread 9 at address 0x7e6b0023:0x00ea0338 (thread 0009), starting debugger...
err:seh:start_debugger Couldn't start debugger ("winedbg --auto 8 212") (2)
Read the Wine Developers Guide on how to set up winedbg or another debugger

 

 

 

Posted by TeamViewer Staff
TeamViewer Staff
Solution

Re: team viewer does not open on debian 8

Hi dosfanat,

Thank you for your post.

Let's clean up your system from TeamViewer previous traces and install the software.

Please use the following commands to solve your issue.

cd /
sudo rm -rf /home/*/.local/share/teamviewer* /home/*/.config/teamviewer /opt/teamviewer
cd ~
wget download.teamviewer.com/download/teamviewer_i386.deb
sudo dpkg -i teamviewer_i386.deb
sudo apt-get install -f -y

The open TeamViewer you may use the following command

teamviewer &

Hope that solution works for you.

Best regards,

Christian

Did my reply answer your question? Accept it as a solution to help others, Thanks.
Posted by RGutknecht
Henagon

Re: team viewer does not open on debian 8

I'm having the same problem on Linux Mint 18, it was working then simply stopped.  Tried to purge and also tried upgrading to TeamViewer 12 with same issue.  Tried your solution, but I received and error on first dpkg command.  Reinstalled from downloaded Deb backage from teamviewer site and whoala! it works!  Thanks!  must have been the 

sudo find . -name *teamviewer* -exec rm -rf {} \;

that made the difference!  Thanks for the assist, I was super frustrated!

 

Posted by dosfanat
Henagon

Re: team viewer does not open on debian 8

Hi, purging all of TV files and reinstall worked GREAT, thanks for your assistance.

Posted by rok
Trigon

Re: team viewer does not open on debian 8

Hi,

I have the same issue in Ubuntu 16.04.. I already tried sevel times to clean up the system and reinstall, it works for some days, then the problem is back.. can anyone help me?

Highlighted
Posted by TeamViewer Staff
TeamViewer Staff

Re: team viewer does not open on debian 8

Dear rok,

Thank you for your post.

What version will you like to use full version or host?

We are looking forward to your comments.

 

Best regards,

Christian

Did my reply answer your question? Accept it as a solution to help others, Thanks.
2 Replies
Posted by RGutknecht
Henagon

Re: team viewer does not open on debian 8

I am using Linux Mint 18

Posted by rok
Trigon

Re: team viewer does not open on debian 8

I solved in this way, looking at /home/user/.config/teamviewer/client.conf the parameter [strng] FT_Start_Directories = "" was ridiculously long and I simply deleted anything between the " " as many of the directories were not even in my computer. Now Teamviewer is back!

Anyway this always happens after some file transfers (with other ubuntu machines), then I clean that parameter and teamviewer comes back...

I use Teamviewer 12.0.71.510 , licensed, full version.

Posted by RadioFreq
Henagon

Re: team viewer does not open on debian 8

I get this messag, but the application never starts...

Posted by TeamViewer Staff
TeamViewer Staff

Re: team viewer does not open on debian 8

Are you talking about TeamViewer 12?
Then: Which message do you get. Explain in more detail.
Or even better: Try TeamViewer 13

Are you talking about TeamViewer 13?
Then: Please open a new thread, include TV13 in the title.
This thread is about TeamViewer 12.

Linux Developer