Shape the future of the TeamViewer product with our Product Team. Click here to join!

Posted by dece

Re: Why Can't I Control my Android Device?

Same issue - Moto X4 running Android 9

Posted by kostas1

Add-on for Zebra Handheld TC56

Hello i would like to ask if there is any add on for Zebra TC56. I am trying to remote control a device from quicksupport but there is no functionality and i am limited to view only.

Thank you

Posted by Picard

Re: Why Can't I Control my Motorola Droid Turbo 2?

Downloaded the latest version of TeamViewer Host, got it up, but (like many others) it's only showing the screen and NOT allowing any kind of remote control.  When I clicked the little eject icon in the bottom right and clicked on the keyboard it said: "Remote side does not support remote input".

So despite Motorola being on the list of compatible devices, it's not working.

Posted by Nagmet

TeamViewer on BlackBerry devices

Please remove TeamViewer from BlackBerry World. On BlackBerry10 this application does not work anymore. And disable the ban in the android application for use in BlackBerry10 devicesIMG_20190623_204505.png

Posted by btingle1

Re: android tv box

Worked like a charm. Thank you.
Posted by Tomb1

Android 5.1.1

When connecting to Android 5.1.1, we have to 'allow' and then imediately select 'home' icon otherwise the tablet freezes and shuts down.

Juniper Systems, Mesa2 tablet

Any idea please?  Thank you

Posted by JRHPM

Re: Why Can't I Control my Android Device?

Hi @Scotty 

Nokia (HMD) is in the list of fully supported manufacturers. As you may see from the comments at the Google Play Store's "Add-On: Nokia", which is required to unfold the full capabilites on Nokia 8 smartphones, there is a malfunction during the installation process for this add on. (Google Play Store: TeamViewer Add-On: Nokia) It does not install.


Google Play Store TeamViewer Add-On Nokia.PNGAdd-On: Nokia does not installPlease review the "Nokia" add-on for Nokia 8 and let us know, when it works! Thanks!


Posted by niribiun

Mi Box S


Can I use TeamViewer with Mi Box S (Android 8.1)?



  • Output Resolution: 4K (3840 x 2160)
  • CPU: Cortex-A53 Quad-core 64bit
  • GPU: Mali-450
  • RAM: 2GB DDR3
  • Storage: 8GB eMMC
  • Operating System: Android TV

Wireless connectivity

  • Wi-Fi: 802.11a/b/g/n/ac 2.4GHz/5GHz
  • Bluetooth: 4.1


  • Video decoder: 4K@60fps,VP9, H.264,MPEG1/2/4,VC-1,Real8/9/10
  • Video Format: RM,MOV,VOB,AVI,MKV,TS,Mp4,3D
  • Audio decoder: DOLBY, DTS
  • Audio Format: MP3,APE,Flac
  • Image decoder: JPG,BMP,GIF,PNG,TIF
  • Support Language: Global


  • HDMI2.0a: 1
  • USB2.0: 1
  • Power Interface: 1
  • Audio Out: 1


Posted by WildcatMidnight

Re: Why Can't I Control my Android Device?

Why Teamviewer (from my Pc) can not Remote-control my Asus device (Smart-phone): Zenfone Max-plus(M1) X018d(Zb570Tl) - even if Teamviewer-host & Add-on_Asus(y) are already installed (but Screen-sharing is Ok)? 

Posted by osaether

Re: Why Can't I Control my Android Device?

Is there a list of devices that are known to work with TeamViewer Host? I would like to buy a device that is known to work.

I know there already is a list of manufacturers but unfortunately that is not enough. Both Motorola and Huawei are on that list but both my Moto G7 Play and Nexus 6P does not work with TeamViewer Host. 

Posted by manojanand

Re: Why Can't I Control my Android Device?

I see Lenovo Android devices are supported for remote control. Whereas I am only able to view my device when I connect to the host.

Host Details : Lenovo A6 Note, Android Version 9, Android Security Patch Sep 5 2019. Also I tried Installing the available Lenovo addons for android.

I tried connecting  the host from Android Galaxy S9+ running Android 9 and Windows 10 PC, but I am not able to remote control the device. Also on the Windows, team viewer pops up a message  "device supports screen sharing only teamviewer".

Is this a know limitation ? any solution to the issue?


Posted by Sikred

Re: Why Can't I Control my Android Device?

I downloaded the latest Teamviewer version for Linux  and Android (both host and Quick Support). I'm getting an incompatible verisons error. I just downloaded each version right now.