Posted by Boetn
Henagon

Can't enable two-factor authentication for a user

Hi,

I just added a new user to our company Teamviewer account. The user signed in and now we would like to active the two-factor authentication on his account. However when he goes to his profile the text message Deactived is displayed next to Double Authentication and we can't seem to find a way to activate it.

Thanks in advance for the support!

Kind regards,
Arne Claerebout

6 Replies
6 Replies
Posted by Harms1
Photon

Re: Can't enable two-factor authentication for a user

I had the same Issue
As Soon as I recieved admin rights from my admin via the Teamviewer site; the Deactivate dissapeared and Activate appeared instead.

Posted by Moderator Moderator
Moderator

Re: Can't enable two-factor authentication for a user

Hello BOETN,

Thank you for your message.

If "deactivate" is displayed, then the TFA should already be active.

Can you maybe send a screen shot, so we can see how it looks like ?

Thank you in advance for your reply.

Cheers

French Community Moderator
Did my reply answer your question ? Accept it as a solution to help others.
Find this helpful ? Say thanks by clicking on the Thumbs Up button.
Posted by philmacu
Henagon

Re: Can't enable two-factor authentication for a user

Jean, 

I have the same issue, the status is not 'deactivate' but rather 'deactivated', which is also the query that BOETN had

 

Posted by Boetn
Henagon

Re: Can't enable two-factor authentication for a user

Hi Jean,
The helpdesk helped me out. It's because the user doesn't have the right to change his profile.

Once you enable that option in the admin panel, it will be possible.
Posted by philmacu
Henagon

Re: Can't enable two-factor authentication for a user

Thanks will follow up on it
Posted by Moderator Moderator
Moderator

Re: Can't enable two-factor authentication for a user

Hello Boetn,

Hello philmacu,

Indeed, I have verified it also on our side: it is a permission issue.

To give sufficient rights to your users, so they can enable and disable the two factors authentication, you need to edit their profile permissions in your Management Console (as on the screenshots below)

User Management.pngEdit profile.png

Note: Only company profile administrators can give these permissions.

What Boetn just said is absolutely correct.

A special thanks to both of you, your collaborative way of communication makes this Community a better place.

I hope this final explanation could solve this topic. If not, feel free to ask your questions.

I wish you all a good rest of the week.

Cheers

French Community Moderator
Did my reply answer your question ? Accept it as a solution to help others.
Find this helpful ? Say thanks by clicking on the Thumbs Up button.