Posted by AlexFogerty
Trigon

Quick Support Doesn't Elevate Privileges

We have a user with a computer in another country that needs support. I'm a Domain Admin but the machine won't get Group Policy for some reason. The end user isn't an Administrator so cannot install anything. They can download TeamViewer Quick Support, but if I log in I get their permissions which only confirms what I already know, Group Policy isn't working correctly. Trying to connect as the Domain Administrator it says "please wait while TeamViewer reboots to elevate privileges" but it doesn't, it just closes the Quick Support and re-opens it with the same privileges.

Without Group Policy I can't get past the firewall to RDP into the machine.

Any ideas what I can do next? (without handing out the Domain Admin password, obviously)

2 Replies
Posted by Senior Moderator Senior Moderator
Senior Moderator

Re: Quick Support Doesn't Elevate Privileges

Hi @AlexFogerty

This is very strange and not something I have seen before, if you are connecting using Windows Authentication, this is supposed to give the QuickSupport elevated rights.

We have an article on UAC here

If the software is not being elevated, we would need to check this with you.
Can you please Call us or raise a ticket?

Thank you,
-Scotty

Senior Moderator
Did my reply answer your question? Why not accept it as a solution to help others?
Highlighted
Posted by AlexFogerty
Trigon

Re: Quick Support Doesn't Elevate Privileges

After fiddling with it for two hours I decided just to create a new temporary admin and gave one of the end users the details. They then were able to install the full version of TeamViewer and I was able to log in as the main admin account and do what I had to do.