Announcements

Did you already try the new Windows 10 October 2020 Update?


Share your feedback and experience with TeamViewer on the new Windows build with our developers here.

Highlighted
Posted by
Henagon

Setting checkmark "grant easy access" in checkbox during deployment

Hi,

I'm on the latest version of TV (14.something), and everything in my deployment works fine, including group assignment, except this:

  • I use the "--grant-easy-access" parameter, and after deployment I can enable easy access simply by clicking the checkmark in "security/grant easy access for user xxxx", but I would like to set that flag during deployment, to avoid all manual work on the client.

My command line is:

msiexec.exe /i "TeamViewer_Host.msi" /qn CUSTOMCONFIGID=xxxxxxx APITOKEN=xxxxxxx ASSIGNMENTOPTIONS="--grant-easy-access --reassign --group-id gxxxxxxx"

Any help is appreciated :)

Best regards,
Kenneth

2 Replies
1 Accepted Solution

Accepted Solutions
Highlighted
Posted by Moderator Moderator
Moderator
Solution

Re: Setting checkmark "grant easy access" in checkbox during deployment

Hello @Kenneth , hello @nreid,

Thank you for your messages.

@Kenneth, your command line is correct.

FYI: --reassign is only useful for the devices who are already assigned to your account. For new devices who are not assigned to your Management Console, you need to remove this option.

By the way, is the problem still there?

If yes, that you can try to add the following elements in your command:

timeout /t 5
net stop teamviewer
net start teamviewer

at the end of your command line.

In order to get something like this:

msiexec.exe /i "<Path>\TeamViewer_Host.msi" /qn CUSTOMCONFIGID=<YOUR IDCONFIG> APITOKEN=<YOUR APITOKEN> ASSIGNMENTOPTIONS="--alias %COMPUTERNAME% --grant-easy-access"
timeout /t 5
net stop teamviewer
net start teamviewer

It will restart the TeamViewer service on the device you are deploying the Host on. In some cases, it fixes the issue.

I hope this could help. If not, make sure to submit a ticket via this link. Our Support will help you out by having a closer look at your issue.

Cheers

French Community Moderator

If my reply answered your question, help out other users and click the Accept as a Solution button below. ✅
You can also say thanks by clicking on the Thumbs Up button!
Thanks for being an active member of our Community!

View solution in original post

2 Replies
Highlighted
Posted by
Henagon

Re: Setting checkmark "grant easy access" in checkbox during deployment

Having the same exact problem. Really need this to be solved. 

Highlighted
Posted by Moderator Moderator
Moderator
Solution

Re: Setting checkmark "grant easy access" in checkbox during deployment

Hello @Kenneth , hello @nreid,

Thank you for your messages.

@Kenneth, your command line is correct.

FYI: --reassign is only useful for the devices who are already assigned to your account. For new devices who are not assigned to your Management Console, you need to remove this option.

By the way, is the problem still there?

If yes, that you can try to add the following elements in your command:

timeout /t 5
net stop teamviewer
net start teamviewer

at the end of your command line.

In order to get something like this:

msiexec.exe /i "<Path>\TeamViewer_Host.msi" /qn CUSTOMCONFIGID=<YOUR IDCONFIG> APITOKEN=<YOUR APITOKEN> ASSIGNMENTOPTIONS="--alias %COMPUTERNAME% --grant-easy-access"
timeout /t 5
net stop teamviewer
net start teamviewer

It will restart the TeamViewer service on the device you are deploying the Host on. In some cases, it fixes the issue.

I hope this could help. If not, make sure to submit a ticket via this link. Our Support will help you out by having a closer look at your issue.

Cheers

French Community Moderator

If my reply answered your question, help out other users and click the Accept as a Solution button below. ✅
You can also say thanks by clicking on the Thumbs Up button!
Thanks for being an active member of our Community!

View solution in original post