Highlighted
Posted by
Henagon

Two Macs same OS, same Teamviewer version but can't connect.

I was trying to manage a friend's iMac using Teamviewer but kept getting a message saying her version was too old.  My iMac is Catalina but my friend's iMac is running OS X Yosemite, 10.10.5 (I think).  Then I tried from an old Mac running OS X Yosemite and got the same message.  I discovered my Yosemite Mac was running Teamviewer 12 (I think - cant' check right now) and my friends was on version 10.  I helped her download version 12 and install it on her iMac.  We were both on the same OS X and using the exact same version of Teamviewer.  But I got the same 'too old' version error message and still could not connect.

Originally I was trying to access her iMac from my iMac running MacOS Catalina 10.15.4.  I got that 'too old' message and gave up.  I had been able to connect to my friends iMac using Teamviewer the last time I tried about a year or so ago, but before I upgraded to Catalina.

So I've no idea what the problem is.  Can anyone help?  Thanks!

2 Replies
2 Replies
Highlighted
Posted by Moderator Moderator
Moderator

Re: Two Macs same OS, same Teamviewer version but can't connect.

Hi @esmonde ,

Thank you for posting.

Can you kindly check the following articles for more information please:

  1. Sunsetting active support of macOS 10.11 and macOS 10.12 if any of the device is running these OS;
  2. TeamViewer supported OS - macOS to find the corresponding compatible TeamViewer version, please always install the latest version; 
  3. How to control a Mac running macOS 10.14 or higher please check out these sittings if you are actually connecting to these OS;
  4. Once again, please make sure that both sides of connection are running the lastest version of TeamViewer responding to the supported OS

Hope the informatin above will be helpful.

Warm regards,

Ying

Highlighted
Posted by
Henagon

Re: Two Macs same OS, same Teamviewer version but can't connect.

Thanks Ying for your reply and the links.

I'm still confused though.  My friend's iMac is from around 2005 and it's running Yosemite, as I wrote.  And, I have a 2008 Mac Pro also running Yosemite.  Both Macs have the same free version 12 of Teamviewer.  Should I be able to connect and control my friend's iMac?  I understand that TeamViewer no longer provide support, but I'm only trying to help a friend with some simple stuff.  If the above will not work, can you suggest a workaround?

Thanks!