Announcements

Would you like to co-innovate with us? If so, we’d like to invite you to become product development partners with us. Read more about it in our announcement Launch of the TeamViewer User Focus Program

Posted by Comstall
Henagon

Update Version?

I currently run version 7 (XP, as our software only runs on XP for now) on all our machines across the country. I know if the machine has been updated to version 14, I can't log on remotley on my computer using verison 7. What happens with the reverse. If I update my version to v14, and leave all our machines with version 7, can I log on via version 14 to machines running version 7?, or do I have to update all machines to version 14.

1 Accepted Solution

Accepted Solutions
Highlighted
Posted by Moderator Moderator
Moderator
Solution

Re: Update Version?

Hi @Comstall ,

Thank you for your post.

Yes - TeamViewer is able to connect from a higher version to a lower version. So you can have TeamViewer 14 locally to connect to TeamViewer 7.

Please be aware that Windows XP is no longer supported.
Please see this post for more information.
We always recommend our customers to use the latest version of TeamViewer and avoid using old operating systems which are no longer servicable.

Hope this will help you.
I apologize for any inconvenience caused.

Best regards,
Yuri

1 Reply
2 Replies
Highlighted
Posted by Moderator Moderator
Moderator
Solution

Re: Update Version?

Hi @Comstall ,

Thank you for your post.

Yes - TeamViewer is able to connect from a higher version to a lower version. So you can have TeamViewer 14 locally to connect to TeamViewer 7.

Please be aware that Windows XP is no longer supported.
Please see this post for more information.
We always recommend our customers to use the latest version of TeamViewer and avoid using old operating systems which are no longer servicable.

Hope this will help you.
I apologize for any inconvenience caused.

Best regards,
Yuri

1 Reply
Posted by Comstall
Henagon

Re: Update Version?

Thanks Yuri, appreciate your prompt reply.

I know XP is no longer supported, however I don't need it to be as I only need it to run my software, without updates. I am working on new software that will run on newer versions of Windows :)

Regards

Brett