Posted by Pollenator
Henagon

No ID or Password displayed for Teamviewer 14

Hi

I have a continuing issue with Teamviwer 14 on a Windows 10 computer in that when i open it to be connected to by another computer no ID or passowrd is displayed. Ater rebooting the ID and password sometimes return briefly but then disappear. I have tried:

1) Uninstaling and reinstalling Teamviewer

2) Stopping the Teamviewer service and restarting

3) Running as Administrator

I have had this issue on other computers too. looking forward to finding a fix!

Many thanks.

4 Replies
4 Replies
Posted by swisslifeidw
Henagon

Re: No ID or Password displayed for Teamviewer 14

Exactly same problem on W10 with TV14. Randomly sometimes password disapear on computers. Even if u change settings et registry to fix it.

Posted by Moderator Moderator
Moderator

Re: No ID or Password displayed for Teamviewer 14

Hi there, 

Thank you for your posts. 

Which TeamViewer version do you use? Please make sure to install the latest version.

Is port 5938 open for TeamViewer? If not, please open the port for TeamViewer. 

If you are in a commercial environment - are there any restriction within your firewall?

Looking forward to your answer and wish you a great day. 

All the best,
Natascha

 

Posted by swisslifeidw
Henagon

Re: No ID or Password displayed for Teamviewer 14

Hi,

we use teamviewer 14.1.3399.0

5938 TCP/UDP are open and we are able to process remote assistance successfully when password is available, but sometimes password is not here.

Same computer on morning is reachable and password is available, but on the afternoon password disapear

Regards,

Mickael.

Posted by Moderator Moderator
Moderator

Re: No ID or Password displayed for Teamviewer 14

HI @swisslifeidw 

Thanks for the fast answer. 

Can you please update all affected clients to the latest version 14.2.8352?

Please let me know if this could solve the password question. Looking forward to your answer. 

All the best,
Natascha