teamviewer starting fullscreen on boot

Options

updated teamviewer (free) to version 15.11.6. software now starts up with windows and opens fullscreen instead of just loading in the system tray.

poked around in the settings to see if there was a "start minimized" or "load to tray" option and but did not see anything obvious other than the "run at starup" option

is there some option i'm missing or is this a bug now?

 

Answers

  • JeanK
    JeanK Posts: 6,993 Community Manager 🌍
    edited January 2023
    Options

    Hello @HexerPsy@lilshawn,

    1) Go to the General settings (as on your screenshot) and untick Start TeamViewer with Windows

    2) Go to the Advanced settings and tick Close to tray menu

    3) Go back to the General settings and tick Start TeamViewer with Windows back again.

    With this, TeamViewer should start automatically and close to tray menu.

    Community Manager

  • Ford1
    Ford1 Posts: 11 ✭✭
    edited January 2023
    Options

    This does not work with the latest teamviewer software. What happens is when you restart the close to tray icon is still ticked but greyed out. Something in the software is disabling the close to tray feature.

  • JeanK
    JeanK Posts: 6,993 Community Manager 🌍
    Options

    Hi @Ford1,

    If the close to tray icon is still ticked but greyed out, it means that Start TeamViewer with Windows is still ticked.

    Make sure it's unticked before you access the TeamViewer options.

    Let me know if this has worked for you!

    /JeanK

    Community Manager

  • impulsivia
    impulsivia Posts: 1
    Options

    I have the same question as Ford1. I followed you advice but no difference. Unticking start teamviewer with windows automatically greys out close to tray menu.

  • JeanK
    JeanK Posts: 6,993 Community Manager 🌍
    Options

    Hi @impulsivia,

    I could not reproduce the issue. On my test devices, it works as expected:

    I'd recommend:

    1. Uninstalling TeamViewer following the Basic Uninstall Instructions
    2. Deleting the TeamViewer entries following the Advanced Uninstall Instructions
    3. Checking in C:\Program Files\TeamViewer if there is any file. If yes, delete it.
    4. Reinstalling TeamViewer from our website here: https://www.teamviewer.com/en/download

    Let me know if this has worked for you!

    /JeanK

    Community Manager

  • Ford1
    Ford1 Posts: 11 ✭✭
    Options

    I updated to the current version 15.38.3

    but the issue has not been fixed.

    The Teamviewer still opens in full screen when the option is set to start teamviewer with windows. And putting a tick into start teamviewer with windows automatically ticks on Close to tray and then greys out that option.

    This current version did not fix the issue of teamviewer opening in full screen when windows starts. Also I can confirm that setting the teamviewer icon properties to start minimised does not make any difference. Teamviewer starts in full screen when the option to start teamviewer with windows is ticked on.

    Unfortunately some people will find that this error of teamviewer opening in full screen at startup will interfer with other software. So far I have discovered that it interfers with MYOB's pdf manager software.

  • m33ts4k0z
    m33ts4k0z Posts: 1
    Options

    Hello.


    This is still an issue on 15.39.6. I don't know if this can be related to antivirus software not allowing registry modifications. I use Bitdefender.

  • Brad_at_CNC_Auto
    Brad_at_CNC_Auto Posts: 3 ✭✭
    Options

    This is a major issue for me.

    15.40.8 (64 bit) running under Windows 11 (latest and greatest) on a Microsoft Surface Book 3.

    I have tried all of the above ticks off/on suggestions.

  • JeanK
    JeanK Posts: 6,993 Community Manager 🌍
    Options

    Hi all,

    Could you please update your clients to 15.41.7 and check if it fixes the issue?

    /JeanK

    Community Manager

  • kkris87
    kkris87 Posts: 3 ✭✭
    edited May 2023
    Options

    15.41.9, Win 11 Pro, same issue here - teamviewer starts both in tray and in full screen

  • unwiredsoul
    unwiredsoul Posts: 4 ✭✭
    Options

    I'm having this exact same issue on a Windows 10 Home computer that has had TeamViewer for many years.

    The issue began appearing after switching over to the "New interface" and does not go away by switching between the new/old UI, changing the application shortcut to launch as "Minimized" (Windows Explorer setting), or by going thru the process of unchecking/rechecking the "Close to tray" and "Start TeamViewer with Windows" options.

    I also just updated from 15.41.9 (where this behavior started) to 15.41.10 and nothing has changed.

    Is this setting controlled by one (or more) registry keys?

    I should also note this is only happening on one PC of mine where I use TeamViewer, so I completely understand why it's difficult to reproduce.

  • unwiredsoul
    unwiredsoul Posts: 4 ✭✭
    Options

    UPDATE: A clean (advanced) reinstall of 15.41.10 resolved this issue on the one Win10 Home PC that had this issue.

  • davemud
    davemud Posts: 1
    Options

    Has there been any progress on this?

    I have clean installed many times on 4 different Win 11 devices. Win 10 devices work as expected.

    Win 10 (Installed on 7 computers), Teamviewer starts in tray as expected on boot.

    Win 11 (Installed on 4 computers), Teamviewer starts in tray and as a maximized window on boot.

    One of the Win 11 installs was an upgrade from Win 10 just done yesterday (Teamviewer started as expected when it was running Win 10)

    All 11 computers are running Teamviewer 1543.8 (64 bit)

    All but one are running Win 10 Home or Win 11 Home 64 bit 22H2 (The other one is running Win 11 Pro)

  • el_rabanero
    el_rabanero Posts: 1
    Options

    Same problem here.

    Windows 11 shows maximized Teamviewer window on every log in, while it is impossible to change greyed check in advanced options. Clean reinstall didn't work. Please fix that annoying bug.

  • niu_kamiyo
    niu_kamiyo Posts: 2 ✭✭
    Options

    Hello.

    I am using Teamviewer on Windows and have it set to automatically start Teamviewer when Windows starts. However, every time I start it, the connection settings window opens, which is very disturbing.

    Is it possible to start it in a minimized ?

  • JeanK
    JeanK Posts: 6,993 Community Manager 🌍
    Options

    Hi all,

    Our dev team is currently investigating the issue.

    I'll keep you posted in this thread as soon as I have news to share!

    /JeanK

    Community Manager

  • wambo
    wambo Posts: 1
    Options

    Any update on this?

    I'm running 15.47.3 and still have this issue.

  • asianhawk
    asianhawk Posts: 8 ✭✭
    Options

    Had to untick both, then restart computer and then reapply the ticks.

  • veryounique
    veryounique Posts: 5 ✭✭
    Options

    Never mind! The Properties thing STILL does NOT fix the problem! How is it possible that the TV cannot find a fix?

  • PoisonedBrick
    PoisonedBrick Posts: 1
    Options

    Properties thing doesn't work, but that regedit works. Thank you!!!


    For others, just edit [HKEY_CURRENT_USER\SOFTWARE\TeamViewer] "MainWindowMaximized"

    Change value to 0.