Can't login toTeamViewer on Mac OS

I have updated TeamViewer to the latest version: 15.11.6 (1c0ed2aeb38), but I cannot login with my account, which works just fine on I do not get any kind of error message, when I enter my email and password, it simply does nothing.

Mac OS version: Big Sur 11.0.1


  • JeanK
    JeanK Posts: 6,848 Community Manager 🌍

    Hello @TenshiRyu,

    Thank you for your message and welcome to the TeamViewer Community! ?

    macOS 11.0 (Big Sur) is only compatible with TeamViewer 15.12 and newer, which we have not released yet. Please be patient, we will soon release the 15.12 version and you will be able to use it on your Mac device.

    I hope this could help. ?

    Stay safe and sane! ?


    Community Manager

    JGSKEWES Posts: 1

    This reply is informational - but still leaves TeamViewer unusable - and with no timeline for release of an updated application, it leaves me angry.
    So now I'll shop around. If TeamViewer does not view MAC users as valuable customers - then what is the point.


  • JeanK
    JeanK Posts: 6,848 Community Manager 🌍

    Hello @JGSKEWES and @TenshiRyu,

    We have updated our macOS version to 15.12.4.

    This version is compatible with macOS 11.0 (Big Sur).

    Feel free to update your TeamViewer and use it on your Mac devices!

    Feedback would be highly appreciated. ?

    Best regards


    Community Manager

  • TheKevan
    TheKevan Posts: 1

    Teamviewer 15.14.3, macOS Big Sur 11.1, still having this problem. Enter email and password, click the sign-in button, doesn't do anything. Just sits there.

  • same problem here. I enter the correct user name and password. but it does nothing once I try to hit login. please help?

  • V_Ireland
    V_Ireland Posts: 0 Newbie

    Same story. Works on 2014 MB Air, not on M1 Mac mini. (Both Big Sur)

  • jfortes
    jfortes Posts: 0

    Same thing here, not working on mac book pro M1. I use the correct login and password, and nothing happens when I click the sign-in button.

  • stevie_d
    stevie_d Posts: 0

    I am still experiencing this issue on Mac OS 11.2.3 using TeamViewer version 15.15.5 (4dbfdadce58)

  • stevie_d
    stevie_d Posts: 0

    Now on version 15.16.8 (b0756eefb01) and the problem persists.

    I have asked our IT Purchasing to look for a different tool as Teamviewer is completely ignoring Apple M1 users.

  • matuzalem
    matuzalem Posts: 1

    Same issue here:

    OS: macOS 11.2.3 20D91 arm64 

    Host: MacBookAir10,1

    TeamViewer:Version: 15.16.8 (b0756eefb01)

    I just lost a valuable client because I could not login to support them.

  • Hello,

    I am having the same issue. No M1 involved though. version 15.1.3937

    Thank you

  • taylorsteve
    taylorsteve Posts: 1

    I'm having the same problem with OSX 11.2.3 and TEamviewer 15.16.8. Tech support says it must be the remote iMac because they can't explain the lack of connecting. This is terrible support.

  • edsmith323
    edsmith323 Posts: 0


    I'm having the same problem, unable to sign in on mac os 11.2.3. Updated TV to the latest version 15.16.8.

    Username and password are correct, click sign on nothing happens.

    If Login to the website and the management console, click connect on my MacBook, allow a TeamViewer connection, when I open TV again it's logged in.

  • 68a869
    68a869 Posts: 0

    Same issue here. After big sur update on macbook air cannot connect to teamviewer 15.16.8. It sounds like this is a known issue. Can the moderator or someone from Teamviewer give an update?

  • 68a869
    68a869 Posts: 0

    Update: Problem resolved itself. After big sur update on the macbook air, was unable to connect from Windows. The mac showed teamviewer availability and was on the setup screen for big sur. After the setup options were complete I was able to connect.

  • wholockedat221b
    wholockedat221b Posts: 0 Newbie

    Mid April 2021 having this same issue.

    TeamViewer 15.16.8

    macOS 11.2.3

    MacBook Pro 17,1

  • ToastSteve
    ToastSteve Posts: 1 Newbie

    April 22, 2021. I can't log into my remote tablet any more. It was working on my old MacBook Pro before it disintegrated but is not working on my new MacBook Air. I go to log in, it says loading display preferences, and then I get non-rotating beach ball. I have to Force Quit to get it to stop. I have uninstalled using the recommended process and re-installed with no resolution.

    TeamViewer 15.6.8

    macOS 11.2.3

    MacBook Air M1 (2020)

    This is incredibly frustrating. I can't do my job properly at this point and looking for a new solution to replace TeamViewer.

  • notadamb
    notadamb Posts: 3 ✭✭

    April 28

    Still the same issue.

    I enter username and password, click Login, and nothing happens.

    Tried restarting computer and reinstalling app.

    Running 15.17.6 (a008a771384) on 11.3 (20E232)

  • Anders_Hazen
    Anders_Hazen Posts: 1 Newbie


    (By the way, I have a Norwegian version of the client, some names within the TeamViewer Client will not be accurate...)

    1) Go to TeamViewer - General - "Assign Account"

    2) Enter Your "User Name/User Account" and Copy your password from Safari - that's it.

    Do not autofill your password from Safari.

    Best Regards

    Anders Hazen

  • YoSappy
    YoSappy Posts: 4 Newbie

    Nope, that does not work. I can't even type the password to Login because the keyboard doesn't even work. FIX THIS JUNK! Also, this so-called SPECTACULAR USER COMMUNITY DOES NOT FIX ANYTHING! It's just a bunch of GUESSERS with ZERO SOFTWARE ENGINEERING EXPERTISE. WHAT A JOKE!