teamviewer.com link icon
or
Ask The Community

Some applications does not show content (white window) Windows 10 host

Hi,

I'm running Teamviewer 12 on a Windows host - checking for updates it says I'm running the latest version.

My problem is that some programs (Handbrake, NordVPN for example) only comes up with a white window when launching them. You can see the Title on top of the window and you have the "X" to the top right to close the program, but that's it.

Funny thing is that when I launch the program in front of the host and then later connect remotely the program does display everything correctly. Same thing if I reboot the computer and launch the program remotely.

Any ideas?

Thanks in advance,

Best Answer

«1

Answers

  • I had the same issue with this as well.

    I have a laptop that is always on and connected to my TV (It's used as a media server). When I connect remotely and try and open certain applications (Java based apps etc) then I get the white box.

    When I switch my TV on and then remote into the PC, there is no longer a white box. It's something to do with the resolution. 

    I would try removing your TV when you are away (if possible) or just connect an old monitor haha - this worked for me (removing the TV cable)

  • I wonder if the programs are using the graphic card or something advanced to display their window. I get this error with Handbrake, and the Plex client from the Windows store.

    It is super annoying, for sure!

     

  • I still have the same issue in JavaFX windows in TeamViewer 13

  • Not sure what just happened, it was working just fine and suddenly applications just start showing completely white??  Just like that. No changes of drivers, applications, configuration, absolute nothing different than an hour ago... and bam, Teamviewer completely useless. How is that possible? 

  • Hey,
    What sort of monitor and resolution is the device you are remoting onto using?

    Mine always has white boxes on applications when I remote in, the device I'm connecting too has a TV as the monitor as I use it for a server.

    However.. When the TV of the device I am remoting onto is switched on, then I have no issues with the white boxes - it's so strange.

    I've fiddled with the resolution settings etc but it only works fine when the device's monitor is switched on *shrug*
  • I think someone must have shut down the display/monitor connected to it by accident. It has a DVI input but dunno for sure what type of monitor is connected. Probably a cheap screen though since it's mostly used remotely. Thanks for getting back to me so quickly. I guess i'll stop trying to troubleshoot that remotely. I've reinstalled drivers, applications, installed chrome remote deskptop to try an other remote desktop application, same **bleep**. It's too frustrating, i'll wait a few hours until someone's physically in that room and turns the darn monitor on again. SMH.

    Cheers.

  • I have the same problem. I cannot immagine that it is the monitor, since only one application shows a white window, but not the others. How could the monitor know? What else could cause this issue?

  • kai696
    kai696 Posts: 3

    This sounds like a rendering issue, if minizmied and restored does this fix the issue?

    Do you use an integrated graphics chip or are you using stand-alone? (or both running?)

    Have you updated your graphics drivers regardless of your chip? Does this only happen on Teamveiwer? Have you installed the Monitor Driver for the software, if so was that successful? 

     

    Please let me know at your earliest convenience. 

  • In our case the issue was known to be related to a defectuous display emulator, it had to be replaced. Everything worked just fine since.

    Cheers,

    A.

  • Hi, 
    Do you use an integrated graphics chip or are you using stand-alone? --> I use a GTX1080Ti with the newest driver.
    Does this only happen on Teamveiwer? --> It only happend with Teamviewer. At the PC the software works without any problems. I did not use any other remote viewing software.
     Have you installed the Monitor Driver for the software, if so was that successful? --> No, how to install a monitor driver for a specific software, this is new to me.

    The software is made by a smaller software company. It does not offer the feature of minimizing and restoring.

    Any idea how to fix the problem?

     

  • I have the same issue, I see this issue with Chrome Remote Desktop as well.

    I have Intel HD Graphics 3000 , not sure if there is a setting that can fix this.

    If I create a vm on the host and run the same application inside the VM I can see the screen for the same application just fine. 

  • I tested this last night. If my monitor is turned on, the application shows just fine. If I turn the monitor off, the application shows white. The graphic rendering engine must be making a decision to render the window or not. The thought is probably “why waste the resources to draw this window if the user can’t see it?” Unfortunately for us, it does not take into account remote control scenarios.
  • Glassdub
    Glassdub Posts: 80 ✭✭

    Yeah, I got this problem now that I've installed SAMSUNG U28E590D 4K monitor, connected by DP cable, Firefox would whitescreen, I was able to fix this by disabling graphic acceleration but Windows Live Mail still only displays part of the screen, I may have to unplug the cable when I get home to see if it resolves this as I've been at this all night remotely, getting nothing done, I never thought switching a monitor would be such a pain. :-/    

  • Glassdub
    Glassdub Posts: 80 ✭✭

    I've since found that connecting a HDMI cable to the mb port to monitor seems to fix this, I can still default to using the add on video card to monitor by DP cable when at home but somehow having that second connection resolved this issue.

  • raymar8
    raymar8 Posts: 1

    For me, I get black windows!  I am remoting into a laptop media server, which used to work fine.  However, as of a couple of days ago, I am starting to see black windows for VLC (I hear audio but see no video), Next PVR, and even Firefox and Edge browsers.  It's the same whether I use TeamViewer or Chrome Remote Desktop.  However, following the comments above, I have just realized that if I open the laptop lid, all the windows display correctly.  If I close it again, they go black.  So, yes, it's definitely a rendering issue.  I wonder if there was something contained in a recent Microsoft update that caused this behavior?

  • MONSTaR
    MONSTaR Posts: 1
    It's not a Microsoft update causing; all or my machines have group policy restriction on updates yet still black screen certain apps.

    Not exclusive of teamviewer either. Happens with CRD as well
  • Have the latest version of Teamviewer. Whenever I try to access remote desktop through teamviewer on host computer the white screen appears.

  • Hey I have exactly the same problem and a Samsung monitor. When you say 'connecting a HDMI cable to the mb port to monitor' ... what do you mean by mb port to monitor? Just trying to resolve this issue so I can actually use TeamViewer? Thanks

  • This sounds like my exact issue, but the remote machine is a Mac.

    The remote machine is mac mini that does not have a monitor attached at all. It is headless.

    The issue only started after upgrading the remote host to Mac OS Mojave.

    I have used Team Viewer without issues on this host for around 6-12 months, without a monitor attached.

    Please note, **Third Party Product** is working perfectly fine and it's the only reason I can continue to work remotely on this machine.

    With an external monitor plugged into the mac mini, the problem is solved. You can then unplug the monitor and the remote session continues to work.

    After a reboot, the problem returns, unless a physical monitor is present.

    I'm going to try the dummyplug, that could be a cheap solution. They are under $10 online.

  • buzz339
    buzz339 Posts: 1

    When I open Internet Explorer Edge remotely with Teamviewer (latest release), it shows the start page fine. However if I go to any other page it shows a blank.  If I grab on the edge of the window and drag it to make it larger, the page goes from blank to displaying the content, but only while dragging.  As soon as I release my finger from the mouse button, the page goes blank again,  How to fix this?

  • egorks
    egorks Posts: 1

    i am pretty sure its an issue with teamviewer. remote desktop works fine in same circumstances.

    also looking for a solution since this is very annoying, also i cannot recall such an issue in an earlier TV version. will downgrade to TV v11 in the mean time.

     

  • KF001
    KF001 Posts: 1

    I had the same problem (my client --> TV host --> RDP client to another host) and the RDP client window was black (running on the TV host) if the monitor is not turned on at the TV host.

    I found a workaround: I've installed the VPN driver on my client and on the TV host, and selected VPN when connected to the TV host and using the VPN tunnel I was able to create an RDP connection from my computer to the TV host and this connection can run and RDP client properly.

    This connection is noticably slower than the TV connection, but has no problem with turned off monitors.

  • Pade
    Pade Posts: 1

    Hi. Same issue here. This is not a fix, but i found with my monitor that instead of I shut it down from power button, I change picture source to something else than DP, which i normally use. My monitor goes black since it has no signal and after a while it goes sleeping. With this i can sleep my nights and remote desktops work fine. (Teamviewer and google remote) If I shut down from power button neither of those does not work.

  • Romeo2
    Romeo2 Posts: 1

    The teamviwer team can do something to prevent this form happening ... this software uses a virtual display driver that activates the videocard just like the physical display monitor ... use this software: https://www.spacedesk.net/download/

  • Thanks but how does this work to solve the problem? I just leave my screen on these days and it works fine

  • Get one of these ghost adapters, really cheap.

    I had someone on site insert one of these and its fixed the white window issue. Very cheap solution, only seemed to happen on one of our Mac Mini's the others are all fine headless.

  • @Julia if you have a laptop that the lid is closed, you will face the exact same problem since there will not be any power directed to the LCD panel. If you open the lid everything will work.

  • This answer expands upon @Julia's, second point 'Window contents that are drawn hardware-accelerated (e.g. browser content or 3D applications / games) are no longer drawn (you cannot see the application)'.

    See 'Solution' below.

    Abstract
    I have noticed this issue commonly relates to Java applications when the primary monitor is no-longer attached to the device; such as certain laptops which "disconnect" the built-in screen when the lid is shut - corroborated by @ashimet - or workstations when no screens are attached.

    Based upon the behaviour of applications with and without a monitor attached, a surface level understanding of graphics accelerators (https://en.wikipedia.org/wiki/Framebuffer#Graphics_accelerators), and experiences in the forum posts I've referenced below, I believe the cause of the contentless windows is the result of application dependencies upon either the DirectDraw or Direct3D sub-systems - which interface with 3D acceleration hardware - when the accelerators are disabled as a result of the disconnection of a monitor.

    I think I've also experienced similar problems when attempting to run applications which depend upon 3D acceleration within a Linux environment using the Wine compatibility layer (https://bugs.winehq.org/buglist.cgi?component=directx-d3d&product=Wine&resolution=---)

    Perhaps this is a power-saving feature of 3D graphics processors which activates when no screens are detected, or perhaps this is related to the framebuffer being unaware of the supported output resolutions and so disables access to the GPU for the Windows shell, which causes Windows to revert to software-only rendering; or some other reason.

    Whatever the cause, my assumption that the dedicated graphics hardware was unavailable for 3D processing when the monitor is disabled, and the common denominator for all software experiencing the problem was Java, I questioned whether the JVM was depending upon D3D for rendering, even though Windows only had software-only rendering available.

    Solution
    Ref: https://superuser.com/a/496775
    Using DXDiag, I checked the status of Display DirectX Features:

    DirectDraw Acceleration: Enabled

    Direct3D Acceleration: Enabled

    AGP Texture Acceleration: Enabled

    I manually created these registry values, in addition to creating the Direct3D\Drivers key:

    Reg Add HKLM\SOFTWARE\Microsoft\DirectDraw /V EmulationOnly /T REG_DWORD /D %_Mode% /F
    Reg Add HKLM\SOFTWARE\Microsoft\Direct3D\Drivers /V SoftwareOnly /T REG_DWORD /D %_Mode% /F

    Then, using DXDiag, I checked the new status of Display DirectX Features:

    DirectDraw Acceleration: Disabled

    Direct3D Acceleration: Disabled

    AGP Texture Acceleration: Not Available

    The Java program window now rendered content correctly via VNC Viewer, when monitor is detached.

    I've not tried the "ForceDirectDrawEmulation" option within the Compatibility Wizard suggestion from the referenced SuperUser thread.

    Research and references
    Disable hardware acceleration in Windows Display Settings
    Ref: https://www.auslogics.com/en/articles/disable-hardware-acceleration-in-windows/
    > Not tried because Display Settings window crashes

    Attempt to prevent GPU (ATI Mobility Radeon HD 4500) from disabling hardware acceleration when monitor disconnects
    Ref: https://social.technet.microsoft.com/forums/windows/en-us/8a9b5aa7-fe33-4e6d-b39b-8ac80a21fdc2/disable-monitor-off-detection-how?forum=w7itprogeneral
    > Disabled ?Display Detection?, to prevent disconnection being detected to avoid disabling of HW acceleration

    HKLM\SYSTEM\ControlSet001\Control\Class\{4d36e968-e325-11ce-bfc1-08002be10318}\0000 Display_Detection_DEF DWORD 1

    > Create/NULL DMMEnableDDCPolling for ATI cards - Ref: Post by NetMage

    HKLM\SYSTEM\ControlSet001\Control\Class\{4d36e968-e325-11ce-bfc1-08002be10318}\0000 DMMEnableDDCPolling DWORD 0


    System-wide (Java Control Panel) disabling of D3D acceleration for Java applications
    Ref: https://forums.guru3d.com/threads/disable-hardware-acceleration-for-java.296918/#post-4096709

    System-wide (Envionment variables) disabling of D3D acceleration for Java applications
    Ref: https://stackoverflow.com/a/36235217
    > System Properties for Java 2D: http://docs.oracle.com/javase/8/docs/technotes/guides/2d/flags.html
    > Tried setting user Environment Variables, but it didn't resolve the contentless Window issue:
    >> _JAVA_OPTION=-Dsun.java2d.d3d=false -Dsun.java2d.noddraw=true
    >> J2D_D3D=false

    Disable Direct3D acceleration on Windows 7
    Ref: https://stackoverflow.com/questions/14497545/how-to-disable-direct3d-acceleration-on-windows-7
    > Guide for directx.cpl - changes 32-bit DirectDraw and Direct3D, but not 64-bit (dxdiag 32/64-bit): https://stackoverflow.com/a/25508331

    Disable DirectDraw and Direct3D acceleration on Windows 8[/10]
    Ref: https://superuser.com/questions/495303/how-do-i-disable-directdraw-and-direct3d-acceleration-on-windows-8
    > Guide for directx.cpl - changes 32-bit DirectDraw and Direct3D, but not 64-bit (dxdiag 32/64-bit): https://superuser.com/a/504510
    > DirectDraw and Direct3D registry entries: https://superuser.com/a/496775

  • meme1
    meme1 Posts: 1

    Sooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooo.......what is the point of using teamviewer then?

Sign In or Register to comment.