Compatibility between versions 15 and 10

I would need to connect to an old OSX 10.11.6 (El Capitan) laptop from High Sierra (11.2) but apparently the corresponding versions of TeamViewer (10 and 15) are not compatible.

Is there a workaround to this, or anything I am missing?

Thank you.

Best Answer

  • Yuri_T
    Yuri_T Posts: 2,256 [Former Staff]
    Answer ✓

    Hi @dactyl,

    Thank you for your post 😊

    TeamViewer is backward compatible: licensed versions can always connect to older versions, but for private versions are required the latest version on both devices. You can check the supported operating system from the below article.

    Please note that we are no longer actively servicing macOS 10.6 to 10.12. You can continue using the last supported version of TeamViewer on those operating systems, but we are no longer providing updates or fixes which are specific to them. See this announcement for more details.

    Hope this information will help you.

    Kind regards,

    Yuri

    Former Japanese Community Moderator

Answers

  • Yuri_T
    Yuri_T Posts: 2,256 [Former Staff]
    Answer ✓

    Hi @dactyl,

    Thank you for your post 😊

    TeamViewer is backward compatible: licensed versions can always connect to older versions, but for private versions are required the latest version on both devices. You can check the supported operating system from the below article.

    Please note that we are no longer actively servicing macOS 10.6 to 10.12. You can continue using the last supported version of TeamViewer on those operating systems, but we are no longer providing updates or fixes which are specific to them. See this announcement for more details.

    Hope this information will help you.

    Kind regards,

    Yuri

    Former Japanese Community Moderator