How to lauch local program as opposed to web - which doesn't work



How do I launch the locally-installed program where I see my list of devices where I can double-click and it will initiate a remote session?

This is the way it has worked for years, but now I'm always taken to a web page - which looks similar to the local program, but the "Connect" button flashes up a number, disappears and nothing happens.

I have two programs installed - TV and TV Host (I didn't use to need TV Host ).

If I launch TeamViewer, I get the following:

(It initially has text boxes to enter my email and password but logs in automatically)

I then click "Computer & Contacts" which takes me to "TeamViewer management console" web page.

I have noticed that if I run the TV installer (TeamViewer_Setup.exe), I get the pane I am looking for:

I've just downloaded and upgraded 15.14.4 to 15.15.5 and interesting I have an old version:

I can try launching via the icon in the system tray or start menu, with the same result.

I'm running Windows 10 20H2.

Thanks in advance.