My company has TeamViewer Corporate but I keep getting License already activated,

Options

Hello, The company I work for has a TeamViewer Corporate account, bet when I use the activate link it gives me a message 'License already activated' and my account stay 'Free'.

Best Answer

  • JoshP
    JoshP Posts: 896 Community Manager 🌍
    edited September 2021 Answer ✓
    Options

    Hello,

    Thanks for your post.

    Your company may have already created a Company Profile - In this situation, you would need to request addition to the profile to utilize the license.

    Information on the steps can be found here. I have summarized what you should do below:

    • Go to https://login.teamviewer.com/cmd/joincompany
    • Log in with your own TeamViewer credentials
    • When prompted, enter the email address of the Company Admin - this would be the user(s) in your company that manage the license

    Should you have any trouble with this, or require more clarification, we recommend reaching out to our support teams directly. You can find local numbers here.

    Josh P.

    Senior Community Moderator

    ---

Answers

  • JoshP
    JoshP Posts: 896 Community Manager 🌍
    edited September 2021 Answer ✓
    Options

    Hello,

    Thanks for your post.

    Your company may have already created a Company Profile - In this situation, you would need to request addition to the profile to utilize the license.

    Information on the steps can be found here. I have summarized what you should do below:

    • Go to https://login.teamviewer.com/cmd/joincompany
    • Log in with your own TeamViewer credentials
    • When prompted, enter the email address of the Company Admin - this would be the user(s) in your company that manage the license

    Should you have any trouble with this, or require more clarification, we recommend reaching out to our support teams directly. You can find local numbers here.

    Josh P.

    Senior Community Moderator

    ---

  • jord
    jord Posts: 2 ✭✭
    Options

    Thanks Josh, Weird that I was the only one at out company who had to do that.