teamviewer.com link icon
or
Ask The Community

Mouse click not working

ztraeger
ztraeger Posts: 2 ✭✭

I know this has been asked a bunch of times, but I've read through every thread and still cannot get remote mouse clicks to register. Both keyboard input and screen monitoring are working.

"Actions/Disable Remote Input" is greyed out as an option. Remote computer is running Mojave, computer trying to access is running high sierra. I've run through the mac permissions and everything is set correct on both computers. Full disk access is allowed in Team Viewer Preferences. Unplugged the mouse on the remote computer, restarted both computers. Tried pressing the alt key. Enabled secondary click on mouse.

Any additional suggestions or something I'm not considering?

«1

Answers

  • BillDMcGee
    BillDMcGee Posts: 1

    My exact problem as well. But, I am using a Windows 10 machine to connect to a Mac.

  • Assaf1113
    Assaf1113 Posts: 4 ✭✭
    edited January 11

    I had an online private class, and for some reason my teacher was not able to use the his mouse Left click on my computer.


    we tried to reconnect/disconnect i restarted my computer and Reinstalled teamviwer.


    Nothing worked. later that day when i tried to Remote control my computer with my Laptop it worked fine, any idea why?!


    I am using Team viewer 15


    and my OS is Windows 10 home edition.

  • ztraeger
    ztraeger Posts: 2 ✭✭

    Anyone have any ideas?

  • Assaf1113
    Assaf1113 Posts: 4 ✭✭

    Environment : Windows 10 Home edition 64 bit

    Team viewer V15.25(64 bit)


    Description:

    - let someone else remote control my PC.


    Expected result:

    That someone will be able to access my computer, move the mouse and use it to select icons and activate applications on my PC.


    Actual result:"That someone was able to gain access to my PC and move the mouse around however, he was not able it to select icons and activate applications on my computer the. left click was effectively disabled.


    Notes: i tried to ask someone else to gain access to my PC and tried to access it myself using my laptop. in both cases the Left Mouse button worked fine.


    I asked about few days ago and went completely unanswered can i please get some answer now please?

  • jamc
    jamc Posts: 1 Newbie

    I'm having the same problem. I can remote in just fine, see everything and move the pointer. I just can't click on anything. After about 2 minutes the pointer on remote computer gets very small. Can anyone help with this. I have uninstalled and reinstalled the software.

  • bjornagn
    bjornagn Posts: 1

    I have the same problem. Have tried to access from both a mac and a PC, with same result, keyboard working but mouse inactive. All TeamViewers are up to date.

  • davide3203097
    davide3203097 Posts: 2 ✭✭

    Hi everyone,

    I am writing because I have a problem with Teamviewer: I have recently added a second monitor to the station that I have to remotely control. When I start the session I see both screens correctly but I can only interact with one of them during videocall. On one I can write, point with the mouse and click to open applications while on the other I can only write with the keyboard and move the mouse but without clicking. Due to this problem I cannot interact with the windows I open on the second monitor which then get stuck.

    I tried to update the software on both stations but without success… what can I do? It's urgent.

    Thanks!

  • Vijoy
    Vijoy Posts: 1 Newbie
    edited January 18

    Same here. Can't figure out any solutions. Trying to control macs running Catalina 10.15.7. All Security / Privacy settings has TeamViewer set to "Full Access". Worked until Nov 2021 just fine.

    Can use the same Catalina macs 10.15.7 with Teamviewer  15.25.5 to control Macs running Big Sur. No problem.

  • MahamMultani
    MahamMultani Posts: 1 Newbie

    @ztraeger I already tried many YouTube tutorial both pc selected never notify slider. This Is Not Working.

  • Madbox_justin
    Madbox_justin Posts: 2 Newbie
    edited January 18

    Experiencing the same issue on Catalina (and Big Sur). Permissions are are granted on remote desktop, but can only see desktop not control. Previously worked on machine...what happened with the latest Teamviewer update?

  • antoineburke
    antoineburke Posts: 1

    Facing a similar issue since I am using the latest version (15.25.5 (5ceca702ecc)).

    It was working fine before but since the upgrade, when the remote computer is connected to a secondary screen, keyboard interactions are working but mouse is not. I tried reinstalling on all computer but nothing helps.

    When there is no external monitor on the remote computer, everything works fine.

    I would suspect a bug somewhere... help needed.

    Thanks,

  • Zinkle
    Zinkle Posts: 2 Newbie

    Still no solution? Im simply going from android to Windows 11 PC. Touch or mouse clicks dont work....

  • StephenMonaghan_DK
    StephenMonaghan_DK Posts: 1 Newbie

    Same issue here Mac OS 12.1 - Mac OS 12.1.

    Whats going on?

  • TarsDJ
    TarsDJ Posts: 4 ✭✭
    edited January 26

    I'm experiencing the exact same problem.

    Mouse clicks are not registering when the remote computer has more than one screen (video call is on). When I remotely switch the session to the other monitor (via the menu bar at the top of the screen), everything works fine. Mouse clicks are only registering on one monitor. Mouse movement, and scrolling with the scroll wheel works perfectly on all monitors.

    My colleagues all have more than one screen, and they all have the same problem. Problem occured after a recent update.

    Reinstalling/updateing Teamviewer on both stations does not help. Both stations are running Windows 11.

    Thanks

  • Assaf1113
    Assaf1113 Posts: 4 ✭✭
    edited January 28

    Environment:

    OS: Windows 10 home edition

    Software version: TeamViewer 15

    Mic: Siren razer x

    what i did:

    1:Opened TeamViewer.

    2:Allowed my teacher to remote control my computer.

    3:Enabled the mic in the software by pressing on the mic button in the software.

    expected result:

    The teacher will be able to hear me, he will be to move the cursor . and control my computer.

    Actual result

    My teacher cant access my computer and move the cursor around but left click is not working for him.

    notes

    this problem happens with anyone who tries to remote control my computer.

    -i downloaded the most recent version (15.26) to see if the problem will persist.

    and the problem indeed persists

  • luckman212
    luckman212 Posts: 2 Newbie

    Same problem... but in my case iPhone --> Win11 PC running latest TeamViewer host.

  • luckman212
    luckman212 Posts: 2 Newbie

    Same problem .... left click in recent versions is maddeningly buggy.

  • hmalinjod
    hmalinjod Posts: 1

    had a similar issue, I couldn't click, dragging a folder would make the folder stick to the cursor and never let go.

    In my case, in TV's Advanced tab/Access control, changing it to CUSTOM SETTINGS instead of CONFIRM ALL, fixed it. Even with all field individually set to "After Confirmation" and some to "Deny".

    I'm on Mojave 10.14.6, tested with TV 14 and latest TV15.

  • earthcomedy
    earthcomedy Posts: 2 Newbie

    Using latest version of Teamviewer. 15.x on both PCs (laptops).

    Windows 10 on both machines.

    As noted in a couple of earlier discussions (No resolution), screen looks fine, keyboard works, just not the mouse click. Search - MOUSE CLICK NOT WORKING

    Any ideas on a fix date or workaround?

    While talking to other party I have to tell them to click on things while I move the mouse around....

  • TarsDJ
    TarsDJ Posts: 4 ✭✭

    I have the same issue. Only when the remote host has an external monitor, and when voice commumication is enabled...

  • IFe
    IFe Posts: 2 Newbie

    I have the same issue for sometime, thought it is because of the connection, but it works if ones keep the mouse button down a little longer. Also, the touch screen works fine. Maybe some update messed this up, or it is as design?

  • Jlogan
    Jlogan Posts: 1 Newbie

    Ive just started getting the same issue.

    Mouse clicking is very non responsive and have to hold the mouse button down for a long time for it to register.

    Restarting the connection works for a short time, then the problem reoccurs.

  • coon
    coon Posts: 1 Newbie

    We have been also experiencing same issue on all windows environment. Restarting teamviewer and reconnecting helps temporarily. Horrible when controlling multiple sessions at a time. Fix asap!

  • Arniol
    Arniol Posts: 3 ✭✭

    Have the same problem; Connect fine, file transfer works, keyboard works and everything is quick an snappy.

    The mouse click is the problem, rigth and left both. I have to hold the button 2-3 seconds to get responce and double click is almost out of the question.

    I toggled the Options - Advanced - Advanced settings for connections to other computers. Changed from Custom to Full and back to custom. Optimized quality for speed. Ran TW as admin and not.

    The first session after restarting TW is fine works fast and is ok in any setting I tried but every connection after that is slow.

    I'm running WIN10 [10.0.19043.1466] Teamviewer 15.27.1 64-bit the remote client is WIN10

  • Arniol
    Arniol Posts: 3 ✭✭


    Solution is here if you opted to Receive insider builds and you have build 15.27.1

    Uninstall and reinstall build 15.26.4 and untick Extras --> Options --> General--> tick Receive insider builds

  • Arniol
    Arniol Posts: 3 ✭✭

    Mouse click-to-select not working

    DrSramicFeb 8, 2022

    Teamviewer V15.27.1

    I have an issue with after connecting from PC to remote PC (Windows 10 to Windows 10) machine where when I click on something it does not select what I clicked on. The mouse cursor moves, the items highlight the hover over, if i click and drag it works no problem, i can draw a select box and you can see the mouse button action that it is pressed and held down, and you can see the release, but when I click on a menu item or a file, I cannot select it. No double clicking responds to open a program or file. I have attached a recording of my issue below. If I EXIT teamviewer and restart TEAMVIEWER , and reconnect to the remote pc the mouse clicks will work but only for 1 session. If I close and reopen the same connection or any other I get the same problem back.

    https://us.v-cdn.net/6032394/uploads/FI21DR1J29QR/teamviewer-mouse-click-issue.gif

    View Post


    Solution is here if you opted to Receive insider builds and you have build 15.27.1

    Uninstall and reinstall build 15.26.4 and untick Extras --> Options --> General--> tick Receive insider builds

  • IFe
    IFe Posts: 2 Newbie

    It appears that a workaround works by restarting the TeamViewer.

  • earthcomedy
    earthcomedy Posts: 2 Newbie

    Not sure the version on the remote machine just right now, but the version I have here is 15.26.4


    Insider Builds is NOT checked.


    I'm assuming remote machine is similar, but I'd have to log in and check. I installed the REMOTE version, so I imagine it is the same.

    Have not tried holding the mouse button down either as some have indicated does "work."

  • mtdc
    mtdc Posts: 1

    just would like to share if the clicks aren't working it might be because the latest updates to Teamviewer had a bug, a simple way to overcome this is just to uninstall Teamviewer, re-download the latest installer and do a fresh reinstallation. You can also use another laptop or PC and install a new Teamviewer there and see if the left clicks work now.

  • G_Baylis
    G_Baylis Posts: 5 ✭✭

    I have a Windows 10 64bit PC running TeamViewer 15.26.4 (Let's call this PC "A")

    (I am using 2 others to test this issue, All 3 are Win 10 on TV 15.26.4, one is TV 32bit. All 3 PC's rebuilt within the last 6 months)

    If I remote to "A" (From PC "B" (or alternately PC "C")) I can left/right click from both units fine...

    If I touch options within the sidebar on "A" (to perhaps turn "A"' microphone ON (unmute)) I loose the ability to left/right click from "B"... but can still do so from "A". (It does not matter if I touch the headphone icon on "A"'s sidebar from "A" OR "B", the result is no mouse clicks from "B"

    This also happens if I remote "A" from "C"

    If I remote to "B" or "C" from "A" or if I remote between "B" and "C" I do not have the issue which seems to point to the problem at being "A".

    I uninstalled TV on "A" (Twice. Once leaving the settings, the 2nd time removing settings) but the problem persists. (I note removing the settings option still reinstalls with the remote ID's for "B" and "C" so it didn't actually remove ALL settings).

    I've looked through the previous logged calls and have seen this issue over and over (Although not many seem to have tested the mouse before and after clicking on that sidebar).

    Remoting to a vacant "A" is fine (As long as I just minimize the side bar) but If I am trying to say "Teach mum how to rule the interweb" and try and have both "A" and "B" headsets working, it is impossible without killing the click ability from the calling PC ("B" or "C").

    If there was a way to force the headphones on at connection this would be avoidable.

    I checked the settings on all 3, tried multiple combinations and all failed. (I was an IT tech for 20+ years (EDS, Telecom NZ Etc.) and have done quite a bit of bug sorting on Helpdesks so this is a little frustrating...

    It may be a mouse/video driver (I'm surprised how often a video driver affects applications when all it should do is display things... but then again I'm not a programmer)...