Can't connect to Teamviewer QuickSupport on android

zebul666 Posts: 1
edited July 26 in Linux only

I wanted to help someone, so I tested it first myself with Teamviewer QuickSupport on an android 7 tablet (Huawei AGS-W09)

But I couldn't connect to it from my linux desktop. With teamviewer 15.43.7 either on wayland or Xorg.

I upgraded to 15.44.4 and it changed nothing.

What is happening, is that I enter the ID, and click Connect, then I authorize the connection on the android tablet, but then nothing is happening on teamviewer (desktop remote control). Even the button is back to "Connect" state.

While on the android device, the spinning wheel keep turning for a while, and then stops.

It seems the connection attempt is made, but then after that, nothing. I disabled my firewall and VPN, just to be sure, but the problem is still there.

I tried from Windows 11 (from the same desktop) and it worked fine.

Edit: oh and by the way, I had to use the so called "old" GUI on windows , to get it working; because otherwise, it says that the session is unknown...

So ?