Mac OS High Sierra - which version of teamviewer to use? Teamviewer not working anymore on this OS

Options
marinajackson
marinajackson Posts: 8 ✭✭
edited March 19 in General questions

hello there

I cannot use teamviewer anymore on Mac OS High Sierra :( such a shame

Which version of teamviewer to use? Teamviewer not working anymore on this OS

I tried everything, uninstall, install again, change versions, etc.


Nothing works :( still not able to use teamviewer

Comments

  • Valeria2
    Valeria2 Posts: 544 Moderator
    Options

    Hello @marinajackson,

    Happy to see you again visiting our Community!

    We are sorry to hear about the difficulties in the operation of TeamViewer with your operating system, however we have good news for you:

    The TeamViewer version compatible with Mac OS High Sierra is version 15.2, as you can see in the following image:

    You can download the right version from this link:

    📃Sunsetting active support of macOS 10.11 and macOS 10.12

    For details on compatibility between TeamViewer and other operating systems please click here.

    We hope this information will help you and in case of doubt please don´t hesitate to contact us.

    Have a nice day!

    Valeria

    Spanish Community Moderator

    Moderadora de la Comunidad en Español