TeamViewer 13 in Debian 8

Options

Note say: System requirements

TeamViewer Host for Linux requires at least Qt 5.2, Kernel 2.6.27 and GLIBC 2.17. Therefore, the following operating systems are supported:

  • Debian 8 (incl. Raspbian)
  • Ubuntu 14.04, Ubuntu 16.04 and derivates (e.g. Kubuntu).
  • CentOS 7, Fedora 26
  • openSuse 42

well:

dpkg -i teamviewer_13.0.5494_amd64.deb

dpkg: problemas de dependencias impiden la configuración de teamviewer:
teamviewer depende de libqt5gui5 (>= 5.5); sin embargo:
La versión de `libqt5gui5:amd64' en el sistema es 5.3.2+dfsg-4+deb8u2.
teamviewer depende de libqt5widgets5 (>= 5.5); sin embargo:
La versión de `libqt5widgets5:amd64' en el sistema es 5.3.2+dfsg-4+deb8u2.
teamviewer depende de libqt5qml5 (>= 5.5); sin embargo:
La versión de `libqt5qml5:amd64' en el sistema es 5.3.2-4.
teamviewer depende de libqt5quick5 (>= 5.5); sin embargo:
La versión de `libqt5quick5:amd64' en el sistema es 5.3.2-4.
teamviewer depende de libqt5dbus5 (>= 5.5); sin embargo:
La versión de `libqt5dbus5:amd64' en el sistema es 5.3.2+dfsg-4+deb8u2.
teamviewer depende de libqt5x11extras5 (>= 5.5); sin embargo:
La versión de `libqt5x11extras5:amd64' en el sistema es 5.3.2-2.
teamviewer depende de qtdeclarative5-qtquick2-plugin (>= 5.5) | qml-module-qtquick2 (>= 5.5); sin embargo:
El paquete `qtdeclarative5-qtquick2-plugin' no está instalado.

then: teamviewer 13 is for Debian 9 ( Stretch)

Comments

  • DanielStm
    DanielStm Posts: 224 Staff member 🤠
    Options

    Hi cracapedro,

    as you can see, the specification is for TeamViewer Host, which is still on Qt 5.2.
    Unfortunately we did not have time to update the requirements and installation notes.
    It's on my ToDo list :)

    On Debian 8, please see my other answer.

    Linux Developer
  • jflambert
    jflambert Posts: 5 ✭✭
    Options

    Yup I'm facing the same problem with Ubuntu 14.04 (Qt 5.5 is required)

    So you can also say that TeamViewer 13 no longer supports Ubuntu 14.04. This support page is outdated. I will stick to TeamViewer 12 because I'm not going to upgrade my operating systems for this tool.

  • DanielStm
    DanielStm Posts: 224 Staff member 🤠
    Options

    True. So...

    On Debian 8, and Ubuntu 14.04 please see my other answer.

    Linux Developer
  • allan225
    allan225 Posts: 1
    Options

    rum sudo apt-get install -f to solve the porblem

  • DanielStm
    DanielStm Posts: 224 Staff member 🤠
    Options

    @caracapedro, @jflambert, @allan225

    Please have a look at the update with limited Debian 8 support:
    [Update: 13.0.6634] Christmas Update

    Linux Developer