High CPU usage when TV 13 hosted on Linux Mint

Options
ghczzz
ghczzz Posts: 2 ✭✭

I installed "TeamViewer Host for Linux: 13.0.5641" on "Linux Mint 18.2 with Xfce", when I connect it from my Windows, I found the host keep high CPU usage. But this only come out with blinked TeamViewer icon. When collapse the TeamViewer panel on the right edge of screen, the TeamViewer icon on the panel tab begin blink, and CPU usage got to high. When the TeamViewer panel is expanded or mouse hover on the panel tab while panel collapsed, there is no blinked TeamViewer icon, and the CPU usage got back to normal. Would you please check if this can be reproduced on you side, thanks!

1.png2.png

Best Answer

Answers

  • ghczzz
    ghczzz Posts: 2 ✭✭
    Options

    Thanks for your reply.

    I install "kubuntu-16.04.3-desktop-amd64" on VBox just now, there is same issue. For my orginal post, I installed Linux Mint on VBox and a real computer, both got high CPU usage. May this issue associated with special hardware and driver.

    But this is not a big deal, I can use TV12 for now, it work well with my Linux Mint. Thank you.

  • mikeul
    mikeul Posts: 1
    Options

    HI, same problem on my configuration Linux Mint 18.3 with TV 13.0.6634. :s bad news i have to downgrade to TV12...

     

  • Xenobiot
    Xenobiot Posts: 2 ✭✭
    Options

    Same problem on Gentoo x64.

    Teamviewer_Desktop + teamviewerd = 15%. If nothing mooving or in idle.

    If any windows movements -> 70%

    CPU i5-4430.

    TeamViewer12 was around 1% in idle. Also TV12 did some video artifacts. TV13 - no artifacts, but high cpu%.

    My list of installed qt packages:

    Spoiler
    PyQt4-4.12.1
    eselect-qtgraphicssystem-1.1.1
    qttest-5.7.1
    qtdbus-5.7.1
    qtgui-4.8.7
    qtopengl-5.7.1
    qtgui-5.7.1-r1
    qtsvg-4.8.7
    qtnetwork-5.7.1
    qtscript-4.8.7
    qtquickcontrols-5.7.1
    qtsql-5.7.1-r1
    qtopengl-4.8.7
    qtdeclarative-5.7.1-r1
    qtxml-5.7.1
    qtlockedfile-2.4.1_p20150629
    qtconcurrent-5.7.1
    qtdbus-4.8.7
    qttranslations-4.8.7
    qtwidgets-5.7.1
    qtwebkit-5.7.1
    qtcore-5.7.1-r3
    qtchooser-0_p20151008
    qtx11extras-5.7.1
    linguist-tools-5.7.1
    qtsingleapplication-2.6.1_p20150629
    qtcore-4.8.7-r3

    Memory maps showing, that Teamviewer 13 using only qt5 libs.

    Problem:

    localhost ~/Desktop # ps aux | grep Team
    root 1434 grep --colour=auto Team
    root 8221 /opt/teamviewer/tv_bin/TeamViewer
    root 11151 /opt/teamviewer/tv_bin/TeamViewer_Desktop
    localhost ~/Desktop # strace -c -p 11151
    strace: Process 11151 attached
    ^Cstrace: Process 11151 detached
    % time seconds usecs/call calls errors syscall
    ------ ----------- ----------- --------- --------- ----------------
    99.81 0.578409 449 1289 644 futex
    0.19 0.001100 2 645 select
    0.00 0.000000 0 1 1 restart_syscall
    ------ ----------- ----------- --------- --------- ----------------
    100.00 0.579509 1935 645 total

    Also, "strace -p 11151" showing megatons of this:

    Spoiler
    restart_syscall(<... resuming interrupted futex ...>) = -1 ETIMEDOUT (Connection timed out)
    futex(0x2926278, FUTEX_WAKE_PRIVATE, 1) = 0
    select(18, [17], NULL, NULL, {tv_sec=0, tv_usec=0}) = 0 (Timeout)
    futex(0x29262c8, FUTEX_WAIT_BITSET_PRIVATE|FUTEX_CLOCK_REALTIME, 0, {tv_sec=1518267842, tv_nsec=801947000}, 0xffffffff) = -1 ETIMEDOUT (Connection timed out)
    futex(0x2926278, FUTEX_WAKE_PRIVATE, 1) = 0
    select(18, [17], NULL, NULL, {tv_sec=0, tv_usec=0}) = 0 (Timeout)
    futex(0x29262c8, FUTEX_WAIT_BITSET_PRIVATE|FUTEX_CLOCK_REALTIME, 0, {tv_sec=1518267842, tv_nsec=812294000}, 0xffffffff) = -1 ETIMEDOUT (Connection timed out)
    futex(0x2926278, FUTEX_WAKE_PRIVATE, 1) = 0
    select(18, [17], NULL, NULL, {tv_sec=0, tv_usec=0}) = 0 (Timeout)
    futex(0x29262c8, FUTEX_WAIT_BITSET_PRIVATE|FUTEX_CLOCK_REALTIME, 0, {tv_sec=1518267842, tv_nsec=822625000}, 0xffffffff) = -1 ETIMEDOUT (Connection timed out)
    futex(0x2926278, FUTEX_WAKE_PRIVATE, 1) = 0
    select(18, [17], NULL, NULL, {tv_sec=0, tv_usec=0}) = 0 (Timeout)
    futex(0x29262c8, FUTEX_WAIT_BITSET_PRIVATE|FUTEX_CLOCK_REALTIME, 0, {tv_sec=1518267842, tv_nsec=832991000}, 0xffffffff) = -1 ETIMEDOUT (Connection timed out)
    futex(0x2926278, FUTEX_WAKE_PRIVATE, 1) = 0
    select(18, [17], NULL, NULL, {tv_sec=0, tv_usec=0}) = 0 (Timeout)
    futex(0x29262c8, FUTEX_WAIT_BITSET_PRIVATE|FUTEX_CLOCK_REALTIME, 0, {tv_sec=1518267842, tv_nsec=843223000}, 0xffffffff) = -1 ETIMEDOUT (Connection timed out)
    futex(0x2926278, FUTEX_WAKE_PRIVATE, 1) = 0
    select(18, [17], NULL, NULL, {tv_sec=0, tv_usec=0}) = 0 (Timeout)

     

  • izll
    izll Posts: 3 ✭✭
    Options

    Hi,

    Same problem in Xubuntu 16.04, because the teamviewer icon is flashing if I compact the info panel. If the info panel not compacted, cpu usage is minimal.

    Any suggestion, how can I disable icon flashing?

    Thanks

  • edmarcio
    edmarcio Posts: 1
    Options

    Same is happening with Peppermint Eight default install.

    - Icon blinking on the side of desktop: 50% CPU
    - Mouse over the icon blinking: 5% CPU
    - Expanded tab (no icon): 5% CPU

    The issue is that expanded uses too much desktop... I want to have the icon on side with normal CPU usage.